M: Black Screen in a Develop Module

New Here ,
Mar 24, 2019

Copy link to clipboard

Copied

I'm new to LR.  When I installed it and imported some images into LR I can see them in the Library module.  When I select an image in the Library module and hit D or go to the Develop module, all I get is a black (not blank) screen.

 

I'm sure I switched some setting somewhere, but I don't know which one.

 

I'm using Windows 10, 64 bit.

 

Lightroom moderator (or anyone else), please help.

 

{Moderator note: Edited the thread title}

TOPICS
Performance

Views

14.8K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Adobe Employee , Jan 18, 2021
Mohit Goyal Adobe Employee , Jan 18, 2021
Hi all,   We're sorry for the black screen issue when going to the Develop Module. If you are seeing this issue with the latest version of Lightroom Classic then, you should check the minimum graphics card requirements for the latest Lightroom Classic app.   Here's the GPU FAQ: https://helpx.adobe.com/lightroom-classic/kb/lightroom-gpu-faq.html   If the installed graphics card doesn't meet the minimum system requirements then, turn it off from the Lightroom Classic preferences > Performance tab ...

Likes

Translate

Translate
Jump to answer Jump to answer
Most Valuable Participant ,
Mar 24, 2019

Copy link to clipboard

Copied

Turn off the graphics processor, force LR to use DirectX, and update your graphics driver directly from the manufacturer, as described in this article: Adobe Lightroom GPU Troubleshooting and FAQ

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Mar 24, 2019

Copy link to clipboard

Copied

Thanks so much, John.  Turning off the graphics processor seems to have solved the issue.  And I will go ahead and update my graplhics driver.

I'm wondering if you could please tell me, though, what forcing LR to use DirectX will do.

Thanks again.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Mar 24, 2019

Copy link to clipboard

Copied

My (imperfect) understanding of DirectX: Windows provides programs with a number of different ways to access the display. LR tries to choose the fastest method that's compatible with the Windows version and graphic drivers installed. But due to bugs in graphics drivers, LR doesn't always choose a reliable method. DirectX is usually the most reliable but not necessarily the fastest method. Forcing LR to use DirectX may work around bugs in the other methods exposed by the graphics drivers installed.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Contributor ,
Jan 12, 2021

Copy link to clipboard

Copied

This happened to me. I updated to the latest Nvidia Studio Driver to this date 1.12.21. Should this still be happening?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Feb 01, 2021

Copy link to clipboard

Copied

Hi there,

 

We're sorry for the trouble. Which Lightroom version do you have installed? Also, which Graphics card do you installed on the machine?

 

After updating to the latest Graphics drivers, does it resolve the problem for you?

 

Thanks,

Mohit

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Contributor ,
Feb 01, 2021

Copy link to clipboard

Copied

Nvidia 2080ti, two of them. 

 

Lightroom v9.4

 

I'm on the latest Nvidia Studio Driver, not the gaming/general driver. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Feb 02, 2021

Copy link to clipboard

Copied

Hi there,

 

Thanks for the update. Is there any specific reason that you are still using Lightroom Classic 9.4? You can update Lightroom to 10.1.1 via the Adobe Creative Cloud Desktop app.

 

Let us know if that helps.

Thanks,

Mohit

 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Oct 19, 2017

Copy link to clipboard

Copied

I just updated LR and I am having problems viewing/working my files in the Develop module.

When I chose a photo in Library and I go to the Develop Module I only see a Black.

The LR software and commands are visible but the frame with the image is completely black !

What is going on and what is the fix?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Oct 19, 2017

Copy link to clipboard

Copied

First suggestion-

Have you tried disabling the Graphics processor in Preferences? (and a restart)

ScreenShot470.jpg

 

Update:

Lightroom-Classic v8.4.1 now has a slightly different dialog with a drop-down menu for 'Use Graphics Processor'

ScreenShot378.jpg

Regards. My System: Lr-Classic 10.1.1, Photoshop 22.2, Lightroom 4.1, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Oct 19, 2017

Copy link to clipboard

Copied

Disabling the Graphics Processor did the trick for now.

Next question: What  version driver is compatible for my video card AMD R9 200 series.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Oct 19, 2017

Copy link to clipboard

Copied

Sorry, beyond my knowledge.

Refer to-  Photoshop graphics processor (GPU) card FAQ

Note here that R9 Series are "Tested Cards".

Ensure that you have the latest driver for your specific graphic processor installed.

Regards. My System: Lr-Classic 10.1.1, Photoshop 22.2, Lightroom 4.1, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Oct 19, 2017

Copy link to clipboard

Copied

I have the AMD R9 290 card but I was advised by Adobe not to upgrade to the newest driver because LR was having a conflict with LR 2017. With this new LR 2018, perhaps the latest AMD driver will work.

I guess there is only one real way to find out....I will update my video driver to the latest version and hopefully I won't encounter additional problems. I will post the results after the driver update.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Nov 23, 2017

Copy link to clipboard

Copied

This solves the problem only seemingly - by doing this, you're giving up GPU acceleration and going back to software acceleration only. There is a problem with GPU acceleration and it needs to be solved.

The black screen issue also happens to me. Latest available Lightroom Classic as of now running on a Windows 10 machine (Intel Core i7-5820K, 16 GB RAM @ 2400 MHz, Radeon HD6770 running latest CCC). Restarting Lightroom fixes the issue, but it usually appears again shortly after that.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Nov 23, 2017

Copy link to clipboard

Copied

I have read many forum posts that suggest that the GPU option in Lr preferences favors primarily large 4K, 5K monitors. Unless you have such a monitor, using GPU 'acceleration' may not make much noticeable difference.

See the help page-

Adobe Lightroom GPU Troubleshooting and FAQ

Regards. My System: Lr-Classic 10.1.1, Photoshop 22.2, Lightroom 4.1, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Nov 24, 2017

Copy link to clipboard

Copied

I have to correct myself: GPU Scaling does NOT solve the bug. I have been lucky for some time but now I experience again black screens in the Develop module.

On my PC which is 4 years old there is a significant difference in performance.

Adobe should fix this bug - we are using a graphics card which is explicitly recommended by Adobe.

Thomas

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 12, 2017

Copy link to clipboard

Copied

Totally disagree with the statement that the GPU makes no difference unless you have a 4k or 5k monitor.  I have a 30" Dell that supports 12 bit internals but not 4k.  There is a HUGE difference in performance with GPU enabled vs. disabled.  And yes, I'm having the same blackout issue with by Radeon RX 470 GPU enabled.  And my system CPU is no slouch either.  I've got an i7 running overclocked at 4.3Ghz with 32GB of memory.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 22, 2017

Copy link to clipboard

Copied

Same problem here since I updated to CC Classic.

Windows 7 64bit

i7-4790K

RX480 8GB

Radeon firmware 17.11.4 + 17.12.1 + 17.12.2 all failed

Works fine before the update to Classic. Switching off the use of GPU is obviously no solution. It slows the develop module down very much, also in 1920px resolution.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Aug 01, 2018

Copy link to clipboard

Copied

YMMV, but I had a 1680*1050 screen as my main screen before and even then there was a noticeable difference between hardware and software acceleration.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jul 10, 2019

Copy link to clipboard

Copied

Thank you!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 19, 2017

Copy link to clipboard

Copied

HI all,

I have the same problem everything is working but I get a grey screen when I go into the develop module.

Can I please have some more defined instructions in how to fix this problem as I'm not a computer expert

cheers Brenden

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Oct 19, 2017

Copy link to clipboard

Copied

Choose the Lightroom preferences from the menu. In the Lightroom preferences go to the performance tab. There is a checkbox there to enable the graphics processor unit. Make sure there is NOT a checkmark in that checkbox. That is the usual fix for the problem you are encountering.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Oct 19, 2017

Copy link to clipboard

Copied

I just finished installing the latest video driver 17.7.2 for the AMD Radeon R9 200 series.

Restarted Win7 64 bit,

Restarted LR...changed Preference settings and activated GPU Processor.

Shut down and restarted LR....Everything works.

LR runs much slower than before and there appears to be a response lag. I think that this version is utilizing much more CPU/ RAM resources than the previous version of LR.

Will continue working with LR and post any other bugs that I may encounter.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Nov 04, 2017

Copy link to clipboard

Copied

The Disabling of the graphics processor fixes the missing image problem, but then creates the new problem of the image taking forever to render when zooming in. The image is all pixelated when you zoom in to it to work. Is there an actual fix for this problem that doesn't create that new problem?

Also using the recommended AMD Radeon R9 2000

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Nov 10, 2017

Copy link to clipboard

Copied

Had the same issue and solved it by enabling GPU Scaling.

As my AMD utilities are in German I'm not sure my translation of their settings is correct:

Open AMD Settings, navigate to "Monitor" ("Anzeige" in German) and enable "GPU-Scaling".

Normally this setting should not be required but it seems it solves the issue.

My Develop module does not show black screens anymore and it is much faster than disabling hw acceleration in LR.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more