Highlighted

M: Open as layer not working from Lightroom Classic to Photoshop

New Here ,
Jun 17, 2020

Copy link to clipboard

Copied

I edit about 30 images per day by selecting the below command, within Lightroom Classic (recently updated):

 

PHOTO > EDIT IN > OPEN AS LAYERS IN PHOTOSHOP (also recently updated)

 

But after the most recent update of PS and LrC I have lost this ability.  If I select 5 images in LrC and try to do the above, only about 1-2 images appear in my layered PS file as a layer, then a blank "LOAD LAYERS" layer appears (see attahed) and one more image will open in a seperate PS file and not a part of the layered file - then the import quits.

 

After I am done editing the layered file and when I save it - it will automatically save and load the modified layerd file in LrC - which it does not do anymore.

 

Obviously the only work around is for me to copy and past each layer individally and then manually save the file and import into my LrC catalog - which makes the process of editing images very inefficient when doing dozens of these edits per day.

 

I'm on a Macbook Pro, latest install of LrC and PS / Catalina - again, I have edited hundreds of images prior to the updates and never had an issue so obviously it have soemthing to do with the update, at least for me.

 

andrew

 

{Moderator Note: Edited the thread title, LRD-4204498}

TOPICS
Bug, Import and export, Mac, Problem or error

Views

380

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

M: Open as layer not working from Lightroom Classic to Photoshop

New Here ,
Jun 17, 2020

Copy link to clipboard

Copied

I edit about 30 images per day by selecting the below command, within Lightroom Classic (recently updated):

 

PHOTO > EDIT IN > OPEN AS LAYERS IN PHOTOSHOP (also recently updated)

 

But after the most recent update of PS and LrC I have lost this ability.  If I select 5 images in LrC and try to do the above, only about 1-2 images appear in my layered PS file as a layer, then a blank "LOAD LAYERS" layer appears (see attahed) and one more image will open in a seperate PS file and not a part of the layered file - then the import quits.

 

After I am done editing the layered file and when I save it - it will automatically save and load the modified layerd file in LrC - which it does not do anymore.

 

Obviously the only work around is for me to copy and past each layer individally and then manually save the file and import into my LrC catalog - which makes the process of editing images very inefficient when doing dozens of these edits per day.

 

I'm on a Macbook Pro, latest install of LrC and PS / Catalina - again, I have edited hundreds of images prior to the updates and never had an issue so obviously it have soemthing to do with the update, at least for me.

 

andrew

 

{Moderator Note: Edited the thread title, LRD-4204498}

TOPICS
Bug, Import and export, Mac, Problem or error

Views

381

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 17, 2020 0
Most Valuable Participant ,
Jun 17, 2020

Copy link to clipboard

Copied

I just did a quick test with my LR 9.3 / Mac OS 10.15.5, and Open As Layers In Photoshop correctly opened the 10 selected photos as layers. I suggest you post a bug report in the official Adobe feedback forum, where Adobe wants all bug reports and feature suggestions: 
https://feedback.photoshop.com/photoshop_family/categories/photoshop_family_photoshop_lightroom

Be sure to include the first ten lines of the menu command Help > System Info for both LR and PS.  Provide all the details, rather than linking back to this thread -- experience shows that Adobe developers tend not to follow the links.

 

[Use the blue reply button under the first post to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2020 0
New Here ,
Jun 18, 2020

Copy link to clipboard

Copied

I had the same issue and after extensive uninstall and the like, I had to remove the lastest PS and installed the previous one and the previous PS works fine.  I will wait for a bug fix.  I use Windows 10 with the latest feature update.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2020 0
Most Valuable Participant ,
Jun 18, 2020

Copy link to clipboard

Copied

Andrew filed a bug report here:

https://feedback.photoshop.com/photoshop_family/topics/-open-as-layers-in-photoshop-function-in-ligh...

 

In response, Adobe suggested resetting both LR's and PS's preferences. I suggest you try that and post whether or not that helped on that bug report's thread (not here).

 

Unless others me-too that bug report with more details, I think it's unlikely that Adobe will take any action, since (as of now) they don't appear to have a way to reproduce the problem.

 

[Use the blue reply button under the first post to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2020 0
LEGEND ,
Jun 18, 2020

Copy link to clipboard

Copied

I tried this 10 times with 10 photos and it worked correctly 9 times.  One time it loaded 4 files in layers with the blank "Load Layers" and then a fifth one loaded in a separate Window.  The other 5 did not load.  

 

This is better odds than another long term bug of doing Edit In Photoshop for 10 files where doing it 10 times it fails on 3 or 4 times to load them all.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2020 0
New Here ,
Jun 26, 2020

Copy link to clipboard

Copied

Just upgraded to the latest versions of Lightroom Classic (9.3) and Photoshop (21.2). In LrC, Photo > Edit In > Open as Layers in Photoshop... opens some number of layers then stops. As the number of layers varies, I suspect it's a resource issue but can't identify what may be limited. Running MacOS 10.14.6 (Mojave) on a 2017 iMac Pro with 32GB RAM and several large drives available for scratch space.

I have seen this problem discussed for older versions, but not the latest updates.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2020 0
LEGEND ,
Jun 26, 2020

Copy link to clipboard

Copied

This issue has been reported several times since 9.3 was released. I did a test awhile back when this was first reported I tested 10 photos 10 times and it worked correctly 9 out of 10 times.

 

 

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2020 0
Most Valuable Participant ,
Jun 26, 2020

Copy link to clipboard

Copied

To build on Bob's reply, here's the bug report:

https://feedback.photoshop.com/photoshop_family/topics/-open-as-layers-in-photoshop-function-in-ligh...

 

Please add your constructive opinion to the bug report, and be sure to click Me Too and Follow in the upper-right corner. That will make it a little more likely that Adobe will prioritize a fix, and you'll be notified when the bug's status changes. A number of people have reported these symptoms with 9.3, but so far no one else has Me Too-ed the bug report. Even though it's marked In Progress, meaning an internal bug report has been filed with the development team, that doesn't mean it will get prioritized, so the more votes the better.

 

[Use the blue reply button under the first post to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2020 0
New Here ,
Aug 11, 2020

Copy link to clipboard

Copied

When I select multiple files and choose "Open as Layers in Photoshop" it opens up the files in separate tabs in Photoshop instead of layering them in one tab. If I restart my macbook it will work as normal first try and then the next time it will open in separate tabs again. Help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 11, 2020 0
Adobe Employee ,
Aug 11, 2020

Copy link to clipboard

Copied

Hi,

 

We're sorry about the trouble with Photoshop while opening images as layers from Lightroom. Would you mind sharing the versions of Lightroom Classic and Photoshop you are using along with your computers operating system?

 

Have you tried re-installing the apps to check if that helps? If not, please try that and let us know if the issue persists.

You can also check the suggestions here: https://feedback.photoshop.com/photoshop_family/topics/edit-in-open-as-layers-in-photoshop-not-worki...

 

Regards,

Nikunj

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 11, 2020 1
New Here ,
Aug 11, 2020

Copy link to clipboard

Copied

Photoshop is version 21.2.1 and Lightroom Classic is version 9.3. My mac OS is Catalina 10.15.6. I have not tried re-installing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 11, 2020 0
New Here ,
Aug 12, 2020

Copy link to clipboard

Copied

I have now uninstalled and reinstalled both LR and PS and it is still happening!!! This is very frustrating. I'm now having to pay a 3rd party to edit my photos for me. Please someone help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 12, 2020 0
New Here ,
Aug 12, 2020

Copy link to clipboard

Copied

Ok I have now tried downgrading to the previous version of Camera Raw like the gentleman in that link suggested and it still did not fix it! Can I go back to the previous version of LR and PS somehow to see if that helps? This is completely putting a halt to my workflow and my clients are waiting on their photos!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 12, 2020 0
New Here ,
Aug 12, 2020

Copy link to clipboard

Copied

Welp I figured out how to go back to previous version of both LR and PS and that didn't fix it either.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 12, 2020 0
Adobe Employee ,
Aug 21, 2020

Copy link to clipboard

Copied

Hi Patrick,

 

We're sorry for all the trouble. It's known issues with Lightroom Classic. Our engineering team is investigating a fix. Here's the feedback link for the latest updates on this issue: https://feedback.photoshop.com/photoshop_family/topics/-open-as-layers-in-photoshop-function-in-ligh...

 

Check all the suggestions and workarounds suggested by Adobe and other users on the above thread and do add your vote as well.

 

Thanks,

Mohit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 21, 2020 0
New Here ,
Sep 21, 2020

Copy link to clipboard

Copied

Im having this problem.

 

Photoshop opens and when it finally stops the import i am left with the two files separately loaded and two layers, one of which is one of the layers and the other is labelled Load Layers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 21, 2020 0
LEGEND ,
Sep 22, 2020

Copy link to clipboard

Copied

Could you please post screenshots to illustrate the issue? 

How many images do you select, what file formats, are you suing the Script »Load Files into Stack«, …? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 1
Adobe Community Professional ,
Sep 22, 2020

Copy link to clipboard

Copied

Can you also describe steps involved in process?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 2
New Here ,
Sep 22, 2020

Copy link to clipboard

Copied

Hi, I'm sorry for not detailing.

 

when in lightroom, I select 2 or more images then use the "`OPEN AS LAYERS IN PHOTOSHOP". Photoshop will attempt to load it in layers however there are times that it will load all the images in layers. Kindly check the image attached for better understanding. Thank you so much for your response. I'll screen record when I encounter it again. Screen Shot 2020-09-22 at 6.52.04 PM.pngScreen Shot 2020-09-22 at 6.52.28 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 0
New Here ,
Sep 22, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 0
Adobe Community Professional ,
Sep 22, 2020

Copy link to clipboard

Copied

All images must be open in the same document. Script is failing but I can not tell you why. The process is similar to what you see in your app with small difference on your side: Photoshop is failing to move image open in separate tab to document with two layers or images already open. 

 

Try to post on Photoshop family https://feedback.photoshop.com/, report bug and ask for help there because Adobe engineers are monitoring that site while this site is user to user.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 0
New Here ,
Sep 22, 2020

Copy link to clipboard

Copied

Thank you. But the images are not yet opened. What you see is the result of the attempt to open layers in photoshop.

Thanks, I'll post there. `Thanks alot.

 

By the way, I noticed something.

 

1. This problem happens when one of the selected image was not "lens corrected" as for the other images selected.

2. When browser or whatsapp or other non adobe products are open.

 

Kind a wierd, but that's my observation.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 0
New Here ,
Sep 27, 2020

Copy link to clipboard

Copied

With the new Photoshop 2020 if I press "Open as layer in photoshop" from Lightroom Classic it fails one time on tre. I mean that it open files as many singole file in PS. How to resolve it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2020 0
Adobe Employee ,
Sep 29, 2020

Copy link to clipboard

Copied

Hi there,

 

Sorry that the "Open as layers in Photoshop" is not working when you open an image from Lightroom Classic

 

Have you updated to the recent update of Photoshop 2020 version 21.2.4? See https://helpx.adobe.com/photoshop/kb/uptodate.html 

 

Could you please take a look at this discussion Lightroom: 'Open as Layers' in Photoshop doesn't work | Photoshop Family Customer Community  and let us know if that helps?

 

Thanks,

Akash

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 29, 2020 0
Community Beginner ,
Oct 04, 2020

Copy link to clipboard

Copied

I am STILL having this problem, and it is absolutely crippling my ability to get my work out. I have reinstalled LRC and PS and deleted my PS prefs. No change. 

 

I have found that if I quit photoshop, I have about a 40% change that PS will complete the work (open as layers) when I try to use 'open as layers' from LRC. If I do not quit PS first, the odds are about 5% it will work.

 

All files are RAW files. That is all I use. 

 

Also, when I try to 'open as layers' from LRC, PS seems to 'hang' at breaks in source file number continuity. I.E. when files are continuous 1,2,3,4,5,6 etc it opens OK nearly every time, even if I do not restart PS. 

 

However, if there are skips in the selected files (I.E. select files 1,2,4,5,6) then it will get derailed when it has to 'skip' file 3. 

 

The above are the only two 'patterns' I've noticed with this bug, which I have been contending with for several months now. It is beyond infuriating. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 0
Most Valuable Participant ,
Oct 04, 2020

Copy link to clipboard

Copied

Adobe product developers don't participate in this forum and won't see your feedback. Please add your details to the existing bug report:

https://feedback.photoshop.com/conversations/camera-raw-and-dng/lightroom-classic-open-as-layers-in-... 

 

and be sure to click Like and Follow at the bottom of the first post. That will make it a little more likely that Adobe will prioritize a fix, and you'll be notified when the bug's status changes.  Adobe has marked the bug report "acknowledged", but they rarely give indications as to when bugs will be fixed. 

 

While waiting for a bug fix, see this reply for a less-convenient workaround:

https://feedback.photoshop.com/conversations/camera-raw-and-dng/lightroom-classic-open-as-layers-in-...

 

[Use the blue reply button under the first post to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 0
Adobe Employee ,
Oct 09, 2020

Copy link to clipboard

Copied

Hi there,

 

We're sorry for the open as layer isn't working properly from Lightroom Classic to Photoshop. This is a known issue with Lightroom Classic and our engineering team working on the fix.

 

You can refer to the following feedback link for all the future updates on this issue, also you can add your vote to it as well: https://feedback.photoshop.com/conversations/camera-raw-and-dng/lightroom-classic-open-as-layers-in-...

 

For now, you can initiate the stack from Photoshop. Here's how you can do image stack in Photoshop: https://helpx.adobe.com/in/photoshop/using/image-stacks.html

 

Thanks,

Mohit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2020 0
Community Beginner ,
Oct 13, 2020

Copy link to clipboard

Copied

I am having exactly the same problem. I have tried resetting preferences for both LR Classic and PS, which stops the problem for a short while and then it comes back. Also, it is very slow saving Tiff files from PS back to LR after editing. Don't know whether this is a related problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2020 0
New Here ,
Aug 21, 2020

Copy link to clipboard

Copied

I am currently having the same issues, trying to do focus stacking with between 15 to 30 images and have no luck on all attempts even trying smaller amounts of images, the images are  not loaded in order and random ones missing,only getting about 60-70% of selected images loaded and one image always loads on a separate tab. I am also working on Macbook pro - Catalina 10.15.6..I see there is a new upgrade Imight try that and see if there have been bug fixes...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 21, 2020 0
LEGEND ,
Aug 21, 2020

Copy link to clipboard

Copied

And this has what to do with LrC?

LrC does not have a Photo Merge Focus Stack.

 

Just another Adobe customer; My Sys; APP: LRC 10.0, PS 22.0; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.7; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 21, 2020 0
New Here ,
Aug 21, 2020

Copy link to clipboard

Copied

Thanks David, clearly you have not understood the issue, we are not sayig there is a problem with LrC as such just that there is a problem loading images from LrC to PS with 'Open as Layers in PS...

 

calm ya farm!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 21, 2020 0
Most Valuable Participant ,
Aug 21, 2020

Copy link to clipboard

Copied

"the images are  not loaded in order and random ones missing,only getting about 60-70% of selected images loaded and one image always loads on a separate tab."

 

As mentioned in a previous post, there is a bug report filed on this:

https://feedback.photoshop.com/photoshop_family/topics/-open-as-layers-in-photoshop-function-in-ligh... 

 

It is marked In Progress, which meabns Adobe is actively working on it. Usually that means a fix will come in the next release or two (there's a release every two months), but sometimes bugs stay In Progress for a very long time.

 

Please add your constructive opinion to the bug report, and be sure to click Me Too and Follow in the upper-right corner. That will make it a little more likely that Adobe will prioritize their efforts, and you'll be notified when the bug's status changes. (Safari users, uncheck the option Safari > Preferences > Privacy > Prevent Cross-Site Tracking or use Chrome or Firefox.)

 

[Use the blue reply button under the first post to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 21, 2020 1
Community Beginner ,
Oct 13, 2020

Copy link to clipboard

Copied

This bug substantially slows the workflow for those of us who routinely do layering with multiple images and have to work on lots of images this way. I would ask that Adobe give special priority to this over other bugs that might not be so fundamental to workflow. 

Also, Photoshop is now very slow saving Tiff files back to LR. Don't know if this is related or whether it is a LR or PS issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2020 0