Manually adding geotags in LR Classic 7.5 hardly works anymore

Community Beginner ,
Sep 01, 2018

Copy link to clipboard

Copied

I have a DSLR camera Sony A77 Mk II. It doesn't support GPS. Therefore I need to add the tags manually in LR maps mode. For 2 years this worked fine, but returning from my vacation with 700 photos, August 2018, it becomes ever more difficult to place the geotags on the map. For most (raw) photos I have to click about 5 times before it "catches", sometimes even 10 times. Now I have some tags that won't be placed at all.

I tried all 3 types of adding geotags: dragging photo(s) to a location, right click and select "Add GPS coordinates to selected photos", as well as control-click on a location when a photo or photos are selected. My OS is Windows 10, I do my Windows updates always (automatically), also for LR.

This is very annoying, I managed to tag 300 photos so far, but I still have 400 to go.

Any ideas how to remedy this? Thanks!

Most Valuable Participant
Correct answer by johnrellis | Most Valuable Participant

A number of people have reported problems with this -- see this bug report in the official Adobe feedback forum: Manually adding geotags in LR Classic 7.5 hardly works anymore . Please add details of your issue and copy/paste the first ten lines of the menu command Help > System Info. Be sure to click Me Too and Follow in the upper-right corner. This will make it a little more likely Adobe will prioritize a fix.

Views

576

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Manually adding geotags in LR Classic 7.5 hardly works anymore

Community Beginner ,
Sep 01, 2018

Copy link to clipboard

Copied

I have a DSLR camera Sony A77 Mk II. It doesn't support GPS. Therefore I need to add the tags manually in LR maps mode. For 2 years this worked fine, but returning from my vacation with 700 photos, August 2018, it becomes ever more difficult to place the geotags on the map. For most (raw) photos I have to click about 5 times before it "catches", sometimes even 10 times. Now I have some tags that won't be placed at all.

I tried all 3 types of adding geotags: dragging photo(s) to a location, right click and select "Add GPS coordinates to selected photos", as well as control-click on a location when a photo or photos are selected. My OS is Windows 10, I do my Windows updates always (automatically), also for LR.

This is very annoying, I managed to tag 300 photos so far, but I still have 400 to go.

Any ideas how to remedy this? Thanks!

Most Valuable Participant
Correct answer by johnrellis | Most Valuable Participant

A number of people have reported problems with this -- see this bug report in the official Adobe feedback forum: Manually adding geotags in LR Classic 7.5 hardly works anymore . Please add details of your issue and copy/paste the first ten lines of the menu command Help > System Info. Be sure to click Me Too and Follow in the upper-right corner. This will make it a little more likely Adobe will prioritize a fix.

Views

577

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 01, 2018 2
Most Valuable Participant ,
Sep 01, 2018

Copy link to clipboard

Copied

A number of people have reported problems with this -- see this bug report in the official Adobe feedback forum: Manually adding geotags in LR Classic 7.5 hardly works anymore . Please add details of your issue and copy/paste the first ten lines of the menu command Help > System Info. Be sure to click Me Too and Follow in the upper-right corner. This will make it a little more likely Adobe will prioritize a fix.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 01, 2018 0
New Here ,
Sep 02, 2018

Copy link to clipboard

Copied

I have had the same problen since the last update. Concerns all my cameras and all picture formats I have: dng (converted from Sony or

Canon RAW files) and JPG.

Usually I use Sports Tracker with my phone and attach the data in LR. That works still fine, sometimes however I use LR Map module

manually to add GPS-data, (or correct the sometimes inaccurate Sports Tracker data), and that works just so badly as joopvde said.

By the way, what an whewre is "official Adobe feedback forum"?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 02, 2018 0
Most Valuable Participant ,
Sep 02, 2018

Copy link to clipboard

Copied

What and where is "official Adobe feedback forum"?

The feedback forum is where Adobe wants all product feedback posted -- bugs, feature requests, etc.  See this FAQ from the top of the Overview page of this forum for details: Which forum should I post to? (Feedback vs Forums) . Adobe product developers actively monitor and participate in the feedback forum but are rarely seen here, which is primarily a user-to-user forum with some low-level Adobe technical support.

Here is the correct link for the bug report on this thread's problem: Lightroom Classic: Placing photos on Map module erratic and slow since update LR Classic CC 7.5 (Win...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 02, 2018 0
Community Beginner ,
Sep 02, 2018

Copy link to clipboard

Copied

Thanks johnrellis for pointing me to the Adobe feedback forum. I will grant you the correct answer, although your link didn't help to find the right thread on the feedback forum (it is pointing to this thread itself...). I followed your advise to "Me too", follow the thread etc, and included my system info.

I don't consider the issue solved though. In the feedback forum there is no real solution. The only workable way seems to be to downgrade to LR 7.4, which I will do if this is not fixed within days.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 02, 2018 0
Most Valuable Participant ,
Sep 02, 2018

Copy link to clipboard

Copied

Sorry about the wrong link. The issue is definitely not solved, but Adobe has acknowledged it, which is a significant step.  New versions get released every 8 weeks on average, and Adobe almost never issues "emergency" releases except in the most severe circumstances. So you might consider rolling back if this is seriously affecting your workflow. 

Also, a lot of people use the Geoencoding Support plugin -- the author generally supports his plugins much better than Adobe supports LR.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 02, 2018 2
Community Beginner ,
Sep 02, 2018

Copy link to clipboard

Copied

Thanks John for suggesting the Geoencoding Support plugin! I was wondering if there wouldn't be some app adding geotags to photos from a map (e.g. on Google Earth). This app promises to do just that, even from inside LR. I will try it if Adobe will not fix the issue in the next upgrade. For manually pinpointing locations the plugin does seem to be a little less direct than the standard LR map functionality.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 02, 2018 0
Most Valuable Participant ,
Sep 02, 2018

Copy link to clipboard

Copied

On Windows, Geosetter is pretty popular (and free): https://www.geosetter.de/en/main-en/

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 02, 2018 0