Highlighted

ORF files not recognized as RAW

New Here ,
Jun 29, 2020

Copy link to clipboard

Copied

Setup:

LR classic 9.3 Camera Raw 12.3:

Windows 10

Olympus E-M10 (supported) with ORF raw files.

 

I shoot raw+jpeg. I imported these files into lightroom, they are listed in the library as .orf. I'd expect Adobe color profiles to show up (like vivid, natural etc) but the develop panel shows up as if they are jpegs. I changed the Lightroom setting to "treat jpeg files next to raw files as separate" and synchronized the folder but it didn't fix it.

 

When I open the same ORF files directly into photoshop 2020, camera raw doesn't show up, which is what I would expect to happen, it just loads the image like a jpeg. If I choose 'edit in.." with from LR to Photshop, I still don't see camera raw.

 

Are my expectations correct, and if so, how can I fix this? I'd prefer to avoid another converstion step for DNG or something into my workflow. Thanks.

Topics

Bug, Problem or error, Windows

Views

94

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

ORF files not recognized as RAW

New Here ,
Jun 29, 2020

Copy link to clipboard

Copied

Setup:

LR classic 9.3 Camera Raw 12.3:

Windows 10

Olympus E-M10 (supported) with ORF raw files.

 

I shoot raw+jpeg. I imported these files into lightroom, they are listed in the library as .orf. I'd expect Adobe color profiles to show up (like vivid, natural etc) but the develop panel shows up as if they are jpegs. I changed the Lightroom setting to "treat jpeg files next to raw files as separate" and synchronized the folder but it didn't fix it.

 

When I open the same ORF files directly into photoshop 2020, camera raw doesn't show up, which is what I would expect to happen, it just loads the image like a jpeg. If I choose 'edit in.." with from LR to Photshop, I still don't see camera raw.

 

Are my expectations correct, and if so, how can I fix this? I'd prefer to avoid another converstion step for DNG or something into my workflow. Thanks.

Topics

Bug, Problem or error, Windows

Views

95

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 29, 2020

Copy link to clipboard

Copied

You should see the Adobe profiles indeed. If you are not that's a bug. The files should be shown in Lightroom C as raw+jpeg. Synchronizing the folder afterwards will not separate the files if they were imported together before. The only way to separate them is to reimport them. I am quite puzzled by Photoshop opening the jpeg when you point it to the orf file. That should definitely not happen. If you use "Edit in" you will never see the camera raw dialog as the Lightroom settings are simply used in that case. Can you copy just the orf file into a different folder and open that in Photoshop directly?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 29, 2020

Copy link to clipboard

Copied

I tried copying the file to my desktop and opening it to no avail.

 

I found this thread: https://feedback.photoshop.com/photoshop_family/topics/lightroom-classic-presets-missing-after-9-3-u...

 

Does it mean anything that I cannot select a camera from that dropdown in either LR 9.21 or 9.3? I can't even tell if this is a LR problem or a camera raw problem.

 

image.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jun 29, 2020

Copy link to clipboard

Copied

About that screenshot.

 

So LrC has received a change allowing for more flexibility and more automation during import.

 

See the following article on that:

 

https://lightroomkillertips.com/customizing-camera-raw-defaults-in-lightroom-classic/

 

oh, and:

https://community.adobe.com/t5/lightroom-classic/lightroom-classic-set-defaults-for-raw-file-import/...

 

Should not be what is going oddly for you.

 

 

Just another Adobe customer; My Sys; APP: LRC 9.3, PS 21.2.1; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.6; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jun 29, 2020

Copy link to clipboard

Copied

When I open the same ORF files directly into photoshop 2020, camera raw doesn't show up, which is what I would expect to happen, it just loads the image like a jpeg.

 

By that statement, do you mean that you start PS, not LrC, and from PS you open a RAW file?

 

Just another Adobe customer; My Sys; APP: LRC 9.3, PS 21.2.1; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.6; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jun 29, 2020

Copy link to clipboard

Copied

If I choose 'edit in.." with from LR to Photshop, I still don't see camera raw.

 

When the version of Camera RAW internal to your copy of LrC, and the Adobe Camera RAW plugin that PS uses match, then this is expected behavor. The RAW file was converted via LrC so PS has no need to bring up Adobe Camera RAW.

 

 

Just another Adobe customer; My Sys; APP: LRC 9.3, PS 21.2.1; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.6; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jun 29, 2020

Copy link to clipboard

Copied

Inquiry, Develop module, lower right, Process version. V 5 or later, correct?

 

Just another Adobe customer; My Sys; APP: LRC 9.3, PS 21.2.1; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.6; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jun 29, 2020

Copy link to clipboard

Copied

Inquiry, Develop module, upper right. Profile. Perhaps saying Color? What if you change that, perhaps to a camera matching profile?

 

How about a screenshot

 

 

Just another Adobe customer; My Sys; APP: LRC 9.3, PS 21.2.1; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.6; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 29, 2020

Copy link to clipboard

Copied

Thanks.

 

Yes, if I open the .orf file directly in photoshop, I expect camera raw to show up, but it does not. Photoshop opens the orf file directly as if it is a jpeg. Good to know that camera raw wouldn't need to come up again while using 'edit in,' from lightroom, however lightroom isn't seeing it as RAW in the first place.

 

Yes the image is process V5.

 

My profile dropdown only includes Color, Monochrome, and Browse. Ther is no camera matching profile, unless I'm misunderstanding (which is possible).

 

I found this so I am going to roll back to 9.2.1 and see if that helps first. https://feedback.photoshop.com/photoshop_family/topics/lightroom-classic-presets-missing-after-9-3-u...

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 29, 2020

Copy link to clipboard

Copied

Can you post one of the offending files (just put it on dropbox or similar and post the link)?

 

Have you tried making a copy in a different place that doesn't have the jpeg next to it and opening that in Photoshop?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 29, 2020

Copy link to clipboard

Copied

Ok, I think I'm close now.

 

I use a utility so that I can incorporate google photos into my workflow (google broke the photos to drive sync a while back so an indie dev wrote a python script for it).

 

If I take an ORF right off my camera and import it into LR, it works fine. (still doesn't address the raw preset bug but I think that's different. However, all of these offending files were uploaded to Google photos, then synced to my machine via python/google api. On google photos they retain metadata, but after the python sync it is all removed except dimensions/size. I think this has to do with my issue, so I will dig into the code to see what's happening during sync.

 

False alarm, I guess. thanks so much for the help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...