Photo in develop module flashes black in Lightroom Classic 10.1.1 on Windows 10

Community Beginner ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

Hi, I run Lightroom Classic v10.1.1 on Windows 10 using an Nvidia RTX 2070 Ti (latest drivers).

 

Since I think v10.1 I have very annoying behavior: when moving around sliders in the develop module or just zooming in or out, there is a short black flash in the photo display box. It's probably only 1 frame long on my 60 Hz monitor. The black flash does not happen on every operation on the photo but often enough that it's really annoying and it also starts to hurt my eyes after a while.

 

I tried to take a video of it using my phone: https://photos.app.goo.gl/MqdEn8Y4qJF61jM5A. You can see it for example when I zoom into the photo at the beginning of the video or when moving the first slider after zooming out again.

 

This issue started recently for me, maybe starting with v10.1, but maybe some other update broke Lightroom classic on my system.

 

Has anyone experienced something similar?

 

 

{Thread title edited by moderator}

TOPICS
Bug, Problem or error, Windows

Views

193

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct Answers

Adobe Employee , Jan 22, 2021 Jan 22, 2021
Hi,   We're sorry about the trouble with Lightroom Classic. Do you still experience the same behavior if you disable the option to Use Graphics Processor from Lightroom Classic by going to Preferences, then Performance? Please relaunch the application before testing. If you do not experience the same behavior, please try re-installing the graphics card drivers to check if that helps.   You can also try to reset the preferences of Lightroom using the steps mentioned here: https://adobe.ly/2JSym5e...

Likes

translate

Translate

Translate
Community Beginner , Feb 02, 2021 Feb 02, 2021
Solving this one for myself: Having experimented quite a bit, I finally solved this problem: G-Sync is to blame! I have a LG 28UD88 which is FreeSync capable. Nvidia supports G-Sync compatible mode for FreeSync monitors. I turned this setting on ages ago, since it helps when relaxing from photo editing by playing games  Unfortunately, the FreeSync implementation in the LG 27UD88 is less than stellar, I have had issues before, mostly flickering. I only came across this again since I enabled the ...

Likes

translate

Translate

Translate
Adobe Employee ,
Jan 22, 2021 Jan 22, 2021

Copy link to clipboard

Copied

Hi,

 

We're sorry about the trouble with Lightroom Classic. Do you still experience the same behavior if you disable the option to Use Graphics Processor from Lightroom Classic by going to Preferences, then Performance? Please relaunch the application before testing.

If you do not experience the same behavior, please try re-installing the graphics card drivers to check if that helps.

 

You can also try to reset the preferences of Lightroom using the steps mentioned here: https://adobe.ly/2JSym5e

Please backup your presets prior to resetting the preferences.

 

Let us know how it goes!

Regards,

Nikunj

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 22, 2021 Jan 22, 2021

Copy link to clipboard

Copied

Hi,

 

thanks for your reply. Checking the GPU acceleration was the right idea. I disabled it and the issue did go away. Unfortunately, Lightroom felt a lot less responsive, but that's expected.

 

I then switched from Nvidia' "Game ready" branch of drivers to their Studio drivers and re-enabedl GPU acceleration in Lightroom. This also fixed the issue.  So

 

Nvidia driver 461.09 ... black flashes

Nvidia driver 460.89 ... no flashes

 

Let's hope Nvidia finds and fixes the issue until they branch their next studio driver release (studio drivers are just snapshots of the game ready drivers with extended testing from my understanding).

 

Thanks for your support!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 26, 2021 Jan 26, 2021

Copy link to clipboard

Copied

Today I received an update for Nvidia's studio drivers, now they are at version 461.40.

Unfortunately, the issue has returned. I can now downgrade my drivers, but I am a bit worried I will be stuck with an old driver version now.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 29, 2021 Jan 29, 2021

Copy link to clipboard

Copied

Thanks for the info! This gives us some insights & a direction in which we can test things out. There may be something in the drivers not playing well with the application or vice versa.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2021 Feb 02, 2021

Copy link to clipboard

Copied

Solving this one for myself:

 

Having experimented quite a bit, I finally solved this problem: G-Sync is to blame!

 

I have a LG 28UD88 which is FreeSync capable. Nvidia supports G-Sync compatible mode for FreeSync monitors. I turned this setting on ages ago, since it helps when relaxing from photo editing by playing games 🙂

 

Unfortunately, the FreeSync implementation in the LG 27UD88 is less than stellar, I have had issues before, mostly flickering. I only came across this again since I enabled the G-Sync indicator in the Nvidia settings. All programs using G-Sync would have a small overlay that says that G-Sync is enabled. And...Lightroom also had this overlay in the develop module!

 

So I disabled G-Sync for Lightroom in the NVidia control panel and the flickering is gone!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines