Photos not loading in develop module, Lightroom slow in general

New Here ,
Nov 13, 2020

Copy link to clipboard

Copied

Hi everyone,

 

In the past few days Lightroom Classic has been running slower and slower and tonight it just won't load any photos in the Develop module. The photos are just blurry and the sliders and editing panels are all greyed out so I can't use them, and there's a loading sign at the bottom. However they seem to load fine in the Library module, but of course that doesn't do me any good if I need to edit and export them.

 

I have updated to Lightroom Classic v10 (the latest update) but that was after the issues started. I'm using a Macbook Pro that I bought earlier this year (the latest model) and I haven't yet updated it to Big Sur. The only thing I can think of is that I imported RAW files from my new Canon R5 into Lightroom for the first time just before this started so I'm thinking that might be what stuffed it up? They're CR3 files so different format to what I've used in the past. Could this be the problem? And is there any way this can be resolved if so? Nothing else has changed so I can't think of what else would've caused this...

 

Otherwise is there any other way to fix this? I've uninstalled and re-installed Lightroom Classic and I've rebooted my Macbook Pro. Going to update to Big Sur too in case that works.

 

Thanks in advance for any insights into how I can fix this. I'm getting desperate with my editing backing up while my computer is like this..

 

K

TOPICS
Mac, Performance, Problem or error

Views

31

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Photos not loading in develop module, Lightroom slow in general

New Here ,
Nov 13, 2020

Copy link to clipboard

Copied

Hi everyone,

 

In the past few days Lightroom Classic has been running slower and slower and tonight it just won't load any photos in the Develop module. The photos are just blurry and the sliders and editing panels are all greyed out so I can't use them, and there's a loading sign at the bottom. However they seem to load fine in the Library module, but of course that doesn't do me any good if I need to edit and export them.

 

I have updated to Lightroom Classic v10 (the latest update) but that was after the issues started. I'm using a Macbook Pro that I bought earlier this year (the latest model) and I haven't yet updated it to Big Sur. The only thing I can think of is that I imported RAW files from my new Canon R5 into Lightroom for the first time just before this started so I'm thinking that might be what stuffed it up? They're CR3 files so different format to what I've used in the past. Could this be the problem? And is there any way this can be resolved if so? Nothing else has changed so I can't think of what else would've caused this...

 

Otherwise is there any other way to fix this? I've uninstalled and re-installed Lightroom Classic and I've rebooted my Macbook Pro. Going to update to Big Sur too in case that works.

 

Thanks in advance for any insights into how I can fix this. I'm getting desperate with my editing backing up while my computer is like this..

 

K

TOPICS
Mac, Performance, Problem or error

Views

32

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 13, 2020 0
LEGEND ,
Nov 13, 2020

Copy link to clipboard

Copied

Please provide the following basic information:

 

Adobe Forum.png

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 13, 2020 0
GoldingD LATEST
LEGEND ,
Nov 13, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 13, 2020 0