Previews not updating after edit on Photoshop

Community Beginner ,
Jan 31, 2020

Copy link to clipboard

Copied

Hi guys, I was wondering if someone here could help me with this mini headache. 

I have an issue that when I edit photos from

lightroom classic on photoshop cc and saved back, the previews on Lightroom cc mobile doesn't update. On LR classic they are fine, but not on mobile. 

To make it more clear, this is my workflow: 


upload photos to Lightroom classic > creat collections and sync (with smart previews)  to Lightroom CC / mobile > on Lightroom classic I do "edit image in photoshop 2020" > finished editing on PS 2020 and saved back. 

 

On lightroom classic the previews are updated nicely, however on Lightroom CC mobile the new previews doesn't update. The old one remains. 

I have tried to delete smart preview and then creat them again via library but nothing. 

the only work around it's to delete the collection (or sync) > delete smart previews > creat smart previews > creat collection and sync over and over again everytime I edit in photoshop. 

I mean, it's a complete nightmare 😞 

Does anyone have this issue? 
thank you in advance and sorry for my English 🙂 

Adobe Community Professional
Correct answer by JohanElzenga | Adobe Community Professional

Do you use 'Edit in Potoshop' while you are in the synced collection? If you are not in the synced collection, then the returned Photoshop image will not be added to the synced collection and so you will still only have the original online.

TOPICS
Problem or error

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Previews not updating after edit on Photoshop

Community Beginner ,
Jan 31, 2020

Copy link to clipboard

Copied

Hi guys, I was wondering if someone here could help me with this mini headache. 

I have an issue that when I edit photos from

lightroom classic on photoshop cc and saved back, the previews on Lightroom cc mobile doesn't update. On LR classic they are fine, but not on mobile. 

To make it more clear, this is my workflow: 


upload photos to Lightroom classic > creat collections and sync (with smart previews)  to Lightroom CC / mobile > on Lightroom classic I do "edit image in photoshop 2020" > finished editing on PS 2020 and saved back. 

 

On lightroom classic the previews are updated nicely, however on Lightroom CC mobile the new previews doesn't update. The old one remains. 

I have tried to delete smart preview and then creat them again via library but nothing. 

the only work around it's to delete the collection (or sync) > delete smart previews > creat smart previews > creat collection and sync over and over again everytime I edit in photoshop. 

I mean, it's a complete nightmare 😞 

Does anyone have this issue? 
thank you in advance and sorry for my English 🙂 

Adobe Community Professional
Correct answer by JohanElzenga | Adobe Community Professional

Do you use 'Edit in Potoshop' while you are in the synced collection? If you are not in the synced collection, then the returned Photoshop image will not be added to the synced collection and so you will still only have the original online.

TOPICS
Problem or error

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 31, 2020 0
Adobe Community Professional ,
Jan 31, 2020

Copy link to clipboard

Copied

Do you use 'Edit in Potoshop' while you are in the synced collection? If you are not in the synced collection, then the returned Photoshop image will not be added to the synced collection and so you will still only have the original online.

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2020 2
Community Beginner ,
Jan 31, 2020

Copy link to clipboard

Copied

Hi Johan! 

thank you so much for this fast reply. 

and no 😞 I do "edit in photoshop" from the "album" and not from sync collection. 

gonna try your advice and see if that solves my lil workflow nightmare. 

Will let you know ASAP. Thank you again! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2020 0
Community Beginner ,
Feb 02, 2020

Copy link to clipboard

Copied

Hey Johan!

 

sorry for the late reply. 

so I have followed your advice and, sadly, still doesn't work.

 

before I followed your advice I did the following:

on lightroom classic: unsynch the collections and delete the photos from all sync > did the "rebuild sync"  > discard  the smart previews > created the collections again and sync them > edit one of the photos "edit in photoshop" to test  

 

but it didn't synch the changes 😞 

 

im not very technical with Lightroom classic so I'm not sure if there's something I'm missing. 

If you can, let me know other advice. Thanks in advance. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 02, 2020 0
Adobe Community Professional ,
Feb 02, 2020

Copy link to clipboard

Copied

Please show a screenshot of Lightroom Classic (your entire screen, don't cut off anything), showing the selected image just before you do 'Edit in Photoshop'. Then show a second screenshot of the result (in Lightroom Classic) after you have done editing in Photoshop.

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 02, 2020 0
Community Beginner ,
Feb 02, 2020

Copy link to clipboard

Copied

Heyyy! 

well... well... well... Lightroom decided to make me look like a fool this time 🙂 

 

while doing the screenshots, it actually worked! Just took awhile to synch. Very happy now. 

sorry for making you waste more time on this. And again thank you so so much for your help. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 02, 2020 0
Community Beginner ,
Mar 04, 2020

Copy link to clipboard

Copied


I am having exactly the same problem. My photos are not syncing with Lightroom Mobile after making adjustments in photoshop. I am making adjustments directly from the collection in Lightroom Classic (current version) and I'm adjusting the original image.  The adjustments appear in Lightroom, and Lightroom says it is syncing the image, but the changes are never actually synced.  The changes are not syncing in the cloud, so they are not reaching LR Mobile.

 

Does anyone have a solution for this?

 

thanks very much.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2020 1
Community Beginner ,
Mar 07, 2020

Copy link to clipboard

Copied

Hey!

 

so sorry for my late reply. 
In regard to the issue, I was following the advise of Johan and it actually worked for a bit

however, I'm back at square one. It is a nightmare for my work flow to be honest. 

Doesn't matter if I edit directly from the collection, if i delete the sync images and re-synch to update the previews etc. 

sometimes (more often than It needs to) the editions made on PS disappeared the moment i dare to do the slightest edit on Lightroom CC. 

I will need to reach out to adobe directly and post their reply. cause it's not the first time  I have experienced this issue.


let me know if you find another trick. 

Regards.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2020 1
New Here ,
Oct 05, 2020

Copy link to clipboard

Copied

Leonel,

 

Have you had any helpful feedback from Adobe on this issue yet? I'm having the exact same issue, which by the way doesn't only apply to the previews in LR web/mobile, but on the full size image as well. 

 

If you have had any news since this last post and would care to share the outcome, I'm sure that would be very much appreciated!

 

Many thanks,

Les

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 0
Adobe Community Professional ,
Oct 05, 2020

Copy link to clipboard

Copied

This is a user to user forum so the responses you receive here are usually from users like yourself. This thread is already marked as answered and it's not likely to receive the attention you would expect.

Create a new thread and describe your specific issue and particular details of the apps involved and Operating System quoting the specific version numbers.

See at this link a number of sync issues there.

https://feedback.photoshop.com/topics/lightroom-classic/5f5f2093785c1f1e6cc40872

 

 

Regards, Denis: System iMac mid-2015, 5K 27”, Ram 24GB, HDD 3TB, macOS 11.1, LrC 10.1 (>10.0), Lr 4.1, Ps 22.1, Pr 14.8.0; Camera OM-D E-M1.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 0
Community Beginner ,
Oct 06, 2020

Copy link to clipboard

Copied

Hi Les,

Unfortunately not, and i have tried everything advice
on this thread and the once i have researched on.

The comments about opening the photos from Sync collection directly into
photoshop CC and then saving back doesn't work for me. I also tried
deleting smart previews and creating them again, but no luck either.

The only thing that works is deleting the image from the collection and all
sync images and then sync again. But that is so much hassle and time
consuming.

Just to clarify, my issue is as follows:
My photos are stored on Lightroom Classic catalogue (originals on external
storage) > I create collections which sync with Lightroom CC (desktop and
mobile) > I Edit photos on Photoshop CC (opening from Lightroom Classic /
originals stored on SSD) > saved back.
On lightroom classic syn collection the previews update correctly, but on
lightroom CC (desktop and mobile) the preview doesn't update.

I do not store my original photos on lightroom CC adobe cloud. that's a
mess for me.

I reached out to Adobe, and one of their representatives did some tricks on
my computer and it worked for a couple of days. But it went back to the
same issue.

This issue for me is a bit recent, a few months before I wrote on this
blog. In the past, I used to do this and everything was updated correctly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2020 0
New Here ,
Oct 06, 2020

Copy link to clipboard

Copied

Interesting and furstrating. I'm having the exact issue and workflow as the one you describe. The only thing that helped a bit was permenantely deleting the 'Recently Deleted' images from lightroom.adobe.com. It seems to affect your total storage quota (although our storage was indicated to be only half full) because after we did that, only 2 photos remained un-synchronised (before that, it was over 100 photos).

 

Looking at the various forums, Adobe hasn't been able to get their stuff together on this matter for over 3 years already. Sometimes it works, sometimes it doesn't. Unbelievable.

 

Good luck.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2020 0