Previews not updating after edit on Photoshop

Community Beginner ,
Jan 31, 2020 Jan 31, 2020

Copy link to clipboard

Copied

Hi guys, I was wondering if someone here could help me with this mini headache. 

I have an issue that when I edit photos from

lightroom classic on photoshop cc and saved back, the previews on Lightroom cc mobile doesn't update. On LR classic they are fine, but not on mobile. 

To make it more clear, this is my workflow: 


upload photos to Lightroom classic > creat collections and sync (with smart previews)  to Lightroom CC / mobile > on Lightroom classic I do "edit image in photoshop 2020" > finished editing on PS 2020 and saved back. 

 

On lightroom classic the previews are updated nicely, however on Lightroom CC mobile the new previews doesn't update. The old one remains. 

I have tried to delete smart preview and then creat them again via library but nothing. 

the only work around it's to delete the collection (or sync) > delete smart previews > creat smart previews > creat collection and sync over and over again everytime I edit in photoshop. 

I mean, it's a complete nightmare 😞 

Does anyone have this issue? 
thank you in advance and sorry for my English 🙂 

TOPICS
Problem or error

Views

2.5K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Jan 31, 2020 Jan 31, 2020
Do you use 'Edit in Potoshop' while you are in the synced collection? If you are not in the synced collection, then the returned Photoshop image will not be added to the synced collection and so you will still only have the original online.

Likes

translate

Translate

Translate
Adobe Community Professional ,
Jan 31, 2020 Jan 31, 2020

Copy link to clipboard

Copied

Do you use 'Edit in Potoshop' while you are in the synced collection? If you are not in the synced collection, then the returned Photoshop image will not be added to the synced collection and so you will still only have the original online.

-- Johan W. Elzenga

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 31, 2020 Jan 31, 2020

Copy link to clipboard

Copied

Hi Johan! 

thank you so much for this fast reply. 

and no 😞 I do "edit in photoshop" from the "album" and not from sync collection. 

gonna try your advice and see if that solves my lil workflow nightmare. 

Will let you know ASAP. Thank you again! 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2020 Feb 02, 2020

Copy link to clipboard

Copied

Hey Johan!

 

sorry for the late reply. 

so I have followed your advice and, sadly, still doesn't work.

 

before I followed your advice I did the following:

on lightroom classic: unsynch the collections and delete the photos from all sync > did the "rebuild sync"  > discard  the smart previews > created the collections again and sync them > edit one of the photos "edit in photoshop" to test  

 

but it didn't synch the changes 😞 

 

im not very technical with Lightroom classic so I'm not sure if there's something I'm missing. 

If you can, let me know other advice. Thanks in advance. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 02, 2020 Feb 02, 2020

Copy link to clipboard

Copied

Please show a screenshot of Lightroom Classic (your entire screen, don't cut off anything), showing the selected image just before you do 'Edit in Photoshop'. Then show a second screenshot of the result (in Lightroom Classic) after you have done editing in Photoshop.

-- Johan W. Elzenga

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2020 Feb 02, 2020

Copy link to clipboard

Copied

Heyyy! 

well... well... well... Lightroom decided to make me look like a fool this time 🙂 

 

while doing the screenshots, it actually worked! Just took awhile to synch. Very happy now. 

sorry for making you waste more time on this. And again thank you so so much for your help. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 04, 2020 Mar 04, 2020

Copy link to clipboard

Copied


I am having exactly the same problem. My photos are not syncing with Lightroom Mobile after making adjustments in photoshop. I am making adjustments directly from the collection in Lightroom Classic (current version) and I'm adjusting the original image.  The adjustments appear in Lightroom, and Lightroom says it is syncing the image, but the changes are never actually synced.  The changes are not syncing in the cloud, so they are not reaching LR Mobile.

 

Does anyone have a solution for this?

 

thanks very much.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 07, 2020 Mar 07, 2020

Copy link to clipboard

Copied

Hey!

 

so sorry for my late reply. 
In regard to the issue, I was following the advise of Johan and it actually worked for a bit

however, I'm back at square one. It is a nightmare for my work flow to be honest. 

Doesn't matter if I edit directly from the collection, if i delete the sync images and re-synch to update the previews etc. 

sometimes (more often than It needs to) the editions made on PS disappeared the moment i dare to do the slightest edit on Lightroom CC. 

I will need to reach out to adobe directly and post their reply. cause it's not the first time  I have experienced this issue.


let me know if you find another trick. 

Regards.

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 05, 2020 Oct 05, 2020

Copy link to clipboard

Copied

Leonel,

 

Have you had any helpful feedback from Adobe on this issue yet? I'm having the exact same issue, which by the way doesn't only apply to the previews in LR web/mobile, but on the full size image as well. 

 

If you have had any news since this last post and would care to share the outcome, I'm sure that would be very much appreciated!

 

Many thanks,

Les

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 05, 2020 Oct 05, 2020

Copy link to clipboard

Copied

This is a user to user forum so the responses you receive here are usually from users like yourself. This thread is already marked as answered and it's not likely to receive the attention you would expect.

Create a new thread and describe your specific issue and particular details of the apps involved and Operating System quoting the specific version numbers.

See at this link a number of sync issues there.

https://feedback.photoshop.com/topics/lightroom-classic/5f5f2093785c1f1e6cc40872

 

 

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.2.3, LrC 10.2, Lr 4.1, Ps 22.3, Pr 14.8.0; Camera OM-D E-M1.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 06, 2020 Oct 06, 2020

Copy link to clipboard

Copied

Hi Les,

Unfortunately not, and i have tried everything advice
on this thread and the once i have researched on.

The comments about opening the photos from Sync collection directly into
photoshop CC and then saving back doesn't work for me. I also tried
deleting smart previews and creating them again, but no luck either.

The only thing that works is deleting the image from the collection and all
sync images and then sync again. But that is so much hassle and time
consuming.

Just to clarify, my issue is as follows:
My photos are stored on Lightroom Classic catalogue (originals on external
storage) > I create collections which sync with Lightroom CC (desktop and
mobile) > I Edit photos on Photoshop CC (opening from Lightroom Classic /
originals stored on SSD) > saved back.
On lightroom classic syn collection the previews update correctly, but on
lightroom CC (desktop and mobile) the preview doesn't update.

I do not store my original photos on lightroom CC adobe cloud. that's a
mess for me.

I reached out to Adobe, and one of their representatives did some tricks on
my computer and it worked for a couple of days. But it went back to the
same issue.

This issue for me is a bit recent, a few months before I wrote on this
blog. In the past, I used to do this and everything was updated correctly.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 06, 2020 Oct 06, 2020

Copy link to clipboard

Copied

Interesting and furstrating. I'm having the exact issue and workflow as the one you describe. The only thing that helped a bit was permenantely deleting the 'Recently Deleted' images from lightroom.adobe.com. It seems to affect your total storage quota (although our storage was indicated to be only half full) because after we did that, only 2 photos remained un-synchronised (before that, it was over 100 photos).

 

Looking at the various forums, Adobe hasn't been able to get their stuff together on this matter for over 3 years already. Sometimes it works, sometimes it doesn't. Unbelievable.

 

Good luck.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Yeah I've been having this problem for years. It is a nightmare. Basically I've concluded 'edit in photoshop' is none functional. Actually this was the exact reason I bought capture one. 

 

Now I ingest in Capture one- do my selects and edit in photoshop or keep work in progress jobs as Adobe cloud - then only when its finished do I import to Lightroom where it has its final resting place and for lightroom only tweaks. 

I really really wish Adobe would fix what is kinda a screaming issue but yeah for me, edit in photoshop is non-functional. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

Hi Thomas, 

 

Thank you for the idea. However, today I was so done with that mess that I decided to reach out to Adobe and see if we can find a solution. 

 

After a long 3 to 4 hours with them on the chat. I have followed up to show them my workflow which is: 

- Import images to Lightroom Classic >

-Create A collection to sync with Lightroom CC (I do not save my originals in the Creative Cloud) >

-Once its all Sync > I go to collection (on lightroom classic) and click "Edit In photoshop" > Edit and save back

 

The problem I was having is that the previous doesn't update on lightroom CC/ Mobile / Web, just on the Lightroom Classic. 

 

We found out that the issue is that Lightroom Classic builds/syncs a preview on the collection, and once you edit on photoshop, a new preview should be created, but it isn't syncing. 

 

So the trick is: 

- Lightroom Classic > go to Sync Collection and Photo > Edit in Photoshop

-Once you finish editing the image > save the image back as usual

- On the collection, you will see the preview has updated correctly... what you need to do, if it's not updated on the mobile and CC version is to > Right-Click the image > Metadata > Save Metadata 

-Once Metadata is save > right-click again > metadata > read Metadata 

And the new preview will be correctly synced 😄 

 

Just tried it with the supervisor on the phone and it worked. Have attached an image in case.

 

Sorry for the long explanation haha wanted to make it as clear as possible. Hope it works for you. 

 

 

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

OMG

 

Your amazing! Been tearing my hair out on this one! 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

hahaha glad It could help. 

 

Also, forgot one important step. Discard the smart previous from the collection FIRST, then do the steps mentioned before. 

 

Just tested it now and it worked perfectly. 

 

Hope it works for you too. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

Actually yeah I've been trying to do this but its not working. Question: How do I discard previous smart previews? 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

Oh sure, 

 

there are 2 ways 

In Bash

So select the images > Click Library (on the top menu) > Previews > Discard Smart Previews

(Attached an image with the info) 

 

By Single Image

Click the image > On the ride side where the Histogram appears, just below it will indicae "Original Photo + Smart Preview" > Click Smart Preview and it will give you an option to discard it. 

 

Let me know if that works. 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

YES!!!!!!!!

 

That works

 

So its important to also then build smart previews for the collection once you've reloaded the metadata! Then it works perfect! Wow

Question: Have you worked out a way to bulk Save metadata and reload metadata ? It looks like I can only do it one image at a time.  

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

No sadly,


For what I can see, you can only save/read metadata per photo.
Will do another little research later on.

And in regard to rebuild the smart previews, for me that step wasn’t necessary for some reason 😄
I just deleted them, and save and read metadata and it updated my stuff correctly.

BUT YAYYY it worked for you too.

For me was so important cause I like to take my iPad and show my clients the artworks. And it wasn’t possible without having to duplicate the d*mn files and sync it again -_-

So now, love Adobe again (for now hahaha )

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

Hey, so did a last lil search

 

And it's possible to batch save/read metadata. Just select the images in the collection  > right click > Metadata the option is there 😄 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines