Highlighted

Problem with a few photos synching as a collection in LR Classic

Participant ,
Sep 26, 2020

Copy link to clipboard

Copied

I see many posts about syncing problems with Lightroom Classic.  I am using version 9.4.  This problems keeps showing up.  It seems to only occur on photos that I have edited in PS and have a PSD extension.  It is very inconstant.  Some sync some don't.  They will sit there for days w/o syncing.  The fact is they actually do sync and show on the web but I continuously get a message that I have photos waiting to sync when I try to shut down. I have found a way to fix it but it is very inconvenient.  I have to remove the photo from the collection and then add it back to the synced collection.  Most of them are in a stack so I have to rebuild the stack.

Anyone have a fix?

 

TOPICS
Problem or error

Views

151

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Problem with a few photos synching as a collection in LR Classic

Participant ,
Sep 26, 2020

Copy link to clipboard

Copied

I see many posts about syncing problems with Lightroom Classic.  I am using version 9.4.  This problems keeps showing up.  It seems to only occur on photos that I have edited in PS and have a PSD extension.  It is very inconstant.  Some sync some don't.  They will sit there for days w/o syncing.  The fact is they actually do sync and show on the web but I continuously get a message that I have photos waiting to sync when I try to shut down. I have found a way to fix it but it is very inconvenient.  I have to remove the photo from the collection and then add it back to the synced collection.  Most of them are in a stack so I have to rebuild the stack.

Anyone have a fix?

 

TOPICS
Problem or error

Views

152

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 26, 2020 0
Adobe Community Professional ,
Sep 26, 2020

Copy link to clipboard

Copied

Stacked in the Collection? Why are you doing that, Stacking in the Synced collection.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2020 0
Participant ,
Sep 26, 2020

Copy link to clipboard

Copied

Sorry.  The original photo is in a stack.  The photo in the synced collection is not.  It is a single photo.  I misspoke.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2020 0
Adobe Community Professional ,
Sep 26, 2020

Copy link to clipboard

Copied

So then my next question is why are you Syncing PSD files with the Lr Web/Mobile system from LrC?

 

What gets uploaded from LrC is a Smart Preview. That Smart Preview is basically the same whether you sync a PSD or a JPG. Depending on the quality of the JPG file.

 

Have you tried creating a JPG of that image and syncing that?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2020 0
Participant ,
Sep 26, 2020

Copy link to clipboard

Copied

I realize there are workarounds to this issue.  What I don't understand is that some of my PSD's get synced and some don't.  And once again they actually are getting synced but it says they are not and I get an error message every time I exit the program.  I will typically open a photo in PS from within LR Classic.  Make some adjustments and then save.  The PSD will now show up in my LR Classic catalog.  If I want to sync it to the cloud I just drag the file into the synced collection.  If I make any changes to the image they are automatically re-synced to the cloud.  All very convenient.  If I have to export to a jpg first it is just an extra step.  This has been working but recent I started getting this problem.  Is there a better way to do this?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2020 0
Adobe Community Professional ,
Sep 26, 2020

Copy link to clipboard

Copied

It could be the PSD's that don't sync properly have to much going on in them, layers,whatever, and LrC can't easily build a smart preview for it so it just hangs during the sync process.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2020 0
Participant ,
Sep 26, 2020

Copy link to clipboard

Copied

I do appreciate your responses but it sounds like something I am going to just have to live with.  If what you say is true then there are two things that do not make sense.  The image does not hang, actually does sync.  I can view in on the web page.  The sync utility just does not complete the cycle and confirm it complete.  Second, if I remove the image from the synced collection and re-add it  - it syncs up perfectly.

Thank you for the feedback.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2020 0
Community Beginner ,
Oct 03, 2020

Copy link to clipboard

Copied

I have noticed this exact issue/behavior in recent days. The majority of my work flow involves editing raw in Lightroom Classic and then round-tripping to Photoshop resulting in a psd returned to Lightroom Classic. I frequently put the edited photos into a synced collection. If I re-edit the psd, the file appears to sync across platforms but Classic reports an endless sync in progress. When I remove the file from the collection, the sync status turns green almost immediately. When i put the edited file back into the collection it immediately syncs!  This must be a bug introduced in one of the most recent updates since I just noticed this behavior recently and I have not had this problem in the past. Hoping Adobe takes notice and fixes it. Very annoying. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2020 1
Participant ,
Oct 04, 2020

Copy link to clipboard

Copied

Thanks for the response.  I am glad I am not the only one.  I too think it is a bug.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 0
Community Beginner ,
Oct 04, 2020

Copy link to clipboard

Copied

You're welcome!  Glad I found your post before I tried anything potentially disastrous like reinstalling, tinkering with the catalog, deleting all my collections,etc. I had already done all the usual "fixes" such as deleting sync cache, rebuilding the sync data, signing in and out, etc. At least for now I can just remove and re-add edited photos to collections. While trouble shooting I think (I did so much I lost track!) I did find that Photoshop editing was the issue and the problem also occurs if round-tripped in tiff, not just psd. It also didn't matter if the file was complex or very large (note that psb large format files do not sync--that is a known limitation). I also don't think that edits done directly in Lightroom are an issue but I'm going to re-test that. I'm almost inclined to think that the bug may somehow be in Photoshop since Photoshop has had several very recent updates (including one that fixed tablet pen pressure issues). 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 0
Participant ,
Oct 04, 2020

Copy link to clipboard

Copied

I agree with your assessments completely.  I have 6 photos saying they are not synced right now.  All edited PSD's.  Haven't tried tiff.  Since I know they are actually synced I decided I was just going to ignore them.  One thing I believe, although I have not done several trials to prove it, if you create the PSD and save it and then add it to the synced collection it will sync.  If you then edit that same file again the syncing freezes.  Since you have confirmed the issue I think I will create a bug report.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 1
Participant ,
Oct 05, 2020

Copy link to clipboard

Copied

Here is the answer I received after posting a bug report:

Hi,

Lightroom Classic doesn't support syncing of PSD files yet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 1
Community Beginner ,
Oct 05, 2020

Copy link to clipboard

Copied

That's laughable. Virtually all my synced files are psd and all have synced just fine for years now. They're all synced right now!  Maybe they meant psb file. Anyway, the issue is bigger as I've just figured out. Any file type, including jpg, has the same issue. They sync perfectly when placed in synced collection. Edits (even an edit in Lightroom alone) will Sync as they should almost immediately. The problem is that the sync function in the top right of Lightroom reports sync in progress. There are no syncing errors reported in the Cloud. Again, this behavior just recently started. It's interesting that they'd say psd files aren't supported!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 0
Community Beginner ,
Oct 05, 2020

Copy link to clipboard

Copied

I think Adobe must be referring to the fact that psd files themselves don't sync in Lightroom Classic--it's the Smart Previews that sync.  We already know that, and as you also know, that's not even the issue.  The issue is that edited files in a synced collection continue to sync properly (using a Smart Preview as designed) but are erroneously reported as endlessly syncing.  I just noticed that the sync step that appears to be hung up (but really isn't hung up) is "Building Smart Preview for Lightroom Ecosystem." (you can see that in Grid view by hoovering over the "hung" photo top right corner little arrows) So even though the edited file absolutely builds the Smart Preview and then absolutely syncs it to the Lightroom Ecosystem (you can see the Smart Preview on any of your synced platforms), Lightroom Classic reports the endless sync erroneously.

 

I think for now we just have to live with it and eventually it will work again--just like it has worked properly for several years now (I'm a newbee on the Community but have been running Adobe, Lightroom and sync extensively on multiple platforms for years). It's a shame Adobe completely missed the boat with their response.  Whoever wrote that just needs to click on the Cloud in the top right corner of Lightroom Classic and then click on "SyncFAQs" to see that the only specific file type that doesn't sync is psb.  Thanks again for trying to get this fixed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 0
Participant ,
Oct 05, 2020

Copy link to clipboard

Copied

I agree with everything you are saying.  Purhaps you should also create a post on their bug page.  https://feedback.photoshop.com/.  As you know the more that post a problem the more likely they will take it seriously.  Maybe I did not explain the problem correctly.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 1
Community Beginner ,
Oct 05, 2020

Copy link to clipboard

Copied

I'll give that a shot tomorrow. Thanks for link. The good news is that everything seems to otherwise work as advertised.  It's just annoying to see that cloud spinning, being told that files are syncing, getting that annoying message about syncing when you go to close, etc. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 0
Participant ,
Oct 07, 2020

Copy link to clipboard

Copied

Just got this response to my bug report:

 

"There is a bug in 9.4 release which blocks the re upload of binary. We are fixing this in the coming update."

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2020 1
Community Beginner ,
Oct 07, 2020

Copy link to clipboard

Copied

Wow!  That sounds promising. I had not yet submitted anything so at this point I'll wait. I did notice yesterday another twist to this issue. If I made edits to a file directly from the main Library (vs the same file in a collection), most files re-synced without any reported hang in upload. This wasn't true if the file also had virtual copies in the Library. Hopefully all is well in next bug fix. Thanks for info. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2020 0
Adobe Community Professional ,
Oct 07, 2020

Copy link to clipboard

Copied

This is good news, Syncing between the ACC (Adobe Creative Cloud) with LrC 9.4 certainly had some challenges for the past few months. I had an issue two days ago which took me over an hour to sort out, the issue involved worked for me previously without problems.

Looking forward to the update, hoping it is released prior to the macOS 11 (Big Sur) upgrade expected soon.

 

Regards, Denis: System iMac mid-2015, 5K 27” monitor, macOS10.15.7: LrC 10, Lr 4, Ps 22.0,; Camera OM-D E-M1.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2020 1
Adobe Community Professional ,
Oct 07, 2020

Copy link to clipboard

Copied

DdeGannes, I've been seeing the same, to the point where I have completely un-synced everything for the time being except one or two critical collections, and even now, adding a photo from my phone syncs over to the desktop, then becomes "stuck" in the "uploading" process with the caption "building Smart Preview for Lightroom ecosystem." I'm really hopeful for the next release very soon!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2020 1
Adobe Community Professional ,
Oct 10, 2020

Copy link to clipboard

Copied

@Michael J. Hoffman 

I don't understand your response.

 

"Then becomes stuck in the Uploading Process". Uploading from where, LrC or from your phone?

Images imported into Lr Mobile on phone/pad upload Full Res, Full File Size, image files to the Lr web system and then those same Full Reas, Full File Size, images get downloaded to LrC and placed in a folder you have either specified or to the Default folder location and then shown in LrC in a folder in the "Folders" section of the Library module.

 

2020-10-10 11_29_28-LR Classic V9 Catalog - Adobe Photoshop Lightroom Classic - Library.png

 

So I ahve no idea why these same image files would be Re-Uploading to the Lr Web system as Smart Previewa. They already exist on the Web system and on your phone/pad (and or any devices you have the Lr Mobile app installed on).

Can you explain that comment? Are you then placing those images back into the Synced Collection.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 10, 2020 0