Highlighted

Problem with Book Module in New LR CC Classic

New Here ,
Nov 07, 2019

Copy link to clipboard

Copied

I have made several books with the Lightroom CC Classic book module without trouble.  A few days ago I updated to the newest version of LR CC Classic and am having problems with the Book module.  If I just work in the Book module all works well.  However, if I switch to the Library module and then back to the Book module, the pages of the multi-page view don't repopulate fully until the cursor is placed over them.  The more I switch back and forth to the Library module the worse the problem gets.  Surprisingly, if I go to the two page spread view and then back to the multi-page view the pages repopulate as they should for a while.  However this doesn't seem to last.  

 

I am working on a Mac with OSX 14.6 with all the latest updates.  I have tried closing down Lightroom and restarting it.  This works for a short while until I again switch to the Library mode.  I have also tried rebooting the system that only fixes the problem for a short time.  Has anyone else experienced this issue?

TOPICS
Bug, Mac, Problem or error

Views

200

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Problem with Book Module in New LR CC Classic

New Here ,
Nov 07, 2019

Copy link to clipboard

Copied

I have made several books with the Lightroom CC Classic book module without trouble.  A few days ago I updated to the newest version of LR CC Classic and am having problems with the Book module.  If I just work in the Book module all works well.  However, if I switch to the Library module and then back to the Book module, the pages of the multi-page view don't repopulate fully until the cursor is placed over them.  The more I switch back and forth to the Library module the worse the problem gets.  Surprisingly, if I go to the two page spread view and then back to the multi-page view the pages repopulate as they should for a while.  However this doesn't seem to last.  

 

I am working on a Mac with OSX 14.6 with all the latest updates.  I have tried closing down Lightroom and restarting it.  This works for a short while until I again switch to the Library mode.  I have also tried rebooting the system that only fixes the problem for a short time.  Has anyone else experienced this issue?

TOPICS
Bug, Mac, Problem or error

Views

201

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 07, 2019 0
Adobe Community Professional ,
Nov 07, 2019

Copy link to clipboard

Copied

I see a brief pause before my book pages are 're-drawn' in multi-page view, but never a long delay or the re-draw with cursor over. (Windows-10)

Suggestions-

Always work from a 'Saved Book Collection', [Library] or [G] will take you back to a Grid view of the photos in the Saved Book.

To return to the Book- always [Double-click] the Saved Book Collection, (or one click the white arrow on the Collection). Never use the top menu [Book] to go back to a book that has be saved in a Collection!

 

I know that Lr-Classic v8.0 had bad problems with the book module, I hope these are not re-surfacing in v9!

Regards. My System: Lr-Classic 10.0, Photoshop 22.0.1, Lightroom 4.0, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2019 0
Adobe Employee ,
Nov 08, 2019

Copy link to clipboard

Copied

Hi John,

 

Is it possible for you to share the catalog?

It will help us isolate the root cause.

 

Thanks,

Bhargav

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2019 0
New Here ,
Dec 06, 2019

Copy link to clipboard

Copied

Did you ever find a solution to this problem?  I seem to be having the same issue with LR Classic 9.0.  I've rebooted, reinstalled LR, erased the preferences file, etc.  Nothing seems to help.  Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 06, 2019 1
Community Beginner ,
Sep 24, 2020

Copy link to clipboard

Copied

And I'm having a problem in LR Classic 9.4. I've used LR to create books for years. Now I can populate a collection and but not create a new book. As an example, today I created a test collection of 14 pages for a book. Then I created a new book based on the collection and dragged the 14 pages into it. When I shift from Library to Book modules, only two of the pages appeared. The same thing happens with some of the books I created previously. I'm at a loss as to know how to deal with this and will appreciate any suggestions (other than those Redzuba tried - and which I have also tried).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 24, 2020 0
Adobe Community Professional ,
Sep 25, 2020

Copy link to clipboard

Copied

I do not understand your procedure-

"I created a test collection of 14 pages for a book." A Collection contains only photos! Not "pages".

"...dragged the 14 pages into it."  When you 'open' the Book module from a Standard Collection then the PHOTOS in the Collection will appear on the Filmstrip. They can then be added to Book pages either by clicking on [Auto Layout], or by manually adding blank pages and dragging photos into Photo Cells on the pages. The pages can be the supplied templates, or your freehand design of "Photo" and "Description" cells.

 

A CRITICAL step in Book designing in LrC is to ALWAYS create a 'Saved Book Collection' for a new book, and always edit the book using the Saved Book Collection (NOT the Standard Collection!)

 

! BEST PAGE-How to Make a Photo Book

 

Regards. My System: Lr-Classic 10.0, Photoshop 22.0.1, Lightroom 4.0, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2020 0
Community Beginner ,
Sep 25, 2020

Copy link to clipboard

Copied

Exactly - I have done what you suggested every time. But now the LR Book
Module simply does not work. If this were my first book, I might think it
was user error, but I have created many books with LR/Blurb and have never,
until now, had a problem. I can send you screen captures if that would help.

Cathryn

"We're all just walking each other home." Ram Dass

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2020 0
Community Beginner ,
Sep 25, 2020

Copy link to clipboard

Copied

My deep gratitude to Adobe support. The issue they found would have totally
flummoxed me had I had to find it. But a smart techie pinpointed and
repaired it, and all is working fine.

Cathryn

"We're all just walking each other home." Ram Dass

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2020 0
Adobe Community Professional ,
Sep 25, 2020

Copy link to clipboard

Copied

Yes, some screen captures may help us to suggest an answer.

The fact that you are experienced book user makes it harder to make suggestions.

Screen-clip- (Insert from the icon above your reply

ScreenShot048.jpg

-Your Menu: Book Preferences.

-The full Book module window showing filmstrip, etc.

-The Collection panel with the saved book collection.

 

A reset of the LrC preferences file, or even an un-install and re-install of LrC 9.4 might help.

Or detail the exact steps you take to create a book.

Hopefully it is not the major bugs returning that were in LrC v8!!

 

 

Regards. My System: Lr-Classic 10.0, Photoshop 22.0.1, Lightroom 4.0, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2020 0
Community Beginner ,
Sep 26, 2020

Copy link to clipboard

Copied

Fortunately, a smart Adobe techie solved the issue by changing a Library
setting that put things back on track.

Cathryn

"We're all just walking each other home." Ram Dass

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2020 0
Adobe Community Professional ,
Sep 26, 2020

Copy link to clipboard

Copied

I would be pleased to know how the techie solved the issue.

Do you know what Library setting was changed?

 

 

Regards. My System: Lr-Classic 10.0, Photoshop 22.0.1, Lightroom 4.0, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2020 0
Community Beginner ,
Sep 26, 2020

Copy link to clipboard

Copied

I've no idea, other than it was a .plist setting.

Cathryn

"We're all just walking each other home." Ram Dass

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2020 1
WobertC LATEST
Adobe Community Professional ,
Sep 26, 2020

Copy link to clipboard

Copied

plist = Preference file.

As I suggested- A reset of the LrC preferences file.

 

Regards. My System: Lr-Classic 10.0, Photoshop 22.0.1, Lightroom 4.0, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2020 0