Highlighted

Reinstalling Lightroom on mac osx El Capitan

New Here ,
Apr 18, 2020

Copy link to clipboard

Copied

I have just retuned my Mac Pro to factory settings and now my Lightroom and Photoshop apps are showing as 'non compatible' though they both worked perfectly well before.  Clicking on the three dots doesn't bring me to the download older versions and I am at a loss as to how I work around this problem!  

 

Topics

Download and install

Views

233

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Reinstalling Lightroom on mac osx El Capitan

New Here ,
Apr 18, 2020

Copy link to clipboard

Copied

I have just retuned my Mac Pro to factory settings and now my Lightroom and Photoshop apps are showing as 'non compatible' though they both worked perfectly well before.  Clicking on the three dots doesn't bring me to the download older versions and I am at a loss as to how I work around this problem!  

 

Topics

Download and install

Views

234

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Apr 18, 2020

Copy link to clipboard

Copied

What version of Lightroom are you referring to? We need the exact version NUMBER.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 18, 2020

Copy link to clipboard

Copied

Hi It was Lightroom 7.5 and Photoshop 19.1.9. Both worked fine before. I have downloaded camera raw 10 as another post suggested that might be the problem. Unfortunately not!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Apr 18, 2020

Copy link to clipboard

Copied

According to this, you need OSX 10.13 or later

https://helpx.adobe.com/lightroom-classic/system-requirements.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 18, 2020

Copy link to clipboard

Copied

So my mac won't upgrade to OSX10.13 so I'm goosed! Or is there an older version of Lightroom/Photoshop that I can download?

Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Apr 18, 2020

Copy link to clipboard

Copied

"is there an older version of Lightroom/Photoshop that I can download?"

 

No.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Apr 18, 2020

Copy link to clipboard

Copied

"So my mac won't upgrade to OSX10.13 so I'm goosed!"

 

If you can upgrade your Mac Pro to Mac OS 10.12 (Sierra), then you can install LR 8 via the Adobe Creative Cloud desktop app. Unfortunately, the Creative Cloud app only gives you access to the last two major versions (8 and 9).  (Adobe has greatly restricted their policy on older versions in the last year, partly driven by legal troubles they had with Dolby.)

 

[Use the blue reply button under the first post to ensure replies sort properly.]

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 18, 2020

Copy link to clipboard

Copied

Thanks, but it's early 2009 and apparently it won't.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...