Scrolling in grid view slower with V10

Explorer ,
Oct 23, 2020

Copy link to clipboard

Copied

Anyone had issue when scrolling your photos in the grid view ? For me, it's much slower than before the update. I'm using a Mac with MacOSCatalina.

TOPICS
Mac, Performance

Views

68

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Scrolling in grid view slower with V10

Explorer ,
Oct 23, 2020

Copy link to clipboard

Copied

Anyone had issue when scrolling your photos in the grid view ? For me, it's much slower than before the update. I'm using a Mac with MacOSCatalina.

TOPICS
Mac, Performance

Views

69

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 23, 2020 1
LEGEND ,
Oct 23, 2020

Copy link to clipboard

Copied

It is not slower for me (Windows 10). Make sure there are no background tasks, such as face detection or sync with Lightroom Mobile, running. Also make sure all your plug-ins are compatible with Lightroom Classic 10.0.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 1
Explorer ,
Oct 23, 2020

Copy link to clipboard

Copied

Ok thank you !  Yes in fact I did had an "adress search" in background that was active. I did put this thing on pause and it did make a big difference. But still this option was active with the previous release of Lightroom and I never had any performance issue. But now it's way better.  Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 0
Explorer ,
Oct 23, 2020

Copy link to clipboard

Copied

All my background processes have been disabled all the time, and it's still slow. I would not like to know how slow it would be with these processes enabled.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 0
Explorer ,
Oct 23, 2020

Copy link to clipboard

Copied

It is way slower, with my MacMini 2020, i7, 32GB, it is probably back to LR5 or LR6 performance. It looks like it regenerates the thumbnails again - which takes time.

Also things like dealing with metadata is somewhat slower. A preformance upgrade to bring it back to LR9 level, would be preferable.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 1
LEGEND ,
Oct 23, 2020

Copy link to clipboard

Copied

Is your Lightroom Classic actually re-generating the previews/thumbnails? If so, once that process ends, you should see improved performance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 0
Explorer ,
Oct 23, 2020

Copy link to clipboard

Copied

It looks like, but there is basically no improvement. I now have forced a regeneration of a selection of my photos to see if that help. I just simply think that LR10 is slow, and we now have to wait a number of iterations for them to put the optimistion back.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 0