Highlighted

Sync pending -- stuck

Community Beginner ,
Oct 05, 2020

Copy link to clipboard

Copied

I have been dealing with an issue for the past 2 months. I use lightroom classic and lightroom mobile. When taking photos with my dslr my images are imported to Classic and they sync to my ipad/iphone. iPhone images are auto-imported into lightroom mobile and sync to my catalog in Classic then backed up to a portable hard drive. Same workflow I have done for at least a couple years. Now I am having issues with syncing. Seems sync gets stuck and the only fix is to rebuild the sync data. Sync can be stuck for days or it maybe only 2 our 4 recent images are stuck. It will stay stuck for days, unless I rebuild sync data and then magically everything is immediately synced. What is going on?

TOPICS
Crash or freeze, Import and export, Mac, Problem or error, Sync

Views

123

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Sync pending -- stuck

Community Beginner ,
Oct 05, 2020

Copy link to clipboard

Copied

I have been dealing with an issue for the past 2 months. I use lightroom classic and lightroom mobile. When taking photos with my dslr my images are imported to Classic and they sync to my ipad/iphone. iPhone images are auto-imported into lightroom mobile and sync to my catalog in Classic then backed up to a portable hard drive. Same workflow I have done for at least a couple years. Now I am having issues with syncing. Seems sync gets stuck and the only fix is to rebuild the sync data. Sync can be stuck for days or it maybe only 2 our 4 recent images are stuck. It will stay stuck for days, unless I rebuild sync data and then magically everything is immediately synced. What is going on?

TOPICS
Crash or freeze, Import and export, Mac, Problem or error, Sync

Views

124

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 05, 2020 1
Explorer ,
Oct 05, 2020

Copy link to clipboard

Copied

Same here – broken for several months now. I had dozens of catalogs synced and over 5,000 photos. Of course I have multiple backups, but LR Sync became such a great part of my workflow that now I'm feeling dead-ended. I have an open case with Adobe Support, senior level, supposedly, but no joy – still not fixed. I simply don't understand why the sync database can't be flushed and then rebuilt from scratch, but I can't even do that!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 0
Adobe Community Professional ,
Oct 05, 2020

Copy link to clipboard

Copied

There has been a lot of frustrated traffic on this forum lately regarding sync issue, and I feel for both of you.

hr114:

Have you tried to clear the sync cache?

If you're seeing "Syncing photos" and it never goes away, try going to Preferences > Lightroom Sync, holding down Alt / Opt, and clicking the Rebuild Sync Data button that magically appears.  This should not change your existing synced collections or their contents, just rebuild the existing relationship between LR Classic and LR CC.
kwrdkc:
To test if you can resolve the problem, are you certain that you have logged into both LR Classic and LR iOS using the same account? (I'm sure you are but it can vary)
Is Sync enabled in your LR Classic catalogue? Try syncing a new photo from Classic, add a title on the iPad, move to a different photo on the iPad, then check the photo in Classic.
Sorry if these are random ideas, but they might help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 0
New Here ,
Oct 05, 2020

Copy link to clipboard

Copied

I am experiencing the exact same problem that kwrdc and hr114 reported. Worked great for what feels like years, but recently, it constantly gets stuck on certain pictures. "Syncing 19 photos" it says since yesterday. 18 uploads, 1 download.

 

Clearing the sync cache sometimes works, but it'll quickly get stuck again. Deleting stuck photos from "All Synced Photographs" and adding them back works, too, until you touch another photo, and sync gets stuck again. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2020 1
Explorer ,
Oct 15, 2020

Copy link to clipboard

Copied

Yes, I've tried rebuilding the sync database numerous times. Nothing changes – it still gets stuck at some point at N photos.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
Explorer ,
Oct 15, 2020

Copy link to clipboard

Copied

Hello Adobe!

This issue still persists for many of us, and my previously wonderful collection of 5,000+ synced photos is forever stuck at <199. Could you please, PLEASE fix this!

Many thanks in advance

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
New Here ,
Oct 15, 2020

Copy link to clipboard

Copied

Same thing here with LRC. "30 Uploading, 0 Downloading, 0 Pending". My Cloud Storage usage hasn't budged --- 0.1 GB  is the smallest increment I can see ---  in the weeks I've had this problem. "Rebuild Sync Data" on the magically appearing button doesn't help for but a day, but I've had to restart Sync each time. The file "lrsync_log.html" from the "Generate Diagnostic Report" is 3,838 lines of incomprehensible HTML. I have not opened LR on my iPad in at least a year. I don't want to run LR (not LRC) because I understand I might lose, or may have already lost photos. I always start LRC from CC Desktop, and it says all applications are up to date.

 

Four instances of Windows Explorer are doing something in the LRC catalog folders of my latest pictures --- to the extent that they are using 100% CPU, and my computer fan is running constantly. That doesn't happen for just about every other application I run. (I just noticed this might happen only when I go to look at the sync status in LRC. ... Yes. Just tried it again.)

 

Nothing in the forums helps except Rebuilding Sync Data, but only for a day, or until I restart Sync, I can't tell which.

 

This has to be something to do with the recent rash of updates; nothing else has changed. A bunch of little annoyances have appeared with the updates --- like images in the viewing grid don't show up until I run my moise over the grid slots --- but I'm not going to worry about those now except to point out that the updates seem to be a bit less than finished. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 1