Highlighted

Synching Crop does not work properly with RAW and PSD of the same file

Community Beginner ,
May 24, 2020

Copy link to clipboard

Copied

Using v9.2.1. Using Sync across multiple RAW files or virtual copies, and selecting Crop (both Size and Aspect Ratio) seems to work properly, with size and location of the crop. However, trying to sync a RAW file with the PSD version of the same file (same dimensions but edited in PS 2020) results in the correct crop size, but wrong location? 

Topics

Bug, Problem or error, Sync

Views

756

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Synching Crop does not work properly with RAW and PSD of the same file

Community Beginner ,
May 24, 2020

Copy link to clipboard

Copied

Using v9.2.1. Using Sync across multiple RAW files or virtual copies, and selecting Crop (both Size and Aspect Ratio) seems to work properly, with size and location of the crop. However, trying to sync a RAW file with the PSD version of the same file (same dimensions but edited in PS 2020) results in the correct crop size, but wrong location? 

Topics

Bug, Problem or error, Sync

Views

757

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
May 24, 2020

Copy link to clipboard

Copied

You've probably tripped over this long-standing problem:

https://feedback.photoshop.com/photoshop_family/topics/copied-radial-filter-effects-appears-on-mirro...

 

This has never worked properly in LR. It's pretty simple to fix (my Any Crop plugin copies crops correctly), but Adobe hasn't made it a priority to fix. Please add your constructive opinion to that feature request and be sure to click Vote and Follow in the upper-right corner. That will make it a little more likely that Adobe will consider implementing the feature and you'll be notified when they do.

 

[Use the blue reply button under the first post to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 25, 2020

Copy link to clipboard

Copied

@johnrellis: That problem seems to have to do with rotation. In my case, no rotation is done to the photo (RAW or PSD). In fact, it can be easily reproduced by just "Editing" a RAW in Photoshop, immediately exiting and saving the PSD, then cropping the RAW, highlight both RAW and PSD to apply crop, and the crop ends up NOT matching. OTOH, if you do this with a virtual copy instead, it works 100%. I have been using LR since v1.0, and I believe that this is a NEW problem because I remember very clearly being able to match crop between different formats of the same exact photo.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
May 25, 2020

Copy link to clipboard

Copied

Is the raw portrait or landscape? If it's portrait, then it was rotated by the camera. In my tests, the bug occurs with portrait raws  (rotated in-camera or in LR) and PSDs, not with landscape raws and PSDs.

 

If you have an example of a landscape raw that shows the bug, please upload the raw to Dropbox or similar and post the sharing link here.  I'll put it under the microscope.

 

[Use the blue reply button under the first post to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 26, 2020

Copy link to clipboard

Copied

Yep--in portrait mode! I did not try landscape mode photos.

 

Seems like a pretty serious bug that Adobe has been ignoring for over a year and a half and now labeling as an "idea or feature request?" Seriously? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 26, 2020

Copy link to clipboard

Copied

So knowing that it is a bug, I purposefully went and rotated the PSD 90 degrees clockwise in Photochop and saved. Then applied the sync between the now landscape PSD with the original RAW, and the crop is now perfectly in sync!

 

To further the experiment, I then used LR 9.2's rotation tool to rotate the landscape PSD 90-degrees counter-clockwise, reset the crop, then synced it to the RAW again. And again, this syncs perfectly also.

 

This is so clearly a bug rather than a "feature request."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...