Syncronizing "Auto" transforms "Update" button, help!

Explorer ,
Nov 10, 2016 Nov 10, 2016

Copy link to clipboard

Copied

I have read all the FAQ's and discussions on this topic, but still cannot get this to work. I want LR to be able to apply the "Auto" transform to a set of real estate interior photos.

I understand how to do this I believe, which is to simply apply the Auto Transform to the first image, then select the rest of the interior images, then  "Sync..." ->Transform -> Upright Mode.

It should be that simple, and as described in the FAQ it is.. However the problem is this: I go to the next (and every) image in the series I had selected for the sync, and I see that "Auto" transform is selected (but not applied), but now this "Update" button is active and I have to click it to get LR to analyze that particular image and apply the Auto Transform. And I have to do this for every single image. I have to force LR to analyze each individual image and apply the Auto Transform with this Update button that I had seemingly successfully synchronized. Not a big deal for a few images, but I just shot a dozen model homes and have over 400 images I have to click next, Update, click, next, update, click, next, update, click, 400 times?... So how do I not only synchronize the Auto Transform to a batch of images but APPLY the Auto Transform to a batch of images?

Thanks for your help!

Chris Miller

www.imagineimagery.com

Views

1.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Explorer , Nov 10, 2016 Nov 10, 2016
Thanks for the attempted assist John, but it turns out the current version of LR will not batch analyze Auto Transform as I was hoping it would. In fact this is why the "Update" button exists. It appears when Sync->Transform->Upright Mode only is checked, because LR will not analyze every image included in the sync. You must manually "Update" the Auto Transform for each image you have synchronized with the setting.I spent a couple hours on the phone and in Remote Desktop sessions with Adobe tech...

Likes

Translate

Translate
Most Valuable Participant ,
Nov 10, 2016 Nov 10, 2016

Copy link to clipboard

Copied

I understand how to do this I believe, which is to simply apply the Auto Transform to the first image, then select the rest of the interior images, then  "Sync..." ->Transform -> Upright Mode.

Troubleshooting steps:

1. Make sure that in the Synchronize Settings window, you've selected Upright Mode only:

When you select Upright Transforms or Transform Adjustments as well, LR will activate the Update button.

2. If 1 doesn't help, please report your exact version of LR (do Help > System Info).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 10, 2016 Nov 10, 2016

Copy link to clipboard

Copied

Thanks for the attempted assist John, but it turns out the current version of LR will not batch analyze Auto Transform as I was hoping it would. In fact this is why the "Update" button exists. It appears when Sync->Transform->Upright Mode only is checked, because LR will not analyze every image included in the sync. You must manually "Update" the Auto Transform for each image you have synchronized with the setting.

I spent a couple hours on the phone and in Remote Desktop sessions with Adobe techs this morning until finally a tier 3 tech came in to let us know that what I was attempting to do is not possible.  This is a big disappointment and a huge PITA now that I have a couple thousand images in my workflow that I have to manually "auto" transform one at a time. I'm sure (praying) future versions of LR address this oversight.

Thanks again for trying to help,

Chris Miller

www.imagineimagery.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Nov 10, 2016 Nov 10, 2016

Copy link to clipboard

Copied

Adobe support is mistaken (a not infrequent occurrence). 

Here is a video showing LR CC 2015.7 properly syncing Upright Mode > Auto on 9 photos: https://dl.dropboxusercontent.com/u/21811200/sync-transform-auto.2016.11.10.mov.

I tried 100 photos and then 400 photos, in two different catalogs, a long-abused test catalog and a fresh catalog. I was able to reproduce your symptoms in the old test catalog -- I saw the Update button enabled on some of the photos after syncing.  However, I then selected all the photos and did Library > Previews > Build Standard-Sized Previews.  After the preview build completed, all of the thumbnails showed that Auto had been applied, and the Update button was no longer active.   And after a couple iterations of this, the symptoms stopped occurring altogether.

I think this bug is a variant of a problem that LR has long had with large-scale batch operations.  It tries to defer the recomputation of the thumbnails until they are actually visible in the Library grid, but sometimes it gets it wrong. For example, see this bug: Lightroom: Applying Auto Tone to a batch of photos loses subsequent develop settings | Photoshop Fam... The workaround for that bug is the same -- invoke Build Standard-Sized Previews.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 10, 2016 Nov 10, 2016

Copy link to clipboard

Copied

That's awesome man, I hope you're right. I have a couple thousand photos to test this out on tomorrow, will report back.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 03, 2019 Apr 03, 2019

Copy link to clipboard

Copied

After so long, the solution does not yet exist. I have the same problem. Would you like to know if you have found a solution to this problem?

Thanks again for trying to help,

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 04, 2019 Apr 04, 2019

Copy link to clipboard

Copied

The following recipe works for others, and I haven't seen a report of it not working:

1. Edit the first photo, and apply Transform > Auto.

2. In Library, select that photo and do Photo > Develop Settings > Copy Settings. 

3. Select just Upright Mode:

4. In Library, select the target photos and do Photo > Develop Settings > Paste Settings.

5. With those photos still selected, do Library > Previews > Build Standard-Sized Previews.

Step 5 is the crucial step for working around the bug.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 04, 2019 Apr 04, 2019

Copy link to clipboard

Copied

Unfortunately, even doing all these steps did not work out in my case. I've tapped the screen if you're interested in seeing my problem. https://youtu.be/_eevpquu0X0 But anyway, thanks for your interest in helping me!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 07, 2019 Apr 07, 2019

Copy link to clipboard

Copied

I noticed in your screen recording that Auto Sync was enabled in Develop. In my testing, I observe the same bad behavior with Auto Sync enabled, but when Auto Sync disabled, it works correctly. This is another variant of the bug I hadn't seen before.

So try this modified recipe:

1. Edit the first photo.

2. Turn off Auto Sync if it is enabled.

3. Apply Transform > Auto.

4. In Library, select that photo and do Photo > Develop Settings > Copy Settings.

5. Select just Upright Mode:

6. In Library, select the target photos and do Photo > Develop Settings > Paste Settings.

7. With those photos still selected, do Library > Previews > Build Standard-Sized Previews.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 07, 2019 Apr 07, 2019

Copy link to clipboard

Copied

It did not work again, at least we tried. Look at the video part 1 and part 2, there was the same problem. https://youtu.be/SKlsfGfzQZw https://youtu.be/M9Zc4NiYqPU Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 08, 2019 Apr 08, 2019

Copy link to clipboard

Copied

In Part 1, it looks like Auto Sync was enabled when you clicked Auto in the Transform panel.  In step 2 of my recipe, I turned off Auto Sync before clicking on Auto.  Try repeating the steps, making sure Auto Sync is disabled before clicking Auto.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 09, 2019 Apr 09, 2019

Copy link to clipboard

Copied

I did it again but it did not work. I do not think there's anything else we can do. I re-recorded the process so you can see. --- https://youtu.be/At6AHiD1K5A

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 10, 2019 Apr 10, 2019

Copy link to clipboard

Copied

Hmm, it's too bad we can't isolate what's going on with your configuration. You could file a bug report in the official Adobe feedback forum, where Adobe wants all product feedback: Lightroom Classic | Photoshop Family Customer Community . But if they don't have a precise recipe that reproduces the bug, then it's unlikely they'll take any action (unless many people reported the same issue).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 02, 2021 Mar 02, 2021

Copy link to clipboard

Copied

I just tried this on 150 photos. I guess you could say it worked in terms of something happening to each of them. The problem is that when doing this in batch mode, Lightroom seems to be 'horizon challenged', 'horizontal element challenged' and 'vertical element challenged'. It screwed up every photo and really recognized nothing noted as 'challenged' above.

 

I had manually re-crop each and every image. 

 

I find this a totally useless tool insofar as batch editing is concerned. A baby lining up toys in a crib ...does a better job!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 02, 2021 Mar 02, 2021

Copy link to clipboard

Copied

LATEST

There have been issues with Transform Sync and some have been fixed and others haven't.  See here and add useful comments and an exact description of your issue as Adobe monitors the Photoshop Family forum.  

https://feedback.photoshop.com/conversations/lightroom-classic/lightroom-classic-transform-doesnt-co... 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines