The Latest Version of Lightroom will not work anymore on my old iMac

New Here ,
Nov 15, 2020 Nov 15, 2020

Copy link to clipboard

Copied

I had the photography plan up until the last update when i got the message that it would no longer run on my iMac.  Therefore I cancelled my plan and reverted to a very old 2015 version of Lightroom Classic that I purchased and still have access to.  I cant afford to update my computer just yet so looking for a fix.

 

Missing all the facilities of the latest version I am trying to find a way to purchase a not so up to date version of LRClassic that will work as it did before the last update.  The Adobe conglomerate doesnt seem too helpful in finding a solution to my problem.

 

Any ideas on what approach I can take apart from swapping to the free Darktable, I have tried that but its not so intutive as lightroom having got used to that over the last 10 years.

 

Any helpful advice would be appreciated

 

Brian

 

TOPICS
Download and install, Mac, Performance, Problem or error

Views

63

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 15, 2020 Nov 15, 2020

Copy link to clipboard

Copied

What MACOS?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 15, 2020 Nov 15, 2020

Copy link to clipboard

Copied

LATEST

And why not simply revert to previous version? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines