Highlighted

Track Gallery Still Not Showing All Images

Participant ,
Nov 07, 2017

Copy link to clipboard

Copied

This is not a new issue, so I am surprised to not see others comment:

Render out a site using the Track web template, then open it up on desktop, mobile, etc. Scroll down the thumbnails page and you will see that very frequently not all of the images show up right away. It's the last bunch that are missing in action.

To get them to show up I can sometimes refresh the screen, but that usually doesn't work. Making the page view smaller, often smaller than the normal 100% is needed. This kicks it into action and boom, we see the last bunch of thumbnail image. What viewer is going to know such efforts are needed to see it all? None.

On mobile it is even worse. A gallery I just made and posted online had 175 image. Bringing it up on my desktop I was missing the last 5 or 7 or so images. But bringing it up on a few phones (mine and others), we only saw the first 5-10. And nothing we could think to do would allow the others to show up.

Views

316

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Track Gallery Still Not Showing All Images

Participant ,
Nov 07, 2017

Copy link to clipboard

Copied

This is not a new issue, so I am surprised to not see others comment:

Render out a site using the Track web template, then open it up on desktop, mobile, etc. Scroll down the thumbnails page and you will see that very frequently not all of the images show up right away. It's the last bunch that are missing in action.

To get them to show up I can sometimes refresh the screen, but that usually doesn't work. Making the page view smaller, often smaller than the normal 100% is needed. This kicks it into action and boom, we see the last bunch of thumbnail image. What viewer is going to know such efforts are needed to see it all? None.

On mobile it is even worse. A gallery I just made and posted online had 175 image. Bringing it up on my desktop I was missing the last 5 or 7 or so images. But bringing it up on a few phones (mine and others), we only saw the first 5-10. And nothing we could think to do would allow the others to show up.

Views

317

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 07, 2017 0
LEGEND ,
Nov 07, 2017

Copy link to clipboard

Copied

There are several issues with the Web Galleries.

Grid, Square and Track Galleries do not work well on Mac High Sierra

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 1
Participant ,
Nov 07, 2017

Copy link to clipboard

Copied

Hi Bob,

Yes and no. First off, you are correct, the issue is more than Track. I just found it with Grid, and probably Square as well.

But the thread you list is a different problem. That, from what I'm reading, involves viewing it in LR on a mac? I'm talking about what is happening when the EXPORTED and POSTED on a webpage.

There are even related issues with the Classic gallery, I believe. In that case, the page number links down below do not show all the numbers. For example, you may have 10 pages of thumbnails, but when you first come to the homepage, only 1-7 may be displayed as links. You don't get access to 8, 9, 10 until you are already on a later thumbnails page.

And as mentioned, I saw this with some of the web exports years ago, and still not fixed. This is mind-numbingly frustrating. Adobe is simply over extended for a long time now. Not a single application is as stable as they use to be. Even the venerable PS. Pity.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
LEGEND ,
Nov 07, 2017

Copy link to clipboard

Copied

I use the Classic Gallery a lot and I know the index only displays pages 1 thru 6 for me until you select higher page and then it displays more of the pages.  There is plenty of room to display all the pages.  It is probably not a bug but just a design decision.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 1
Participant ,
Nov 07, 2017

Copy link to clipboard

Copied

Yes, I used to use the classic a few years ago when I was doing a lot of client work and needed to post. It's been a few years and looking at that template now...it is just looking so 2005. The thumbnail images--on my 4k monitor--are so small, and the rest of it is so outdated looking. And I'm just guessing it isn't great on a mobile? Swipe support?

There has to be a better way to do this. This can't be the best pro solution in 2017.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
New Here ,
Jun 30, 2020

Copy link to clipboard

Copied

Found the solution!
The Track Gallery is the most-modern gallery that Adobe Lightroom Classic CC  (summer 2020) can make, however I encountered just like you the same problem: it won't load all images. Edge browser  works well. Firefox: 1-2scrolls and it stops loading images, instead of my 900images it shows just between 80 and 200 (depends on luck), Chrome: only current screen size.

Solution:
Go to your produced gallery folder and open "assets\js\" and open then "main.js". Look for line 216, it looks like that:

if(LR.images[i].$thumbnail.data("currentRowOffsetTop") < _$w.height() + 100){

Instead of "100" enter "100000" or another Scrooge McDuck gazillion. You will tell the script that your current screenresolution is extended by 1 million pixels (or gazillion), all thumbnails will be loaded at once. The Scrolling-Trigger still doesnt work, but you get to see all thumbnails.  Safe the file, and upload it on your FTP.

Another tip:
Right after "Export Gallery" I wait a minute and abort it. I export the images with my prefered resolution and replace the images in the folders "thumbnail" and "large".

For Adobe:
Fix this and add other galleries, really! I want to show my clients the photos on MY website in a password protected area, and not elsewhere.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 30, 2020 0