Highlighted

Wrong lens information

New Here ,
May 22, 2019

Copy link to clipboard

Copied

Since I updated Lightroom Classic to 8.3 the wrong lens information is shown in the metadata. I used a Sigma 50mm f/1.4 but LR calls it a Tokina opera.

Views

569

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Wrong lens information

New Here ,
May 22, 2019

Copy link to clipboard

Copied

Since I updated Lightroom Classic to 8.3 the wrong lens information is shown in the metadata. I used a Sigma 50mm f/1.4 but LR calls it a Tokina opera.

Views

570

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 22, 2019 3
Adobe Employee ,
May 22, 2019

Copy link to clipboard

Copied

Hi AndrCA9Dorst,

Sorry that Lightroom Classic is showing wrong lens information(specifically the lens name) after the recent update to 8.3 version.

Does the problem also occurs with any other Lens that you have?

Thanks,

Akash

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 22, 2019 0
Explorer ,
May 27, 2019

Copy link to clipboard

Copied

Hello Akash,

I'm not sure if anyone answered this question for you or not. As far as I can tell, the problem is only with the Sigma 50mm lens in my case. I don't have problems with other lenses.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 27, 2019 1
Community Beginner ,
Jun 17, 2020

Copy link to clipboard

Copied

The problem persists with LrC 9.3 and only with a Sigma ART 50mm lens.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2020 0
Adobe Community Professional ,
Jun 17, 2020

Copy link to clipboard

Copied

https://feedback.photoshop.com/photoshop_family/topics/incorrect-lens-name-for-sigma-50mm-f-1-4-art?...

 

The engineering team only very seldom visit this forum. So, use above link to report your issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2020 0
Mentor ,
May 22, 2019

Copy link to clipboard

Copied

LR's recognition of which interchangeable lens was used, depends on a Lens ID code that has been written into the metadata of the image (Raw or JPG) by the camera body.

It's also dependent on this code being in LR's own lookup lists. LR then displays whatever lens name it has, relating to that code.

Either a code has been electronically communicated by the lens to the camera body, or for non-electronic types of lens a more general coding is deduced by the camera body, working from physical properties of the lens (such as, whether it has got auto or manual aperture stop-down).

For lenses belonging to the camera brand, ID code is generally made to be unique so recognition is generally correct. For lenses by a third-party manufacturer such as Sigma or Tokina, the lens manufacturer may not, or may not be able to, ensure that this code is unique. If not, there may be several lenses in existence that all produce the identical lens ID code, from that camera model. So LR cannot distinguish them - and if LR's recognition list names one lens that produces that code, and you've actually used a different lens that produces the same code, the incorrect naming will show unavoidably.

The user cannot edit this recognition list. But the text shown can be altered in external metadata, and read back in, for example using the plugin "Lenstagger".

Regardless, whether the correct descriptive name shows or not, you can still associate (set as default) the particular lens profile that you want, to be used whenever this particular lens ID is found. So in this instance, you can make sure the Sigma profile gets used rather than a Tokina one.

When IDs are non-unique because of legacy lenses, one can use other clues in order to make the right thing happen. Example: my Pentax dslr reports "A series lens" whenever a lens is mounted that is pre-electronic, but that is mechanically detected to possess an auto aperture stop-down lever. And when such a lens was mounted and the camera turned on, the user was prompted to choose a focal length (to make shake reduction work properly). And this entered focal length gets passed through in the image metadata. So I can distinguish my different A series lenses within LR by focal length COMBINED WITH basic lens recognition, and then apply the needed lens profile for each photo. I then also keyword these particular lenses - so don't need to see the correct descriptive lens name in the usual field.

hth - RP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 22, 2019 1
New Here ,
May 22, 2019

Copy link to clipboard

Copied

Thanks for your answer. I already manually changed the lens profile. I understand what you're saying but I still think it's strange that LR used to recognise this lens and now suddenly thinks it is a different one. I'll give LensTagger a try.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 22, 2019 1
LEGEND ,
May 22, 2019

Copy link to clipboard

Copied

Old gray matter makes me think I ran into this before, way back before CC, it got fixed for the lens that was bothering me, an actual Canon lens. Work around was to select a lens manufacturer instead of auto or default .for make

Just another Adobe customer; My Sys; APP: LRC 10.0, PS 22.0; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.7; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 22, 2019 0
Mentor ,
May 23, 2019

Copy link to clipboard

Copied

You'll only need to select that correct lens profile once ever, though, if you follow up with 'save new profile default' - in the Lens Corrections panel / Profile / "setup" menu.

And make sure all new images arrive with a "Default" lens profile selection (not "Auto", not "Manual").

I do this within a preset applied during import. Already imported photos that don't show "Default", can simply have that set: the moment any photo says "Default", LR looks for any customised default lens profile - or failing that, does whatever "Auto" would have done.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 23, 2019 1
New Here ,
Sep 02, 2020

Copy link to clipboard

Copied

Did you find out what the problem was? I had a similar problem with Adobe Bridge showing the wrong lens, instead of showing a Canon 24-105mm it showed a Canon 70-200mm, the same thing happened when using my Canon 500mm. The problem in my case was a corrupt custom metadata template, once I had deleted it the problem was solved for downloads to Bridge. I later found after creating a new metadata template that you could apply it to the the image files displaying the wrong lens information and it would correct it. Try viewing the images files metadata in Bridge, chances are it will show the correct information, when I opened my files in a different application it showed the correct information. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 02, 2020 0