• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
13

P: 1 Syncing Photo Never Syncs

LEGEND ,
Aug 17, 2019 Aug 17, 2019

Copy link to clipboard

Copied

I have a problem with Lightroom CC (for Windows 10) perpetually showing that it is "Syncing 1 photo" (see screenshot below).

It seems that all my photos are synced, however. When I filter to show "Syncing" photos, no photos appear (see screenshot below). All my photos are in albums, and all my albums have the blue icon indicating that all photos in them are "Synced and stored locally." All my devices with Lightroom installed (including on the web) show the same number of total images.

I checked my diagnostic log. Under "Sync/Error Assets" an asset ID is listed. I found that asset ID in Managed Catalog.mcat and noted the associated filename. A photo with that filename no longer exists in Lightroom CC or my local backup drive. I had permanently deleted that file (i.e., I deleted the file and then also permanently deleted it from "Deleted Items"). When I tried to re-import an image with that same filename (just for testing purposes), Lightroom CC warned me about the duplicate image.

It seems that there might be a catalog database entry, but no image file to sync, hence the perpetual syncing. Does anyone know a way to remedy this situation (without taking unnecessarily drastic measures)? Thank you!

Steps I have taken unsuccessfully, thus far: Restart the program, restart my computer, pause/resume syncing, uninstall/reinstall Lightroom CC, install the prior version (2.3). Someone on a support chat suggested that I delete the local Managed Catalog files and let everything re-sync down from the web, but I do not want to do that if I don't have to (that solution seems unnecessarily drastic for such a relatively minor glitch).







 Note: This conversation was created from a reply on: Lightroom CC: Syncing stuck forever.

Bug Fixed
TOPICS
Windows

Views

917

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
57 Comments
LEGEND ,
Jan 14, 2020 Jan 14, 2020

Copy link to clipboard

Copied

Hi everyone,

I have been struggling with the same problem for some days. I migrated my Lightroom Classic catalog to the cloud-based Lightroom a couple of weeks ago. It took some time to upload my ~65k images, and has now finished, apart from 2 remaining photos which have been 'syncing' forever.

I tried several things:
  • I first tried to identify the 2 misbehaving items in the Lightroom desktop application on my mac, which had performed the migration. Selecting the "syncing"-filter showed me 0 results, and holding alt/option while clicking the cloud icon in the upper right corner doesn't do anything for me.
  • Scrolling through 65k photos to try to find the 2 syncing signs is not a viable option, so I skipped this approach.
  • I followed the approach described by Mike, by locating my Managed Catalog.wfindex database and opening it up in an SQL program to research the database. In my case, it appears as if the two problematic assets (which Asset ID's I could find in a diagnostic report I let Lightroom build) are stacks, just as was the case for Mike. My problem however, is that the Assets that are supposed to be in de stacks (the images, I assume), are nowhere to be found in the Asset-table in the database. I therefore still remain clueless as to where this is going wrong.
I'd be glad to hear any tips from you guys, or better yet, some help. It's a complicated issue, and I'd be very happy to make peace with my ever-turning syncing symbol.

Cheers,

Ewout

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 15, 2020 Jan 15, 2020

Copy link to clipboard

Copied

Received your log and forwarded to engineering for review. Stand by.
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
New Here ,
Jan 15, 2020 Jan 15, 2020

Copy link to clipboard

Copied

Thanks Rikk! Problem is solved. It was just a matter of spotting the picture causing the trouble.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 15, 2020 Jan 15, 2020

Copy link to clipboard

Copied

Glad you resolved it.
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
New Here ,
Jun 26, 2020 Jun 26, 2020

Copy link to clipboard

Copied

I have this issue. I found that using LRweb there was a file stuck trying to sync from an old phone. I have deleted that issue in LRWeb but it has not fixed my desktop machine on Windows 10. What can I do to get rid of the issue

Votes

Translate

Translate

Report

Report
LEGEND ,
Aug 29, 2020 Aug 29, 2020

Copy link to clipboard

Copied

Hi all,

I'm facing the same issue since a couple of days.

Followed instructions from above, deleted the pictures that was causing the issue, restarted LRC but now syncing is stuck on 10 remaining pictures with no apparent sync issues/ errors.

As some people indicated in the past: I'd be glad to hear any tips from you guys, or better yet, some help. It's a complicated issue, and I'd be very happy to make peace with my ever-turning syncing symbol.

Kind regards,
Dieter


Votes

Translate

Translate

Report

Report
Adobe Employee ,
Aug 31, 2020 Aug 31, 2020

Copy link to clipboard

Copied

Dieter,

Please go to Help>System Info... and get us the exact installed version number of your software. 
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
LEGEND ,
Aug 31, 2020 Aug 31, 2020

Copy link to clipboard

Copied

Lightroom Classic version: 9.4 [ 202008061458-dbb2971e ]
License: Creative Cloud
Language setting: en
Operating system: Windows 10 - Business Edition
Version: 10.0.18363

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Sep 01, 2020 Sep 01, 2020

Copy link to clipboard

Copied

You have Lightroom Classic - the thread to which you posted was for Lightroom Desktop - a different product.

Please reference the new conversation here: Lightroom Classic: 10 Pictures do not sync.
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
LEGEND ,
Sep 01, 2020 Sep 01, 2020

Copy link to clipboard

Copied

Also facing this issue—stuck on 1 photo syncing forever. Haven't been able to track down any sync errors or corrupted files (although my library is ~70,000 so hard to find by scrolling if that's the only way left). Any ideas?

Votes

Translate

Translate

Report

Report
Explorer ,
Sep 01, 2020 Sep 01, 2020

Copy link to clipboard

Copied

Here's how I fixed it:

Lightroom: Fix Never Ending Sync

  1. In Lightroom Desktop

    1. Edit > Preferences...

    2. With your cursor on Account..... ALT > Click

    3. Click on “Diagnostic Log”

    4. In the Dialog Box that appears Click “Generate Log”

    5. When you see a new Dialog Box that says “Diagnostic Log Generated”

      1. Click on “Show in Explorer”

    6. Open Log in Chrome (or some other method you use to open text files.) by double clicking on it.

    7. Click on... “Collapse ALL Sections”

    8. Scroll down to “Syncing and Error Assets”

      1. You should see a table with the photos that will not sync.

      2. Search LR for the photos in the table

      3. Export the problem photos Original or TIFF

      4. Delete the photos from LR

      5. Permanently delete the photos from the Deleted Album

  2. Done


Votes

Translate

Translate

Report

Report
LEGEND ,
Sep 05, 2020 Sep 05, 2020

Copy link to clipboard

Copied

Dear David, 

thank you for the assistance.

I followed every step and searched in this log but there are no Syncing and Error Assets... Find- instruction also give 0 as result

Kind regards,
Dieter

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 09, 2020 Oct 09, 2020

Copy link to clipboard

Copied

@david_quillman I did that a few times, each time getting more and more images in the report... so far I only reduced the counter of un-synced photos from 5 to 4... 

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 09, 2020 Oct 09, 2020

Copy link to clipboard

Copied

@Rikk I've emailed you my log.

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 09, 2020 Oct 09, 2020

Copy link to clipboard

Copied

@david_quillman I did few more iterations and removed few more and now I'm finally fully synced. Thanks man.

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

@Rikk  i facing the same issue too. how do i send you the log? email?

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 25, 2021 Mar 25, 2021

Copy link to clipboard

Copied

@Rikk I'm facing the same issue: 1 photo stuck in sync, no photos show up when I filter on "syncing" sync status, no sync issues show up on LR web, all deleted photos have been permanently deleted. Can I send you my log? If so, how?

Votes

Translate

Translate

Report

Report
Participant ,
Apr 23, 2021 Apr 23, 2021

Copy link to clipboard

Copied

I ran into this issue once more. But this time there is nothing hidden in trash, no syncing issue in LR web and Reset Lightroom preferences did not work too. In log I found in Syncing and Error asstets this:

I do remember the photo of this file name. I deleted it like 2 days ago. So LR is trying to sync something that does not exist (nor in trash which is empty).

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Apr 23, 2021 Apr 23, 2021

Copy link to clipboard

Copied

@dwbmb A diagnostic log would be needed to diagnose.

Close Lightroom 

Open Lightroom

Do nothing for 60 seconds and confirm the sync is still stuck

For LrDesktop

Go to Preferences

Account Section

Hold down the [Opt/Alt] key to make [Diagnostic Log] button appear.

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Participant ,
Apr 23, 2021 Apr 23, 2021

Copy link to clipboard

Copied

@Rikk You got it on your email.

Votes

Translate

Translate

Report

Report
Participant ,
Apr 23, 2021 Apr 23, 2021

Copy link to clipboard

Copied

Thank you @Rikk , Script worked instantly.

Votes

Translate

Translate

Report

Report
Explorer ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

I was having this same issue. Thanks to this thread, I was able to generate a Diagnostic Log, search for "Error Assets" and find a filename. Then search LR for that filename, delete it, then go to Deleted, find the same file, and delete it for good. 

Oddly, as soon as I did that, the issue reoccurred with another one from the same HDR bracket set, so I had to do it again. Someone upthread also mentioned that they triggered the problem with an HDR set, so maybe that's a clue for the engineers. 

Votes

Translate

Translate

Report

Report
Explorer ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

@Rikk I'm having the same Issue (perpetual sync of 2 files), and ran through every suggestion here. I got to the point where Syncing and Error Assets still show a count of 2 - but now there are no filenames in the report.

I'm happy to send a full diagnostic report to you if you feel you can help me resolve this issue. Thanks very much!

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 13, 2021 May 13, 2021

Copy link to clipboard

Copied

@ccirelli You should probably start a new thread too avoid confusion.  Please include complete system info

OS

Version

Lightroom Version:

a screenshot of https://lightroom.adobe.com

Thanks.  

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Explorer ,
May 13, 2021 May 13, 2021

Copy link to clipboard

Copied

Will do, THANKS so much Rikk. I'll get this posted this morning asap.

Votes

Translate

Translate

Report

Report