P: Image does not return from Photoshop to my Lightroom Desktop Catalog

5 Votes
Explorer ,
Dec 14, 2021 Dec 14, 2021

Copy link to clipboard

Copied

So I've successfully done all the updates mentioned, and attempted my first run with this process. It did NOT work.

36,191 images in my LR at the point of 'Edit in Photoshop' - PS launches, image appears, I make adjustements, duplicate a layer or two, close the file (and obviously agree to save the changes), image closes, and when I go back to LR (and wait a few mins to be sure), nothing has updated with the modified image. 

 

I still have 36,191 images in my library.

 

So, these updates have not made any difference to me. 

Bug Fixed
TOPICS
macOS , Windows

Views

1.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Jun 14, 2022 Jun 14, 2022
Greetings,   Updates to the Adobe Photography Products were released on June 13. The update contains a fix for this issue.  Please download and the latest version of your application via the Adobe Creative Cloud Application or your respective device app store. If you do not see the update (Mac and Win) you can refresh your Creative Cloud App with the keyboard shortcut [Ctrl/Cmd]+[Alt/Opt]+[ R ].    Note: App store availability can take several days for the update to appear and be available.   ...
Status Fixed

Votes

Translate

Translate
Adobe Employee , Feb 09, 2022 Feb 09, 2022
Moving status back to Acknowledged and adding new bug number. 
Status Acknowledged

Votes

Translate

Translate
45 Comments
Contributor ,
Apr 03, 2022 Apr 03, 2022

Copy link to clipboard

Copied

I'm following this thread. I just posted another bug report about this because it still isn't resolved. I started posting here about it back in November of last year. 

 

Oops, I see that my reply/report got added here. 

Votes

Translate

Translate

Report

Report
New Here ,
Apr 04, 2022 Apr 04, 2022

Copy link to clipboard

Copied

Switching to Rosetta does not solve the problem for me. The turnaround trip appeared to work the first time, but the layered Photoshop file was not saved in Lightroom. When I re-opened it in Photoshop, it was flat, and further changes were not saved back to lightroom.

Votes

Translate

Translate

Report

Report
Contributor ,
Apr 09, 2022 Apr 09, 2022

Copy link to clipboard

Copied

Well, turns out enabling Rosetta hasn't fixed it for me, either. It did for a while, but I just had a failed round trip this morning, and then another this afternoon—with Rosetta enabled. I hope Adobe can finally fix this. It has been an issue for a long time. 

Votes

Translate

Translate

Report

Report
Contributor ,
Apr 11, 2022 Apr 11, 2022

Copy link to clipboard

Copied

I'm wondering if anyone is experiencing this problem on an Intel Mac, or is it limited to Apple Silicon Macs? 

Votes

Translate

Translate

Report

Report
Contributor ,
Apr 12, 2022 Apr 12, 2022

Copy link to clipboard

Copied

New Photoshop update today doesn't look like it addressed this issue. https://helpx.adobe.com/photoshop/kb/fixed-issues.html

Votes

Translate

Translate

Report

Report
New Here ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

Hi, Im new to using Adobe software on Mac OS. I've been using it perfectly fine on Windows and iPad OS for the last couple of years. Since i've bought my new MacBook Pro 14" with M1 Pro running the latest version of Monterey OS i've ran into an issue with my usual workflow. I would usually start off in Lightroom as i find it easier to do quick initial edits and also organise albums easier. Then i select the "Edit In Photoshop" button which opens up fine and i can continue editing. Then usually im used to simply closing the file so it auto saves and it will import straight back into Lightroom and stack with the original file. For some reason though this isnt happening it prompts me to instead save it as a separate file inside Photoshop.

 

I've read through many other forums on this subject and none of the steps have worked.

 

The only fix i have found myself is to open both apps using Rosetta emulation and run the Intel version which does seem to resolve the issue however i assume this comes with performance impacts which i'd rather avoid since i've bought a brand new mac and want the full power.

 

Any ideas on when this will be addressed in an update to work fully on Apple Silicon.

Votes

Translate

Translate

Report

Report
New Here ,
Apr 18, 2022 Apr 18, 2022

Copy link to clipboard

Copied

Hi, Did you ever find a solution to this? I'm having the exact same issue at the moment. 

Votes

Translate

Translate

Report

Report
New Here ,
Apr 18, 2022 Apr 18, 2022

Copy link to clipboard

Copied

Unfortunately not! I had to adjust my workflow and export my Lightroom edits and import into photoshop in batches.

Votes

Translate

Translate

Report

Report
Contributor ,
Apr 18, 2022 Apr 18, 2022

Copy link to clipboard

Copied

Adobe has acknowledged this as a bug. For some (but not all) of us, running *both* Lightroom and Photoshop in Rosetta mode solves the problem. There is a slight performance hit, but for me, this is preferable to having to save images from Photoshop to a folder and then import them into Lightroom. 

 

I'd be curious to know if enabling Rosetta for PS/LR works for you?

Votes

Translate

Translate

Report

Report
New Here ,
Apr 18, 2022 Apr 18, 2022

Copy link to clipboard

Copied

I've not heard of Rosetta? Is that an apple thing? I'm using Windows.

Votes

Translate

Translate

Report

Report
Contributor ,
Apr 18, 2022 Apr 18, 2022

Copy link to clipboard

Copied

Oops, I assumed this thread (and bug) were specific to M1 (Apple Silicon) Macs. I didn't realize it also affects PCs. 

Votes

Translate

Translate

Report

Report
Contributor ,
May 17, 2022 May 17, 2022

Copy link to clipboard

Copied

@Rikk Flohr: Photography On Feb 9 of this year, you acknowledged this issue (images opened and edited in Photoshop from Lightroom not saving back to Lightroom) as a bug. It is now May 17. The problem still exists, at least for me and many other users. Has Adobe made any progress here? 

Votes

Translate

Translate

Report

Report
New Here ,
Jun 13, 2022 Jun 13, 2022

Copy link to clipboard

Copied

Hello, I am having similar issues. I have always run Lightroom and Photoshop off my 2017 MacBook Pro (2.8 GHz Quad-Core Intel Core i7) without issues of syncing between apps. It still currently works fine for me on this laptop. I recently upgraded to a 2021 iMac (Apple M1 chip) and am not able to get my PS edits to show up in LR but if I do it from my laptop it will sync on both computers. They were working fine before the latest PS & LR updates and now they no longer sync on the iMac.

 

I am running the latest updates to both PS & LR and macOS Monterey v12.4 on both computers. I have checked all settings to update them to be exactly the same because none of my settings from my laptop synced to my iMac. I cannot figure out how to fix this and see that many others are having this issue still too. 

 

I really need to get this working on my iMac to resume my work, my laptop does not have enough disk space consistently to continue running my PS files. Are there any updates on fixing this bug?

Votes

Translate

Translate

Report

Report
New Here ,
Jun 13, 2022 Jun 13, 2022

Copy link to clipboard

Copied

@Badly Drawn Boy  My Intel Mac works fine but my M1 is having the issues since the latest updates to PS & LR. How do you run the programs in Rosetta mode? I am not finding anything in the forums to explain this.

 

Also, I should note that I am also receiving this error message in LR on my 1Mac M1 after I select "edit in photoshop" from LR and then close PS after saving my edits (which are not imported back into LR), when I try to close LR I get an error message that there is an active edit in photoshop:Screen Shot 2022-02-08 at 7.18.45 PM.png

Votes

Translate

Translate

Report

Report
Contributor ,
Jun 13, 2022 Jun 13, 2022

Copy link to clipboard

Copied

@Victoria23857210ud73 You right-click on the name of the app in the Applications folder, and choose "Get info". There's a checkbox to enable Rosetta mode.

 

It's incomprehensible to me that Adobe has not addressed this given that the M1 chip has been out for 2 years now. And no one from Adobe will even respond to this thread (or any other about this topic) any longer. 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 14, 2022 Jun 14, 2022

Copy link to clipboard

Copied

Greetings,

 

Updates to the Adobe Photography Products were released on June 13. The update contains a fix for this issue.  Please download and the latest version of your application via the Adobe Creative Cloud Application or your respective device app store.

If you do not see the update (Mac and Win) you can refresh your Creative Cloud App with the keyboard shortcut [Ctrl/Cmd]+[Alt/Opt]+[ R ]. 

 

Note: App store availability can take several days for the update to appear and be available. 

 

Thank you for your patience.

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Bug Fixed

Votes

Translate

Translate

Report

Report
Contributor ,
Jun 14, 2022 Jun 14, 2022

Copy link to clipboard

Copied

Updating now. Eager to see if this solves the problem. 

Votes

Translate

Translate

Report

Report
Contributor ,
Jun 14, 2022 Jun 14, 2022

Copy link to clipboard

Copied

I just did 4 Lightroom > Photoshop round trips, with Photoshop in native M1 mode (not Rosetta). They all worked! I'm cautiously optimistic... but, I've had stretches in the past where it worked and then stopped working again, so I'm reserving judgment until I use the apps a bit more. 

Votes

Translate

Translate

Report

Report
New Here ,
Jun 14, 2022 Jun 14, 2022

Copy link to clipboard

Copied

Will be trying this out tomorrow. Thanks for the update

Votes

Translate

Translate

Report

Report
Participant ,
Jun 15, 2022 Jun 15, 2022

Copy link to clipboard

Copied

LATEST

So far the new update has worked as expected. I will continue to test over the next week to ensure it is consistent.

Votes

Translate

Translate

Report

Report