Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Installed the 10.3 newest version of LR and it is SLOW!!!! So SLOW!!!! It's impossible to work!

Explorer ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

Against my better judgement, I installed the newest version of Lightroom Desktop (Classic) 10.3 (13.3 camera raw). I previously had the very stable and fast version 9.4, but since that version didn't support the Nikon mirroless images I had to upgrade without doing a whole bunch of shenanigans to get LR to injest the mirrorless files into a catalog. 

 

Here are the issues with 10.3 (this seems to always be a thing whenever a new version comes out!) 

- healing brush is slow as molasses, it's basically impossible to work at that speed! When I apply my preset and then try to zoom in on a face, and some other areas to remove some things, there's a 3-5 second delay in when removing anything. LR basically freezes up

- zooming in and zooming out (esp. if you need to use the spot heal / healing brush or smoothing of skin brushes) slows things down to a crawl

 

Things are so slow I'm ready to pull my hair out! It's taking me more than twice as long to edit same images as before! 

 

Is there an update coming out to improve the speed????!!! I can't work like this and I have so many weddings to edit! This is the heart of the busy season and since I have a 2nd shooter with a mirrorless I have to be on a newer version of LR. Plus... now I have a whole bunch of upgraded catalogs that I can't roll back without loseing my edits... So, I'm stuck. 

 

Dear Adobe, PLEASE step up your game when it comes to upgrades! This happens literally every single time a new version comes out! It's like you put out some new (useless updates), and break everything else in the process, the speed of the spot healing brush and zooming in and out is literally a problem with every single new version. Do your people not test things things before they are released?? Seriously! 

 

Ester 

TOPICS
Bug, Enhancement, Feature request, General Feedback, Release Notes

Views

25

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

I'm afraid complaining here won't help. Adobe developers do not frequent these forums.

 

I suggest you try https://feedback.photoshop.com/topics/lightroom-classic/5f5f2093785c1f1e6cc40872 where you can provide feedback, feature requests, and bug reports for the Lightroom Classic.


The Using the Community forum is for help in using the Adobe Support Community forums, not for help with specific programs. Product questions should be posted in the associated product community.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2021 Aug 02, 2021

Copy link to clipboard

Copied

LATEST

I've moved this from the Using the Community forum (which is the forum for issues using the forums) to the LR forum.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines