• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

iPad: extremely long lag time when applying edits

New Here ,
Aug 20, 2023 Aug 20, 2023

Copy link to clipboard

Copied

Over the past few months there's been a huge decline in usability on Lightroom for iPad: extremely long lag time when applying edits (especially when trying to create and edit masks and to create named versions), frequent crashes, no longer reliably syncing with my computer, etc. This renders the app almost unusable.

 

I've checked repeatedly for app updates and have installed them as they come out, and the OS for both my iPad and my computer is fully up to date as well. I've restarted all devices several times, contacted Adobe support multiple times and every time been walked through troubleshooting steps I'd already taken on multiple occasions.

 

Many of the recent reviews for iPad Lightroom in the app store are one- and two-star reviews expressing similar sentiments about functionality issues with various app components, so I'm confident this is not an issue with my account, devices, or usage.

 

I first noticed it got REALLY bad in May, but even before then I had been noticing some slowing down, lagging, sync issues, etc.

TOPICS
iPadOS , macOS

Views

54

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation