Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom is terribly slow on recent computer but fast on old

Explorer ,
Feb 08, 2021 Feb 08, 2021

Copy link to clipboard

Copied

Hi

I have a dell XPS13 9360 - i5 7200u, intel graphic card, 8Go of ram, screen 2K. Lightroom is running awfully slow on it - it is barely usable. This slowness shows the most on the grid view and with very long loading times.

I thought my PC wasn't powerful enough, but here I tested :

Macbook 4,1 (2008) - intel Core 2 duo, intel graphic card, 4 Go of ram, windows 10 installed. And everything is quite smooth and usable - but the screen is terrific for photography.

 

Does anyone have an idea why a more powerful PC struggle where this old mac on windows10 runs smoothly ? I reinstalled entirely windows, but it does the same thing. Maybe it's because of the screen resolution ?

TOPICS
Crash or freeze, Performance, Windows

Views

73

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

LATEST

I have the same problem (maybe only my laptop has better parameters (i-7, 16GB RAM, SSD): I only replaced the disk (for SSD NWMe 2TB), installed Win10 x64 20H2.
LR 6 dramatically slowed down. Oddly enough, not immediately (after installing), but the next day, almost certainly after some automatic software reinstallation.
Now even reinstealing LR6 doesn't help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines