Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom lagging, functions not working, extremely slow

New Here ,
Apr 24, 2021 Apr 24, 2021

Copy link to clipboard

Copied

Hi All,

 

Since the new subscription based lightroom, the program has just got WORSE

 

But this week it has been extremely laggy and slow. Problem such as photos not loading, can't create new folders, albums, moving photos, deleting photos, changing views, cropping etc etc.

 

Not even half of my RAM is being used and only 5% of my CPU is being used so it's not my computer.

 

I have updated my Nvidia graphics cards drivers, updated lightroom..

 

What is going on? Anyone else with the same problem? 

 

I'm ready for cancelling and switching to another platform if anyone can recommend something similar to lightroom?

 

Thanks

TOPICS
Bug, Crash or freeze, Performance, Problem or error

Views

272

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

Hi,

I have similar problems with Lightrooms Classic. After more than one week of searching for the cause I detected a crucial difference: when my NAS with the original photos is connected everything works fine. When I disconnect my NAS LRC is as slow as a snail. Can you confirm this behavior?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

LATEST

That's the best place to post as that's monitored by the engineering team whereas this forum is predominantly a Users one, although you may get help.

 

Also this is the cloud based Lightroom forum.... for Lightroom Classic it's probably best to post here in future.... https://community.adobe.com/t5/lightroom-classic/bd-p/lightroom-classic?page=1&sort=latest_replies&f...

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

Mine the same. I subscribed and it Immediately stopped working. When I redos loaded my app all my pictures and presets where gone and I'm unable

to use any features. Very frustrating 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines