Mystery suffix numbers added to files

New Here ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

After adding metadata and changing the file size I Export only to find that a number has been added to the end of my file details  - such as when it is first entered it might be 1234FILE  but when Exported it will appear as 1234FILE - 1   and progresses onward.  So if I do the similar the next day it could well be  12345FILE - 5    and so on.  

 

Help me with the mystery please. 

 

Des E 

TOPICS
Problem or error

Views

412

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

There are a couple of things which could cause this, if you post a screenshot of the export dialog we'll probably be able to be more specific.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Thanks Jim.

 

do I someow attach the screen shot to a reply?   (to be honest I'm always messing up screen shots -  is it written as a text file or what?

 

Des

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

I cant do a screen shot of the whole of the Export area, it would have to be done with three I think

 

Des. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

I think I managed a screen shot in one.

 

see attached png.

 

 

Des. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Thanks, but there's nothing that I can see in those export settings which could cause the problem that you described. So, to be perfectly clear....are you saying that if you proceed with that export (exporting the file "E in Melbourne Derbyshire 01.xxx") you will end up with the exported file having the name "E in Melbourne Derbyshire 01-1.jpg"?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Not only that, but during today with several other files, the numbers jumped from  - 1   to  - 7.  Although its most inconsistent it usually follows a pattern of starting with a lower number first then building up.   I'm just going to do another test with a file that has never gone into LR.   In fact I am going to just take a pic on a small digital camera and read the file from the card without giving it my usual file number.   Back soon. 

 

 

Des. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

As I said - erratic.     I have just Exported a file from a digital camera onto the Desktop and not a sign of a suffix number.   I then renamed that file and Exported to an folder on the Desktop (this I usually do with my LR files) and again not a smell of a end number.   There is just no accounting for this behaviour but it is frustrating when it happens especially if one is working with a quantity of images. 

 

 

 

Des

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

I can think of only two or three circumstances whereby sequence numbers are added during export:

 

1. You export the same file to the same folder over and over without any renaming during the export. Because the operating system won't allow two files with the same name to exist in the same folder, LrC has various ways of dealing with that option using the "Existing Files" drop-down list, and one of them would cause an automatic incremental sequence number (-x) to be added to the exported file, so that the filenames differ. However, you have that option set to "Skip", which means that if LrC detects the output filename already exists, the export of that image is skipped, i.e. not processed.

 

2. There are a couple of rename options that could cause the incremental sequence numbers: one adds a sequence/index number during export (e.g. 01, 02, 03 etc.), the other uses the same filename everytime so that it comes into the same category as the first issue. But your export settings show that you are not renaming during export.

 

If you are always using the same settings, then it's a mystery to me why this problem occurs. Perhaps you are using different export presets?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Thanks Jim.

 

Let me read and digest your suggestions first.  Will have to now do this tomorrow though.  And if I may then get back to you.     Just one that you could clarify now and that is: " Perhaps you are using different export presets "

 

Could you give me an example of this so that I can look into it more. 

 

Regards, 

 

Des. 

 

P.S.  Any reason you can think of as to why when reinstalling that the serial number is not asked for?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

quote

Just one that you could clarify now and that is: " Perhaps you are using different export presets "

 

Could you give me an example of this so that I can look into it more.  

 

P.S.  Any reason you can think of as to why when reinstalling that the serial number is not asked for?

Presets do as the name suggests, i.e. if you frequently use different export settings, you can save those as different presets (they would then appear under the "User Presets" list, see the left hand column of the export dialog box), so that you don't keep having to change the settings each time you export, you'd just select the specific preset. But, given that you had to ask about them, then I guess you don't use them.

 

The serial number business.....I'm pretty sure that once you've entered the serial number and it's been validated, it's actually stored in Program Data/Adobe/Lightroom where it will be referenced when launching after a re-install....so no need to keep asking for it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Hi Jim,

 

I think I've more or less sorted this issue out.   It would seem that when I Import files that I have actioned earlier that the suffix numbers appear in sequence - 1   -  2  -  3  etc. on each occasion I make amendments to the size or metadata.  Clue is in the top presets before Exporting.     I will just have to change my method of working and this should now solve it.   

I've also decided not to take any risks with messing about with Adobe files already installed and live with what I've got.   

 

May I thank you very much for the time you have afforded me.   It gets lonely at times working on ones own and its a relief to have some help.     Best wishes,  keep well.     Des E Gershon. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

It sounds as though your workflow could be improved, as it appears you edit, export, import, edit, export, import, edit, export, etc....all using the same filename. If that's correct you need to understand that there are more efficient ways of working.....generally speaking one need only export when one is satisfied that the editing of the original is complete. If, after exporting the image you then find that you should have included some additional edits, do not re-import the exported file, simply go back to the original file and apply the extra edits. Then export it again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

I've suspected for some time now that my workflow is far from perfect.  Its just that I've got into a routine that clearly now needs tidying up.   Though what you have suggested as a workflow seems very similar to what I have been doing.  May I outline how I work and then maybe you can spot the errors for my benefit?  I could save space possibly by attaching a word file for your perusal, mainly as it may take too much space here. 

 

Des.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Ah! Bingo.    I have now Imported those last two files and then Exported into and different folder and each have the suffix as   -2.    I am also going to do the same but Export to the first folder and see what they arrive as - hold on -  They arrived as the same  -2.   I somehow expected them to be -3    but no.   

 

By the way, I should add that I am using LR 4.1  which is my original from disc.  I have also tried about eight times now to uninstall and reinstall thinking it might clear the problem.  The oddity is that during the installation there was no serial number asked for. This was using my PC.   By way of experiment I then tried to install into my MAC (I dont use this very often believe or not) and then I had to provide the serial number.  Very odd all of this. 

 

Des. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 15, 2021 Jun 15, 2021

Copy link to clipboard

Copied

LATEST

I've had first class attention from the ADOBE Community Professional.   Thanks so much.

 

Des E Gershon. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines