Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Old version of LR

Explorer ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

I need to install LR on my old MacBook Pro running 10.11.6 what version of LR will work on theis old computer and where can I get the download?  I have a photo shoot tomorrow and my not mush newer mac keeps quicking on me

 

 

TOPICS
Download and install, How to, Mac

Views

185

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

Hi DomCIRWS,

 

With Mac 10.11.6 latest Lightroom 10.3 version is not compatible hence you can install Lightroom version 6. Below is the link you may download the setup and install it. Once installed try activating it with your Adobe ID if you have subscription or enter the serial if you have that. You can follow the below article to get the serial no. and download like for standalone version:
https://helpx.adobe.com/download-install/kb/downloaded-older-app.html
Lightroom 6 Mac setup:
https://shared-assets.adobe.com/link/31ccc0f8-0f6c-497b-51eb-b34bb71f975e 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

thank you i'll give it a try

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

Looks like version 6 is not compatible with 10.11.6, I had LR version 5 installed on here years ago.  

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

The following link includes links to Lightroom 5.7.1 which was the final update for Lightroom 5. As far as I know, the links are still valid. But I haven't checked them for quite some time.

Links to previous versions of Lightroom 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

LATEST

Please check Lightroom system requirements as per it LR 6 is compatible with Mac OS X v10.11 (El Capitan), macOS v10.12 (Sierra), or macOS v10.13 (High Sierra)**

Please refer below helpx article


https://helpx.adobe.com/in/lightroom-classic/system-requirements/earlier-versions.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines