• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Planning to Change from Lightroom Classic to Lightroom

Explorer ,
Jul 11, 2022 Jul 11, 2022

Copy link to clipboard

Copied

Hello, I'm certain that I'm simply thick and lack the time, but I've completely given up on the Lightroom Classic plan I'm currently using. The editing tools are exceptional and easy to use, but the catalog aspect is to me sadistic and unintelligible and I've given up.

 

I'm on a 2015 Macbook Pro 2.7 Ghz retina with 8 gbs ram. Could someone describe the editing tools available in the Lightroom program that are only found in Lightroom Classic, for example, is the masking tool available in Lightroom, or is an M1 Mac required to use it?

 

Thanks!

TOPICS
macOS

Views

35

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 11, 2022 Jul 11, 2022

Copy link to clipboard

Copied

You will find the System requirements here- but I doubt you 2015 MacBook will be compatible (OS?).

https://helpx.adobe.com/lightroom-cc/system-requirements.html?promoid=2K4PCHD1&mv=other

2022-07-12 08_29_44-Lightroom system requirements — Mozilla Firefox.jpg

The Editing features are mostly similar in both LrC and Lr and you will find a comparison chart in this link-

COMPARE LR & LR-CLASSIC (Lr Queen)

And you can use the 'Migrate' tool to convert a LrC Catalog to a Lr (Cloud based) version.

That decision is yours to make.

 

Your current Photography Plan would include both LrC and Lr. It might be worth syncing some files in LrC Collections and viewing these in Lr IF possible! You would need LrC v10.4 to sync!

https://helpx.adobe.com/lightroom-classic/kb/sync-faq.html

 

Regards. My System: Lr-Classic 12.0.1 Photoshop 24.0.1, ACR 15.0, Lightroom 6.0, Lr-iOS 8.0.8, Bridge 13.0, Windows-11.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 11, 2022 Jul 11, 2022

Copy link to clipboard

Copied

LATEST

Thanks, that really helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines