Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Roundtrip to PS is always flattening the file if LR is using native code for Apple-silicone

Explorer ,
Nov 18, 2021 Nov 18, 2021

Copy link to clipboard

Copied

If I roundtrip to PS the resulting file always gets flattened if opened again with "Edit in Photoshop".

The issue is the following:

  • Selecting RAF
  • Choose to edit in PS
  • Editing in PS adding layers, ...
  • Saving in PS and closing PS
  • Edited file appears in LrC
  • Selecting the edited TIF-file
  • Choose "Edit in PS" again
  • File opens up in PS without layers and a new version ist generated (Filename contains "Edit-Edit")

Starting LR using Rosetta everything works as expected.

 

Lightroom Version: 5.0 arm64 [ 20211012-0002-a1240ed ] (Oct 12 2021)

Operating System: macOS 12 Monterey

TOPICS
macOS

Views

75

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

If I roundtrip to PS the resulting file always gets flattened if opened again with "Edit in Photoshop".

The issue is the following:

  • Selecting RAF
  • Choose to edit in PS
  • Editing in PS adding layers, ...
  • Saving in PS and closing PS
  • Edited file appears in LrC
  • Selecting the edited TIF-file
  • Choose "Edit in PS" again
  • File opens up in PS without layers and a new version ist generated (Filename contains "Edit-Edit")

Starting LR using Rosetta everything works as expected, i.e. the previously edited file opens with layers intact.

 

Lightroom Version: 5.0 arm64 [ 20211012-0002-a1240ed ] (Oct 12 2021)

Operating System: macOS 12 Monterey

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

I posted this issue as an error twice, but Adobe staff keeps changing it to "Discussion". Why this???

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

The reason it is in Discussions is that it hasn't been confirmed as a Bug. So far, I cannot replicate the issue you are reporting. 

 

As long as no edits are performed on the returned from Photoshop Tiff file, it opens again with all layers intact. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Understood, thanks. Did you try on an M1 Mac? When I try in native mode the problem appears, if I start LR in emulation mode using Rosetta it works as expected. I use a MacBook Pro with M1 Max.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Tested 2017 MBP (Intel) 11.6.1

Tested 2020 MBP (M1) 12.0.1

 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Really strange. Any idea what could possibly be wrong on my side? Already reset prefs in LR and PS. Would a screen recording help?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 27, 2021 Nov 27, 2021

Copy link to clipboard

Copied

LATEST

I did a screenrecording to show the issue

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines