Highlighted

Can I or How do use the catalog from older LR 7.5 to work with LR 3.1

New Here ,
Jan 06, 2020

Copy link to clipboard

Copied

Need help, here is my situation.  I have tried to find an answer with no luck, so I am going to ask here. I'm an intermediate user on Lightroom. I just moved to a new Win 10 PC. My old machine was Win 8, so I was running LR 7.5. Running old Windows 8 and the subscription indicated the newer versions of LR were incompatible. This year I get a new machine running Windows 10. With the creative cloud subscription and Win 10, it will only allow me to install the new LR 3.0 or 3.1. My question is Can I or How do use the catalog from older LR 7.5 to work with LR 3.1 when I can't get either machine to the current or earlier versions of LR? Can you point me in the right direction? What would be my next steps?  Do I have to rebuild the LR 3.1 catalog? All photos and 7.5 catalog are on an external drive.

 

I have been using LR since 2012 and only as a hobbyist. Never have had problems with different OS and different LR versions like this.

Thank you in advance for any help.

 

Topics

How to, Windows

Views

72

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Can I or How do use the catalog from older LR 7.5 to work with LR 3.1

New Here ,
Jan 06, 2020

Copy link to clipboard

Copied

Need help, here is my situation.  I have tried to find an answer with no luck, so I am going to ask here. I'm an intermediate user on Lightroom. I just moved to a new Win 10 PC. My old machine was Win 8, so I was running LR 7.5. Running old Windows 8 and the subscription indicated the newer versions of LR were incompatible. This year I get a new machine running Windows 10. With the creative cloud subscription and Win 10, it will only allow me to install the new LR 3.0 or 3.1. My question is Can I or How do use the catalog from older LR 7.5 to work with LR 3.1 when I can't get either machine to the current or earlier versions of LR? Can you point me in the right direction? What would be my next steps?  Do I have to rebuild the LR 3.1 catalog? All photos and 7.5 catalog are on an external drive.

 

I have been using LR since 2012 and only as a hobbyist. Never have had problems with different OS and different LR versions like this.

Thank you in advance for any help.

 

Topics

How to, Windows

Views

73

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 06, 2020

Copy link to clipboard

Copied

Lightroom 3.1 is the version of Lightroom that you use if you want all of your images in the cloud. Is that what you want? Lightroom Classic is the version of Lightroom that is more like what you were using previously, a local catalog with your images being stored in folders on your computer. Adobe has gone through a name changing exercise that has proven to confuse users considerably. So the question is, do you really want to go all cloud, or would you prefer to have Lightroom functions similar to how it did previously? Lightroom Classic WILL run on your Windows 10 PC. It runs on my Windows 10 PC without a problem. So please clarify what it is that you want to switch to.

 

I might add that Lightroom Classic will upgrade your catalog that you have been using and create a new copy of it will be compatible with Lightroom Classic, keeping all of your work including any collections and all of your keywords intact. You won't lose anything by switching to Lightroom Classic.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 06, 2020

Copy link to clipboard

Copied

Jim, 

Thank you.  Just was looking at that and realized duh, I need to install LR 9.1 for the desktop app.  Of course I realize that the minute after I post.  Anyway, when LR 9.1 upgrade can I use my old 7.5 catalog?

 

Thanks again, 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 06, 2020

Copy link to clipboard

Copied

Yes you can. After you install Lightroom Classic and run it for the first time, it will recognize your old catalog and notify you that he needs to be upgraded. Allow that to happen. Classic will create a new copy of that catalog that will have all the work that you have done previously. It will have the same name as the old catalog but will have a -2 appended to the name. The old catalog will remain, and after you have verified that everything is working as it should you may confidently get rid of it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 06, 2020

Copy link to clipboard

Copied

Great thank you again for your time.  I haven't had trouble in the past so I expect it to go smooth.  

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...