Cannot Import into Lightroom CC - Identified as a Duplicate, but Isn't!

New Here ,
Jan 20, 2020 Jan 20, 2020

Copy link to clipboard


Alongside some issues I've got migrating my Apple Photos library, I've been manually importing some big albums to hopefully ease the migration challenge later...  this is for Lightroom CC from the Mac App Store on a Mac (all latest versions).


With a small number of photos (probably 1 in 1000 or so) I'm finding that Lightroom won't let me import them - it's happy (i.e. not greyed out) in the "Review for Import" window, but after pressing "Add Photos" it comes up with an error saying it couldn't import them because they're duplicates.  Now I've checked, double checked, looked at all photos by date, checked the Lightroom Originals folder on my disk, and the photo definitely absolutely isn't already in my library.  Sometimes there will be another with the same filename, though usually not - and definitely nothing else with the same filename on the same date.


Is there anything I can do to force it to import, even though it thinks its a duplicate?  Or at least get it to tell me what it thinks the duplicate is, because it's definitely not there.  I've gone back and tried to import a single photo, on its own, but get the same result.  I've also tried it with and without its XMP sidecar file.


Any ideas very welcome.  Thanks!

Bug, Mac, Problem or error








Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation