Highlighted

Catalina and Lightroom

New Here ,
Dec 03, 2019

Copy link to clipboard

Copied

I recently upgraded to Mac OS, Catalina, and am now experiencing problems with Lirghtroom CC.  Specifically, color corrections are not working properly and images,when being edidted are somewhat "jerky" and behaving inappropriately. In the limited research I have done, it was recommended to turn the Graphics Processor off.  I have done this and the color ccorrection seems to work better (more accurate), but when in the Develop Module, responses are very slow and again "jerky" along with other inappropriate behaviors.  I have an iMac (2017 Model) with a Radeon Pro 575 - 4 GB graphics processor.

 

It is important to note I never have had any problems with Lightroom CC with previous Mac OS system versions.  This all started after the Catalina upgrade.

 

I have been unable to locate any "Contact Us" information for Radeon to inquire about driver updates.  It appears that information about driver updates for the processor I have in my iMac is not available.  I was hoping there is a driver download that will enable an update of the processor and allow me to activate the graphics processor again.

 

Is anyone else experiencing these or similar problems with Lightroom and the Catalina OS?  And if so, do you have any recommendations/solutions?

 

Thanks


Tom

Topics

Collaboration

Views

181

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Catalina and Lightroom

New Here ,
Dec 03, 2019

Copy link to clipboard

Copied

I recently upgraded to Mac OS, Catalina, and am now experiencing problems with Lirghtroom CC.  Specifically, color corrections are not working properly and images,when being edidted are somewhat "jerky" and behaving inappropriately. In the limited research I have done, it was recommended to turn the Graphics Processor off.  I have done this and the color ccorrection seems to work better (more accurate), but when in the Develop Module, responses are very slow and again "jerky" along with other inappropriate behaviors.  I have an iMac (2017 Model) with a Radeon Pro 575 - 4 GB graphics processor.

 

It is important to note I never have had any problems with Lightroom CC with previous Mac OS system versions.  This all started after the Catalina upgrade.

 

I have been unable to locate any "Contact Us" information for Radeon to inquire about driver updates.  It appears that information about driver updates for the processor I have in my iMac is not available.  I was hoping there is a driver download that will enable an update of the processor and allow me to activate the graphics processor again.

 

Is anyone else experiencing these or similar problems with Lightroom and the Catalina OS?  And if so, do you have any recommendations/solutions?

 

Thanks


Tom

Topics

Collaboration

Views

182

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation