Lightroom 4.2 not compatible with MAC High Sierra?

New Here ,
Apr 05, 2021 Apr 05, 2021

Copy link to clipboard

Copied

I am trying to use Lightroom 4.2 on my MAC OS High Sierra and it is telling me that it is not compatible.

I was able to use it a few weeks ago and now I cannot open LR.  Help!

TOPICS
Problem or error

Views

64

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

In the Creative Cloud app if you select the three dots next to Lightroom and select other versions you should be able to install version 3.4

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

LATEST

The mimum requirements for Lightroom desktop 4.1 and later are specified at the following link https://helpx.adobe.com/uk/lightroom-cc/system-requirements.html You'll note that macOS Mojave 10.14 or later is required with Catalina or Big Sur recommended. Therefore, if you wish to keep using 4.2 you'll need to upgrade the operating system accordingly. If you can't do so, then you also have the option of downgrading Lightroom to 4.0. This can be done via the Adobe Creative Cloud application. Follow below steps:

 

1. Launch the Creative Cloud app

2. Locate Lightroom on the list and click on 3-dots menu on right side

3. Choose 'Other Versions'

4. The following dialog should appear

5. Choose version 4.0

 

Untitled-2.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines