Lightroom and Photoshop compatibility with an iMac 2011

New Here ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

Does Lightroom and photoshop work on an IMac 2011? I found one which is a good offer but I need to be able to edit on it.

TOPICS
Mac

Views

39

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 25, 2021 Feb 25, 2021

Copy link to clipboard

Copied

Hi there,

 

Please checkout the system requirements for Lightroom Classic, Lightroom Desktop and Photoshop below and ensure that your computer meets the recommended specifications requirements: 

 

https://helpx.adobe.com/photoshop/system-requirements.html

https://helpx.adobe.com/lightroom-classic/system-requirements.html 

https://helpx.adobe.com/lightroom-cc/system-requirements.html

 

Hope that helps!

 

Thanks,

Akash

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 25, 2021 Feb 25, 2021

Copy link to clipboard

Copied

It's more than likely the the iMac will only upgrade to Mac OS 10.13.


The latest versions will not run on this, although you can currently download older versions, although I'm not sure for how long. To future proof yourself I would go for something a bit newer if possible.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines