Highlighted

Lightroom CC not compatible with older iOS systems

New Here ,
Mar 27, 2019

Copy link to clipboard

Copied

Hi! Just paid for the Lightroom CC 1T yearly payment- method... Then, it shows that I cannot install the application due to my old computer software (Mac iOS). I would like to withdraw the payment, or get the money returned, since my old MacBook isn't compatible with any of the latest software updates from Apple. This should really be stated by Adobe in advance of the payment, as well.

Views

123

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lightroom CC not compatible with older iOS systems

New Here ,
Mar 27, 2019

Copy link to clipboard

Copied

Hi! Just paid for the Lightroom CC 1T yearly payment- method... Then, it shows that I cannot install the application due to my old computer software (Mac iOS). I would like to withdraw the payment, or get the money returned, since my old MacBook isn't compatible with any of the latest software updates from Apple. This should really be stated by Adobe in advance of the payment, as well.

Views

124

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 27, 2019 0
99jon LATEST
LEGEND ,
Mar 28, 2019

Copy link to clipboard

Copied

Contact Adobe support directly. Click the link below and scroll to the bottom of the page and under individual, click sign in to contact us. You should be able to start an on-line chat session.

https://helpx.adobe.com/support.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 28, 2019 0