Lightroom Premium not getting activated and showing "Start Trial" message

New Here ,
May 19, 2020 May 19, 2020

Copy link to clipboard

Copied

I purchased Lightroom premium in order to use the selective feature a little while ago. It worked once then but I tried to use it again today and it is saying I am not a premium user. Then, when I continue to "Start Trial" it says that I am "currently subscribed to this" already, as I thought. Therefore I am still paying monthly but am unable to use any of the features that I'm paying for. If there is a way I could fix this it would be greatly appreciated! Thank you. 

TOPICS
Feature request, Performance, Problem or error

Views

396

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 19, 2020 May 19, 2020

Copy link to clipboard

Copied

Hi there,

 

Sorry that Lightroom Premium is not not getting activated on your device. Are you using a iOS or Android device? 

 

Please checkout the steps mentioned in this article https://helpx.adobe.com/lightroom-cc/kb/lightroom-mobile-in-app-purchase-issue.html and let us know if that helps?

 

Thanks,

Akash

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines