Mac OS upgrade

New Here ,
Mar 21, 2021 Mar 21, 2021

Copy link to clipboard

Copied

Hi. Can someone give me some advice on what MAC OS I should upgrde to so I can update my LR to the current version? 

I am currently running Sierra 10.12.6. I am paying for my LR/Photoshop and my os is not compatible (am still using the oler version). I dont know very much about this so I am looking for a relatively simple solution here.

Thank you for any help that anyone can provide.

TOPICS
Download and install, FAQ, Mac, Performance, Problem or error

Views

35

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 21, 2021 Mar 21, 2021

Copy link to clipboard

Copied

You'll need to run Mojave or newer to run the latest versions.

warmly/j

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines