Highlighted

Missing photos in Lightroom library

New Here ,
Jun 25, 2020

Copy link to clipboard

Copied

Hello all,

I launched Lightroom today to find the most recent photo in my library was taken over 10 days ago. The others I had added since then are all missing. A real travesty if this is the case. I know the syncing is very slow because upload speeds are slow on my broadband if that could be an issue. Any suggestions?

Thanks

 

I've added a screenshot to show the most 'recently added' folder is only showing photos from back on June 13th whereas Ive been adding photos every 2-3 days since then but they're not showing up. This seems to have happened since the latest update. What can I do?

Topics

How to, Import and share, Mac, Problem or error, Sync

Views

65

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Missing photos in Lightroom library

New Here ,
Jun 25, 2020

Copy link to clipboard

Copied

Hello all,

I launched Lightroom today to find the most recent photo in my library was taken over 10 days ago. The others I had added since then are all missing. A real travesty if this is the case. I know the syncing is very slow because upload speeds are slow on my broadband if that could be an issue. Any suggestions?

Thanks

 

I've added a screenshot to show the most 'recently added' folder is only showing photos from back on June 13th whereas Ive been adding photos every 2-3 days since then but they're not showing up. This seems to have happened since the latest update. What can I do?

Topics

How to, Import and share, Mac, Problem or error, Sync

Views

66

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jun 25, 2020

Copy link to clipboard

Copied

I have the same issue.  There are over 9000 photos missing from Lightroom after updating to 9.3.  The external drive that I use was renamed with an added explanation point, but changing the name back didn't help.  The photos are still on the drive.  I can only recover them one foder at a time (better than 1 photo at least) by clicking n that folder.  I sure hope we find an answer soon.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 26, 2020

Copy link to clipboard

Copied

Whats happening to me seems a little different in that it is no longer showing photos I imported after a certain date (around 10 days ago) The pictures are backed up on my external drive but none of the latest photos and the work I've done on them are appearing in the interface. This is in Lightroom 3.3 the latest version which I updated  recently and has to be said, has been working a little flakely. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...