Highlighted

Performance Continues to Degrade — Even After Update

Explorer ,
Jun 18, 2020

Copy link to clipboard

Copied

I love Lightroom Classic, but over the past several months, it has gotten slower and slower, especially on startup. I was hopeful that the 9.3 update would make it perform better, but it seems like the problem is worse than ever.

 

I'm on Windows 10 with a 500 GB SSD and a 1 TB traditional drive, both about half full. I have 16GB RAM, and my catalog file has about 400 photos in it. When I launch Lightroom, it shows the bezel and then goes into Windows' "Not Responding" mode for almost 7 minutes before the app can be used. After that, it's "acceptably" sluggish, meaning usable, but just launching it is enough to put me off it in many cases. My catalog is optimized regularly. What's going on here??

TOPICS
Crash or freeze, Performance, Windows

Views

60

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Performance Continues to Degrade — Even After Update

Explorer ,
Jun 18, 2020

Copy link to clipboard

Copied

I love Lightroom Classic, but over the past several months, it has gotten slower and slower, especially on startup. I was hopeful that the 9.3 update would make it perform better, but it seems like the problem is worse than ever.

 

I'm on Windows 10 with a 500 GB SSD and a 1 TB traditional drive, both about half full. I have 16GB RAM, and my catalog file has about 400 photos in it. When I launch Lightroom, it shows the bezel and then goes into Windows' "Not Responding" mode for almost 7 minutes before the app can be used. After that, it's "acceptably" sluggish, meaning usable, but just launching it is enough to put me off it in many cases. My catalog is optimized regularly. What's going on here??

TOPICS
Crash or freeze, Performance, Windows

Views

61

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 18, 2020 1
Community Beginner ,
Jun 20, 2020

Copy link to clipboard

Copied

I too have seen a bad performance on my mac with Lightroom Classic since the latest upgrade.  Though my mac is old, it still meets the Adobe hardware minimum requirements.  Images are taking 10-20 seconds to load, scrolling through images is now unworkable.

Contacted Adobe chatline, they were very slow too and it took me over 20 mins to get the answer I was looking for (how to revert to the previous version of Lightroom Classic - not a hard question).

Maybe being slow is an Adobe thing... certainly going to start looking at alternatives.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2020 0