SIGMA 150-600mm F5-6.3 DG OS HSM

New Here ,
Mar 22, 2021 Mar 22, 2021

Copy link to clipboard

Copied

I'm having an issue that my SIGMA 150-600mm F5-6.3 DG OS HSM Contemporary is not being recognized by Lightroom for lens correction. Any insight as to why?

TOPICS
Presets or profiles

Views

100

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

Which version of Lightroom are you using?

And are you using a raw file, as the majority of lens profiles are designed to be used on raw files only, and consequently they would not appear in the list of lens profiles in the Lens Corrections panel if a non-raw file is selected.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

I spoke with Adobe support, they informed me my lens is supported by Lightroom classic, but is currently NOT supported by Lightroom. So I changed products I use and relearned, or really relearning. I must admit, it's a little maddening. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

You didn't answer my earlier question about whether you were using a raw file or not? Adobe Support gave you incorrect information...that lens IS supported by Lightroom as well as Lightroom Classic.

 

Sigma.PNG

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

Sorry, yes I was using raw. I can see what you mean, and your right, the Adobe person was wrong. With my older Canon 70-300 as soon as I enabled lens correction it detected the lens on it's own. But on the Sigma I manually had to click change profile and select sigma, then it saw the lens. That was helpful, thank you. I prefer Lightroom CC over classic, cleaner UI. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

John5C7C_0-1617115140911.png

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

Is this a bug? By the way the same in Lightroom classic. I had to manually select Sigma and then the lens.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines