Welcome Dialog

コミュニティへようこそ。

まったく新しい外観になりました。ツアーに参加して、アドビサポートコミュニティの最新情報をご覧ください


Media Encoder で書き出した圧縮音源(MP3, AAC)にノイズが乗る

New Here ,
Sep 17, 2021 Sep 17, 2021

リンクをクリップボードにコピー

コピー完了

お世話になります。


After Effects で動画編集 → Media Encoder で書き出しをすると音声に定期的にクリップノイズ(プツプツ)が乗ってしまいます。音声は Cubase で編集・書き出し(48kHz/24bit WAV) をしたもので、この時点で音声にピークほか異常は全くなく、それを読み込んだAE上でのプレイバックの時点でも全く異常なく再生されます。AEのオーディオメーターでも赤はでません。

 

問題を切り分けるべく色々試したところ、
・MEで圧縮 MP3, AAC だとビットレートやモノ/ステレオ等変えてもノイズ乗る
・MEで非圧縮 WAV だとノイズが乗らない。
・AEでレンダリングすると音声形式の圧縮・非圧縮問わず正常に書き出しできる
ということが分かり、MEのしかも圧縮に関わる部分が怪しい??というところまでは行き着いたもののその後の打つ手が分かりません。

 

日頃同じ設定で動画制作・書出しをしていてこの様な異常がおきたことがないのですが、普段との違いがあるとしたら、強いて言えば音声の 1kHz~2kHz帯域がすこし強め…ですが、音量も抑えて試していてピーク由来とは考えづらいです。


OS WIN 10
AE, ME CC 2021
Cubase Pro 10
※すべてアップデート最新

 

ME 書き出し設定
H264/MP4 デフォルトの「高速ビットレート」
ほか音声のみ MP3, AAC, WAV を検証(ステレオ・モノ両方検証

 

Cubase書き出し設定
48kHz 24bit WAV(ステレオ・モノ両方検証


ほか必要な情報はすぐ追記いたします、ご助言の程何卒よろしくお願いいたします。

キーワード
エラーまたは問題

表示

111

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
New Here ,
Sep 18, 2021 Sep 18, 2021

リンクをクリップボードにコピー

コピー完了

検証追記です。
MEで、動画編集に読み込んでいるWAVファイルを直接開いて、音声ファイル書き出し(音ファイルをを読み込んで音ファイルを書き出す)だと、AAC, WAV ともにノイズなく書き出されました。

 

AE動画ファイルに読み込まれた音声、という段階で何か変化を遂げる部分があるのでしょうか??

何卒よろしくお願いいたします。

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
New Here ,
Sep 18, 2021 Sep 18, 2021

リンクをクリップボードにコピー

コピー完了

検証追記その2です。

 

質問本文に

・MEで非圧縮 WAV だとノイズが乗らない。

と書きましたが、やはりWAVでもノイズは乗っていました。

 

MEを使って、

・AEファイルから音声を書くとノイズが乗る

・WAVファイル直接読み込んで書き出せばノイズは乗らない

という状況になります。

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
Adobe Most Valuable Participants ,
Sep 19, 2021 Sep 19, 2021

リンクをクリップボードにコピー

コピー完了

私は普段Premiere Proをメインで使用しているのでAfter Effectsからの書き出しに関して見識は無いのですが、お書きいただいた情報を拝見する限りではAfter EffetcsとMedia Encoderの連携に関わる部分のバグである可能性が高いように思います。

 

強いて申しますと、After Effects側の音声の設定(サンプリング周波数など)が気になるところです。

 

Aeからの直接書き出しとMe経由の書き出しは映像にも差が出ると思うので(32bitでの100IRE以上の信号など)Ae書き出しでしのげないといったご事情もあるかもしれないと思うのですが、例えばPremiere ProにAeのコンポジションを読み込ませ、映像と音声をPremiere Proのシーケンス上で合体したうえでMeで書き出していただくといかがでしょうか。

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
New Here ,
Sep 19, 2021 Sep 19, 2021

リンクをクリップボードにコピー

コピー完了

返信いただきありがとうございます!

 

Ae のプロジェクト設定のオーディオサンプリングレートは 48kHz です。

あとは書き出し時の設定のみでプロジェクトとしての設定はございませんよね。書き出し時のサンプリングレートは16 / 24 / 32bit それぞれ試し、読み込むWAVのレートもそれに合わせてみたり、敢えて変えてみたりもしましたが症状は同じでした。

 

AeとMeの書き出しは映像にも差がでるのですね…Meでの書き出しが奨励されているのと、普段mp4で書き出しをしていたので考えなくMeを使っていましたが、直接書き出すことも検討してみます。今回はPremiere Pro で後から音声を差し替えて急場をしのぎましたが、このままだと困ったものです…

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
New Here ,
Sep 19, 2021 Sep 19, 2021

リンクをクリップボードにコピー

コピー完了

失礼しました、書き出し時に試したのは各種ビットレートでした。

サンプリングレートは一貫して48kHzで行っています。

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
Adobe Most Valuable Participants ,
Sep 19, 2021 Sep 19, 2021

リンクをクリップボードにコピー

コピー完了

私も簡単なテストをしてみましたが、症状は再現しませんでした。

 

=====

環境:Windows 10 Pro 21H1, After Effects 18.4.1, Media Encoder 15.4.1

内容:1920×1080 30.00fps 120秒 のコンポジションで平面に「CC Bubbles」をのせて、Auditionで作成した1kHz 0dBFSのFs48kHz 24bitのwavファイルを貼って、Media Encoderのプリセット「ソースの一致 - 高速ビットレート」で書き出し。もうひとつ、書き出し時のフレームレートを29.97fpsに手動で変えて書き出し。

結果:聴感上特に異常なし

=====

 

お書きいただいた内容からフルビット越えの歪みではなく音声の瞬断や僅かな欠落によるノイズの可能性を考えておりましたが、手元の環境では症状が出ず、残念ながらよくわかりません……。

 

これまでは問題なかったようですので、問題が起きるようになるまでの間に何か環境の変化(Adobe製品、Cubaseなどのアップデートのほか、ドライバ類のインストール・更新など)があれば、それらが原因という可能性があるかもしれません。

 

また、おそらく書き出したファイルの再生・ノイズの確認は複数の再生ソフトやPremiere Proでも行われていていると思いますので再生ソフトが原因である可能性は除外してよいと思うのですが、もしPremiere Proでの音差し替え時にPremiere Pro上でノイズの確認をなさっていませんでしたら、一応確認していただいたほうが良いと思います。

 

根本解決にはならないうえ改善される可能性も高くはないと思うのですが、原因の切り分けのためCubaseで書き出したファイルをAdobe AuditionやMedia Encoderで同じ形式(Fs48kHz 24bit)のwavに書き出しなおしてAfter Effectsのコンポジションに貼ってみることも試す価値があるかもしれません。

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
New Here ,
Sep 20, 2021 Sep 20, 2021

リンクをクリップボードにコピー

コピー完了

最新

なんと、ご検証いただきありがとうございます。

PremierePro での音差し替え時も、差し替え前のものにはノイズが乗っておりました。

 

Cubase書き出しWAV → Me で同じ設定でWAV → をAeに読み込みMeでWAV書き出し

を行ってみましたが、やはり最後の「Aeに読み込みMeでWAV書き出し」の段階で同じノイズが乗ってしまいました。Ae上のプレイバックでは一切ノイズは乗りません。

 

「今までは異常がおきなかった」と記述した件ですが、

今まではアコースティックギター(高域が強くない・音の減衰の早い)の音声がほぼ専らだったのですが、この問題の動画で初めてリコーダー(笛)のような(高域1kHz~2Khzの強い、ビ~という張りのある音色)を扱い、この現象がおきました。

そしてこの動画の笛のパートをミュート(残るはギターパートのみ)すると、今回の異常は全く起きなくなると気づきました。つまり今までも同じ異常を抱えたまま、たまたま発現していなかっただけの可能性が高いです…

 

プツプツと音のする箇所は明らかにその笛の強い音に由来しています。ただ最初に書いたとおり、ピークからは大幅に音量を下げており(-10db付近)、またCubaseで書き出した時点のWAV、Aeで書き出した場合の音声 にはまったく異常が現れず、Meで書き出した音源のみに異常がでるという状況です…

 

各種再インストール、アップデートももう一度行ってみます。

ご丁寧にご対応いただき感謝いたします。

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines