• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Mixamo Blender Addon can't create control rig in 2.93

New Here ,
Jul 28, 2021 Jul 28, 2021

Copy link to clipboard

Copied

So I got the Mixamo addon installed in Blender 2.93. But somehow it can't create the control rig. It just spits out an error.

5DE6mHle5z.png

Though, the addon does work in 2.92. I'm guessing that it's because the addon was made in 2.92 or below.

If so, then the addon needs to be updated to 2.93. Also, right now I only got issues with the generate control rig. When I use the rig I created in 2.92 to 2.93, the rig still works. I also added an animation from Mixamo and it does work.

TOPICS
Bug

Views

4.8K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jul 29, 2021 Jul 29, 2021

Copy link to clipboard

Copied

I have seen this same error. For me it helped reimporting the FBX from scratch. Ive also update the code so it does work with the file you already have setup.

 

If you paste the code below at line 89 in the file lib > objects.py
This is how that lines should look, it starts at line 86

# assign to new collection
assigned_collections = []
    for collec in cs_grp.users_collection:
        if not collec in obj.users_collection:
            collec.objects.link(obj)
            assigned_collections.append(collec)

 

When i added that line 'if not collec in obj.users_collection:' it did setup the rig properly

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 29, 2021 Jul 29, 2021

Copy link to clipboard

Copied

Ok. So I add it. But now the addon won't show up.

Here's how the code looks:

]sublime_text_Ht2UsQWitl.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 29, 2021 Jul 29, 2021

Copy link to clipboard

Copied

Oops, sorry. Wrong picture.

Here's the right one:

sublime_text_enb4cqzt7B.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Nov 30, 2021 Nov 30, 2021

Copy link to clipboard

Copied

Sorry for late reply, you have a wrong indent with that 

for collect cs_grp.users_collection:

 That whole for loop should move one tab to the left. I bet you had an indent error in the blender console as well when trying to activate it

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2021 Sep 08, 2021

Copy link to clipboard

Copied

Fixed it by adding an animation Action named Armature|mixamo.com|Layer0 to my armature.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 20, 2021 Sep 20, 2021

Copy link to clipboard

Copied

Hi! So I was having this exact same issue and the code snippet mentioned above didn't help me (and also made my addon disappear as you mentioned). And I couldn't find help anywhere else as it seems not a lot of people are having this problem. So what I did was "File > Default > Load Factory Settings" under the assumption that maybe another addon was causing the issue and BINGO! It works like a charm now. Not sure which addon is causing the issue and maybe I'll do trial by error eventually, but as of now this works (for me anyway).

 

So I created the rig, saved the file and then just re opened the file in my regular Blender setup. Luckily, "Load Default Settings doesn't completley remove all your preferences and installed addons. It only does it for your current session. Which I only just now realized lol

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 31, 2022 Aug 31, 2022

Copy link to clipboard

Copied

LATEST

Thanks. Totally fixed my issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 09, 2021 Oct 09, 2021

Copy link to clipboard

Copied

me too .. same problem !!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Nov 30, 2021 Nov 30, 2021

Copy link to clipboard

Copied

i noticed i pasted the code with a tab to much. In the first for loop showing

for collect cs_grp.users_collection:

This is the corrected code

# assign to new collection
assigned_collections = []
for collec in cs_grp.users_collection:
    if not collec in obj.users_collection:
        collec.objects.link(obj)
        assigned_collections.append(collec)

But check for the new version on the website. i just noticed the version is now already at 1.10.18

https://substance3d.adobe.com/plugins/mixamo-in-blender

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines