Highlighted

Active state button works on 3 of 4

Community Beginner ,
Nov 22, 2017

Copy link to clipboard

Copied

Hi,

To start I explain shortly how the website is build up. It's a vertiial scrolling page with 4 parts acting as pages

I have made a top menu with 4 buttons (this was imported using the Menu widget from Muse)

It's a horizontal layout menu with      ''button 1"  "button 2"  "button 3"  "button 4"

Hyperlinked to these buttons is achor with according name.

All buttons refer to a certain part in the page (by adding anchors) Anchors have the according name to the buttons

The parts are on 4 different layers, the according achors are placed on the same layer.

I made some active states for all buttons in same way. They have a state for rollover and a state for active.

When I preview the site in browser everything woks fine. This means it scrolls to the right anchor, the rollover works fine for all 4 buttons, BUT only the active state on "button 4" isn't working.

When I rollover "button 4" the rollover works, when I click the button, it scrolls to the right part of the website, but the Acitve state is nowhere to be seen...instead it gives an active state to "button 3". ....????....

Scrolling to the right part (anchored) is not working either.

What's going on?

I hope I described clear enough.

Adobe Community Professional
Correct answer by fotoroeder | Adobe Community Professional

That´s due to the fact, that your page might not scroll far enough to place the anchor in the top left corner of the browser window.

Means, your content is not long enough to make the anchor reach the top left corner.

You could try to expand the last "page" with some empty space or a picture (depends on your design of course)

or any other content the makes sense to you (graphic element?).

Best Regards,

Uwe

Views

257

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Active state button works on 3 of 4

Community Beginner ,
Nov 22, 2017

Copy link to clipboard

Copied

Hi,

To start I explain shortly how the website is build up. It's a vertiial scrolling page with 4 parts acting as pages

I have made a top menu with 4 buttons (this was imported using the Menu widget from Muse)

It's a horizontal layout menu with      ''button 1"  "button 2"  "button 3"  "button 4"

Hyperlinked to these buttons is achor with according name.

All buttons refer to a certain part in the page (by adding anchors) Anchors have the according name to the buttons

The parts are on 4 different layers, the according achors are placed on the same layer.

I made some active states for all buttons in same way. They have a state for rollover and a state for active.

When I preview the site in browser everything woks fine. This means it scrolls to the right anchor, the rollover works fine for all 4 buttons, BUT only the active state on "button 4" isn't working.

When I rollover "button 4" the rollover works, when I click the button, it scrolls to the right part of the website, but the Acitve state is nowhere to be seen...instead it gives an active state to "button 3". ....????....

Scrolling to the right part (anchored) is not working either.

What's going on?

I hope I described clear enough.

Adobe Community Professional
Correct answer by fotoroeder | Adobe Community Professional

That´s due to the fact, that your page might not scroll far enough to place the anchor in the top left corner of the browser window.

Means, your content is not long enough to make the anchor reach the top left corner.

You could try to expand the last "page" with some empty space or a picture (depends on your design of course)

or any other content the makes sense to you (graphic element?).

Best Regards,

Uwe

Views

258

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 22, 2017 0
Adobe Community Professional ,
Nov 22, 2017

Copy link to clipboard

Copied

That´s due to the fact, that your page might not scroll far enough to place the anchor in the top left corner of the browser window.

Means, your content is not long enough to make the anchor reach the top left corner.

You could try to expand the last "page" with some empty space or a picture (depends on your design of course)

or any other content the makes sense to you (graphic element?).

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 22, 2017 0
Community Beginner ,
Nov 22, 2017

Copy link to clipboard

Copied

Thx!!

My god... didn't think of that at all.

It worked perfectly. Just moved a picture 30px down.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 22, 2017 0
Adobe Community Professional ,
Nov 22, 2017

Copy link to clipboard

Copied

Gorgeous .

Welcome all day long,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 22, 2017 0
Adobe Community Professional ,
Nov 22, 2017

Copy link to clipboard

Copied

Hi ankushr40215001​, I think, this issue is solved, isn`t it?

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 22, 2017 0
Nov 22, 2017

Copy link to clipboard

Copied

Oh, my bad. got a wrong link.

Edited.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 22, 2017 0
Adobe Community Professional ,
Nov 22, 2017

Copy link to clipboard

Copied

No problem, no reason to blame yourself. Your input is highly welcome all time. I hope you are aware of this

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 22, 2017 0