Highlighted

Can't make a graphic style - are graphic styles broken?

Contributor ,
Dec 01, 2017

Copy link to clipboard

Copied

I'm trying to make a graphic style for a simple button. I make one button the way I want it and hold down alt (⎇ Mac) and click the new graphic style icon in the palette (tool tip says: create a new style from the attributes applied), however the style that appears is zero colour fill at 0% opacity, zero stroke colour at 0% opacity...

(background opacity: 0 + border colour: [None] + border opacity: 0 + stroke alignment: centre + background colour: [None])

...so applying the style completely changes the object (and makes it disappear!). I change the object back to the way I want it and redifine the style and nothing happens - the style doesn't change and the + after its name remains.

I can't make a graphic style that works properly - are graphic styles broken in this version (18.0.0.685*) or am I doing something wrong?

thanks for any help or suggestions,

K.

*Adobe - why can't we copy and paste the version number¡?

I think, you don‘t do that. In your description you say: „… hold down alt and click …“ No need to “hold down alt“

Views

227

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Can't make a graphic style - are graphic styles broken?

Contributor ,
Dec 01, 2017

Copy link to clipboard

Copied

I'm trying to make a graphic style for a simple button. I make one button the way I want it and hold down alt (⎇ Mac) and click the new graphic style icon in the palette (tool tip says: create a new style from the attributes applied), however the style that appears is zero colour fill at 0% opacity, zero stroke colour at 0% opacity...

(background opacity: 0 + border colour: [None] + border opacity: 0 + stroke alignment: centre + background colour: [None])

...so applying the style completely changes the object (and makes it disappear!). I change the object back to the way I want it and redifine the style and nothing happens - the style doesn't change and the + after its name remains.

I can't make a graphic style that works properly - are graphic styles broken in this version (18.0.0.685*) or am I doing something wrong?

thanks for any help or suggestions,

K.

*Adobe - why can't we copy and paste the version number¡?

I think, you don‘t do that. In your description you say: „… hold down alt and click …“ No need to “hold down alt“

Views

228

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 01, 2017 0
LEGEND ,
Dec 01, 2017

Copy link to clipboard

Copied

Works fine here:

Be aware, that actually(!!) a graphic style can’t contain all states of an element. If you need this, you have to create graphic styles state-wise.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2017 0
Contributor ,
Dec 01, 2017

Copy link to clipboard

Copied

Hmmm. I'm doing exactly that - but I get zeo fill zero % opacity for everything!

Any other suggestions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2017 0
LEGEND ,
Dec 01, 2017

Copy link to clipboard

Copied

I think, you don‘t do that. In your description you say: „… hold down alt and click …“ No need to “hold down alt“

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2017 0