Highlighted

Composition menu is making sub links inactive.

Community Beginner ,
Nov 02, 2017

Copy link to clipboard

Copied

Hi I have created a Mega dropdown (top navigation) menu using an inbuilt Muse composition widget. The dropdown menu works fantastic. The problem is – I have some sub (side) navigation off in the right hand column. When I hover over the active links in the side menu they do not activate or funtion, somehow the composition menu is blocking (not allowing) the links to be seen.

The problem can be seen here 

http://adansw02.businesscatalyst.com/about.html

If you hover over the navigation on the right hand side (to the right of the image) the links do not have roll over states until you hover over

"Terms" or at the very end of the line of "Constitution, Policies & Codes". If you hover over the top Navigation button "Centre for Professional Development" you can see the area that is "blocking" the links. I can't figure out a work-around - I can't put the side navigation on a higher layer as it will sit over the top off the top navigation and I can't keep the top navigation drop downs to the left of the side navigation.

This is all very confounding as the problem appears to only have started happening since updating Muse, the navigation worked perfectly a few months ago :–(

Help please.

Unfortunately you run into a nasty bug. This is the bad news. The good news: There is a simple workaround.

I reduced your file to a minimum to make the issue and its solution more evident:

  • Load this  sample file, unzip it and open it in Muse: https://www.dropbox.com/s/kbj8c1aa099xvwv/another-composition-bug.zip?dl=0
  • Now preview the „Home“ page in browser.
  • The text links „Site nav 1 – site nav 5“ to the right of the page can’t be activated, because they are „covered“ by the invisible composition target.
  • This happens, as long as the composition option „Show widget parts while editing“ is checked.
  • As soon as this option is unchecked, all works as expected.

And again I like to invite ankushr40215001​ to have a look at this issue. (It seem to be related to the issue reported in this thread: https://forums.adobe.com/thread/2406994​)

Views

427

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Composition menu is making sub links inactive.

Community Beginner ,
Nov 02, 2017

Copy link to clipboard

Copied

Hi I have created a Mega dropdown (top navigation) menu using an inbuilt Muse composition widget. The dropdown menu works fantastic. The problem is – I have some sub (side) navigation off in the right hand column. When I hover over the active links in the side menu they do not activate or funtion, somehow the composition menu is blocking (not allowing) the links to be seen.

The problem can be seen here 

http://adansw02.businesscatalyst.com/about.html

If you hover over the navigation on the right hand side (to the right of the image) the links do not have roll over states until you hover over

"Terms" or at the very end of the line of "Constitution, Policies & Codes". If you hover over the top Navigation button "Centre for Professional Development" you can see the area that is "blocking" the links. I can't figure out a work-around - I can't put the side navigation on a higher layer as it will sit over the top off the top navigation and I can't keep the top navigation drop downs to the left of the side navigation.

This is all very confounding as the problem appears to only have started happening since updating Muse, the navigation worked perfectly a few months ago :–(

Help please.

Unfortunately you run into a nasty bug. This is the bad news. The good news: There is a simple workaround.

I reduced your file to a minimum to make the issue and its solution more evident:

  • Load this  sample file, unzip it and open it in Muse: https://www.dropbox.com/s/kbj8c1aa099xvwv/another-composition-bug.zip?dl=0
  • Now preview the „Home“ page in browser.
  • The text links „Site nav 1 – site nav 5“ to the right of the page can’t be activated, because they are „covered“ by the invisible composition target.
  • This happens, as long as the composition option „Show widget parts while editing“ is checked.
  • As soon as this option is unchecked, all works as expected.

And again I like to invite ankushr40215001​ to have a look at this issue. (It seem to be related to the issue reported in this thread: https://forums.adobe.com/thread/2406994​)

Views

428

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 02, 2017 0
Adobe Community Professional ,
Nov 03, 2017

Copy link to clipboard

Copied

Could you provide a .muse with just the menu? If you use the automatic menu, could you clear the pages, so the file doesn´t get too heavy? It looks weird but may be solvable. It looks like something is overlapping with your menu.

It is possible, that by deleting all other elements except the menu, you find the solution as well.

If not, share it via CC or dropbox.

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2017 0
Community Beginner ,
Nov 05, 2017

Copy link to clipboard

Copied

Hi Fotoroeder, thank you so much for replying, this problem is really messing with my head.

1. Yes I am on the latest CC version of Muse - and note that about 3 months ago this navigation worked perfectly so I'm wondering if something has happened with the latest update.

2. I have made a simple document with the same top navigation and side navigation and I'm still getting the same problem. It is definitely the composition that is "blocking" the links. If you rollover the top navigation you can see where it overlaps the side navigation, all the bottom links (side nav 11 - 14) in the test site are active, you can view it here Home

3. Here is a link to the test site .muse file

Dropbox - Nav test.muse

4. I don't want to use the standard Muse navigation as I want to include the advertising blocks that are in the first three rollovers, I also want to control what can and can't be seen in my mega menu and I don't believe I can style the Muse automatic menu in the way that I want to?

Regards Deidre

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 05, 2017 0
Adobe Community Professional ,
Nov 05, 2017

Copy link to clipboard

Copied

Bildschirmfoto 2017-11-05 um 23.48.15.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 05, 2017 1
LEGEND ,
Nov 03, 2017

Copy link to clipboard

Copied

With exact which Muse version are you building the site? Could it be, that you don‘t use version 2018.0?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2017 0
Community Beginner ,
Nov 05, 2017

Copy link to clipboard

Copied

Hi Gunter, thank you so much for replying, this problem is really messing with my head.

1. Yes I am on the latest CC version of Muse - and note that about 3 months ago this navigation worked perfectly so I'm wondering if something has happened with the latest update.

2. I have made a simple document with the same top navigation and side navigation and I'm still getting the same problem. It is definitely the composition that is "blocking" the links. If you rollover the top navigation you can see where it overlaps the side navigation, all the bottom links (side nav 11 - 14) in the test site are active, you can view it here Home

3. Here is a link to the test site .muse file

Dropbox - Nav test.muse

4. I don't want to use the standard Muse navigation as I want to include the advertising blocks that are in the first three rollovers, I also want to control what can and can't be seen in my mega menu and I don't believe I can style the Muse automatic menu in the way that I want to?

Regards Deidre

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 05, 2017 0
Adobe Community Professional ,
Nov 06, 2017

Copy link to clipboard

Copied

2. I have made a simple document with the same top navigation and side navigation and I'm still getting the same problem. It is definitely the composition that is "blocking" the links. If you rollover the top navigation you can see where it overlaps the side navigation, all the bottom links (side nav 11 - 14) in the test site are active, you can view it here Home

3. Here is a link to the test site .muse file

Dropbox - Nav test.muse

Regards Deidre

Hi Deidre,

as you may have seen, the file was "working". I don´t know if Günter Heißenbüttel​ was able to open the file?

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 0
Community Beginner ,
Nov 06, 2017

Copy link to clipboard

Copied

Hi Fotoroeder

Here is a dropbox link the the exported Muse files, hopefully that will work for you. Dropbox - Nav Test

Here is the link to the test site the side navigation links from 1-65 do not work Home

Regards Deidre

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 0
LEGEND ,
Nov 06, 2017

Copy link to clipboard

Copied

No, the file is damaged or incomplete.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 0
Community Beginner ,
Nov 06, 2017

Copy link to clipboard

Copied

Hi Gunter

New link to exported dropbox file Dropbox - Nav Test

Here is the link to the test site the side navigation links from 1-5 do not work Home

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 0
LEGEND ,
Nov 06, 2017

Copy link to clipboard

Copied

Unfortunately you run into a nasty bug. This is the bad news. The good news: There is a simple workaround.

I reduced your file to a minimum to make the issue and its solution more evident:

  • Load this  sample file, unzip it and open it in Muse: https://www.dropbox.com/s/kbj8c1aa099xvwv/another-composition-bug.zip?dl=0
  • Now preview the „Home“ page in browser.
  • The text links „Site nav 1 – site nav 5“ to the right of the page can’t be activated, because they are „covered“ by the invisible composition target.
  • This happens, as long as the composition option „Show widget parts while editing“ is checked.
  • As soon as this option is unchecked, all works as expected.

And again I like to invite ankushr40215001​ to have a look at this issue. (It seem to be related to the issue reported in this thread: https://forums.adobe.com/thread/2406994​)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 1
Community Beginner ,
Nov 06, 2017

Copy link to clipboard

Copied

Gunter, you are a legend and here is a virtual beer     to celebrate your awesomeness. I never would have thought to do that, so easy!

Thank you Deidre

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 0
LEGEND ,
Nov 06, 2017

Copy link to clipboard

Copied

Yes it is easy to fix, but nevertheless a bug.

And thanks for the beer! Unfortunately, the bottle is already empty!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 1
Nov 07, 2017

Copy link to clipboard

Copied

Hey Gunter, yeah somewhat relatable, the bug is because of "lightbox parts" not respecting the layers.

I have updated the bug logged by me previously and thank you so much for pointing this out.

Cheers from me as well,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Explorer ,
Mar 08, 2018

Copy link to clipboard

Copied

I am trying to work around this bug right now, unfortunately Muse will not allow me to uncheck "show widget parts while editing". I can only uncheck it if I switch to lightbox mode, but switching back to stacked or scattered greys out the checkbox and rechecks it. Is there another workaround to prevent things under the composition from being blocked?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 08, 2018 0
LEGEND ,
Mar 08, 2018

Copy link to clipboard

Copied

This is already fixed in actual prerelease version of Muse.

(Don’t ask, when it will be published. Only the Muse team knows! )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 08, 2018 1
Explorer ,
Mar 08, 2018

Copy link to clipboard

Copied

Ah, that's good to know, thanks! Hopefully they will release it soon, I'll try to find another way to build this in the meantime.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 08, 2018 0