Contact form submission - reply issues

Community Beginner ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

Hello. The form has been working great until just this month (January 2019). Am using the basic contact form widget with reCAPTCHA 2 added.

Now: An email gets submitted in the form on contact page by customer, then when I reply back to them it sends that email to me, not the new potential customer. Nothing has been changed or modified. Anyone have this happen?

Thanks!

Views

274

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Jan 17, 2019 Jan 17, 2019
Just to be clear, your contact from is using your server's mail function to send the e-mail.  In other words the mail is not coming from the customer's e-mail, it's coming from your server.   So if you hit REPLY,  you're replying to your server, not the customer.   For best results, compose a new e-mail and copy & paste the customer's e-mail address into the TO field.

Likes

translate

Translate

Translate
Adobe Community Professional ,
Jan 17, 2019 Jan 17, 2019

Copy link to clipboard

Copied

Just to be clear, your contact from is using your server's mail function to send the e-mail.  In other words the mail is not coming from the customer's e-mail, it's coming from your server.   So if you hit REPLY,  you're replying to your server, not the customer.   For best results, compose a new e-mail and copy & paste the customer's e-mail address into the TO field.

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 17, 2019 Jan 17, 2019

Copy link to clipboard

Copied

Thank you Nancy.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 17, 2019 Jan 17, 2019

Copy link to clipboard

Copied

You're welcome.

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 17, 2019 Jan 17, 2019

Copy link to clipboard

Copied

Additional note: This issue is actually regarding my friend's website whom I created a Muse site a couple years ago for. Seemed less complicated to explain that way initially.

I have my own Muse site as well, and when I get form submission emails, also with reCAPTCHA installed, I can reply directly back to them (in Apple Mail). She swears she has been able to do this on her site until just this month, so for now she is already doing as you suggested and using copy-paste into a newly composed email.


I'm still going to try to solve this for her, so if you think of any other things it might be, please reply. I have heard PHP scripts can be the issue, but you can't just open the hood and tinker with the Muse engine. Thanks!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 17, 2019 Jan 17, 2019

Copy link to clipboard

Copied

Perhaps the hosting server was upgraded from PHP 5x to 7x which is a lot more secure.

rkile48  wrote

I'm still going to try to solve this for her...

Don't mess with scripts unless you know exactly what you're doing.

Another option is to use a 3rd party form service like Wufoo.com.  Forms are processed by their servers, not yours so it doesn't matter which PHP version you have.

MuseThemes has a Wufoo widget.

]Adobe Muse Wufoo Forms Widget by MuseThemes

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2019 Jan 23, 2019

Copy link to clipboard

Copied

Thanks again, still attempting to solve this for my friend/client. Didn't get a widget form Wufoo because you have to buy a subscription - something I don't want to do with Muse fading away. I did find out the hosting server is PHP 5.4.28

Here's an odd thing: had them restart each device and computer and try to reply back to test email sent from the current form. Same issue, BUT on the iPhone it DOES reply back properly to sender. 

Appreciate the time and advice. -Richard

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines