Contact Form Widget Error

Community Beginner ,
Feb 18, 2017 Feb 18, 2017

Copy link to clipboard

Copied

Website Contact form displaying incorrectly and not submitting.

This problem occurred after the CC 2017 update and remains a problem after the latest 2017.0.2 update.

Website

On the Contact Page I have inserted a contact form from the widgets library.

PROBLEM #1: It displays fine when in Preview Mode.  However, upon publication and opening in web browser, data entry into the contact form does not clear the input box instructions.  In other words, when you type your NAME in the "NAME" box  it overlaps the box title "Enter Name" making for gibberish.
Name.jpeg

PROBLEM #2:

Even after entering the data in the appropriate boxes and fulfilling the reCaptcha test, clicking submit returns this error:

{"MusePHPFormResponse": {"success": false, "error": ""}}

The email address is set to  @mydomain and I have tried it with a public gmail account with the same error results.

Views

600

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Advocate , Feb 19, 2017 Feb 19, 2017
Perhaps one of these will help with the reCaptcha error:reCAPTCHA 2.0 server error -- SOLVED reCAPTCHA 2.0 server error -- SOLVED (These look like the same link, but they are different.)John

Likes

translate

Translate

Translate
Advocate ,
Feb 19, 2017 Feb 19, 2017

Copy link to clipboard

Copied

Perhaps one of these will help with the reCaptcha error:

reCAPTCHA 2.0 server error -- SOLVED

reCAPTCHA 2.0 server error -- SOLVED

(These look like the same link, but they are different.)

John

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 19, 2017 Feb 19, 2017

Copy link to clipboard

Copied

Thanks John,   I went into the php.ini and changed the "url_fopen" to off

This solved problem #2 !  The contact form is now pushing form submissions to @mydomain email address as needed.

Two problems however, remain.  The aforementioned Problem #1, where the text input box titles do not disappear upon entering text (as illustrated in my post) persists and now upon successful submission, instead of redirecting to the page set in the Form widget:

ThanksForContact

...the browser displays:
{"FormResponse": {"success": true, "redirect": "thanksforcontact.html"}}



randy

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 19, 2017 Feb 19, 2017

Copy link to clipboard

Copied

Randy,

"I went into the php.ini and changed the "url_fopen" to off"

I thought it was supposed to be set to ON, but if it worked, that's great.

I'm not a Muse expert, so I can't help with the other issue, other than to suggest you make the form field boxes larger.  That may help with the overlapping issue.

John

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 19, 2017 Feb 19, 2017

Copy link to clipboard

Copied

John,

sorry...I did change  it from OFF to ON as you instructed!

Time for Me to take a break from looking at Code I guess!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Aug 23, 2017 Aug 23, 2017

Copy link to clipboard

Copied

Hey guys,

Sorry for the long wait.The latest update of Muse has done a lot of rectifications in the working of form along with Google ReCaptcha 2.0

However, here is the good news which we all were waiting for so long.

The latest update of Muse has done a lot of rectifications in the working of form along with Google ReCaptcha 2.0

The best this is forms along with composition and slideshow widgets are now responsive.

Could you all please test the new update and let us know if the Reaptacha issue is fixed?

Please see the following release summary for detailed info - New features summary for the 2017 release of Adobe Muse CC

Regards,

Ankush

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines