Highlighted

Disable horizontal scrolling on fixed width breakpoints.

Community Beginner ,
Dec 18, 2016

Copy link to clipboard

Copied

Hi,

I am in the process of building my first functional Muse site and so far, it has been awesome.

I have built in 3 breakpoints all fixed width with effects. I designed each breakpoint to be centered, pinning everything to the middle so that it would look good on all sizes of tablets, phones and Internet Windows I'm each breakpoint. So far it has worked out well on all my browsers, except that the site scrolls horizontally if they are in a smaller screen than the size of the breakpoint. This is frustrating especially on mobile, cause it makes the whole design off center if their finger strays a little left or right.

I set the site properties to be centered, but can't seem to find how to turn off horizontal scroll. Any ideas?

Take a look at an unfinished version below on business catalyst to see what I mean.

HOME

Thanks, Jess

Hi Jess,

You could first try the suggestion based on this post - Muse Websites shake horizontally on mobile devices

If that doesn't work we do have a widget as well available here - disabler-muse-widget

Please try the solutions and let me know if anything works for you.

Regards,

Ankush

Views

7.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Disable horizontal scrolling on fixed width breakpoints.

Community Beginner ,
Dec 18, 2016

Copy link to clipboard

Copied

Hi,

I am in the process of building my first functional Muse site and so far, it has been awesome.

I have built in 3 breakpoints all fixed width with effects. I designed each breakpoint to be centered, pinning everything to the middle so that it would look good on all sizes of tablets, phones and Internet Windows I'm each breakpoint. So far it has worked out well on all my browsers, except that the site scrolls horizontally if they are in a smaller screen than the size of the breakpoint. This is frustrating especially on mobile, cause it makes the whole design off center if their finger strays a little left or right.

I set the site properties to be centered, but can't seem to find how to turn off horizontal scroll. Any ideas?

Take a look at an unfinished version below on business catalyst to see what I mean.

HOME

Thanks, Jess

Hi Jess,

You could first try the suggestion based on this post - Muse Websites shake horizontally on mobile devices

If that doesn't work we do have a widget as well available here - disabler-muse-widget

Please try the solutions and let me know if anything works for you.

Regards,

Ankush

Views

7.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 18, 2016 1
Dec 19, 2016

Copy link to clipboard

Copied

Hi Jess,

You could first try the suggestion based on this post - Muse Websites shake horizontally on mobile devices

If that doesn't work we do have a widget as well available here - disabler-muse-widget

Please try the solutions and let me know if anything works for you.

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2016 0
New Here ,
Feb 22, 2018

Copy link to clipboard

Copied

By far the easiest way to do this (which I am surprised nobody mentioned) is as follows.....

    • Open the page in design mode in which you want to hide the horizontal scroll bar (you can put this in the master page to make sure it goes throughout your whole site)
    • Click on Page > Page Properties
    • Go to Metadata tab.
    • Paste following code in HTML for head section. Click OK.
<style type="text/css"> html,body{ overflow-x:hidden; } </style>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 22, 2018 4
New Here ,
May 14, 2018

Copy link to clipboard

Copied

This worked perfectly. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
Explorer ,
Jul 14, 2020

Copy link to clipboard

Copied

2-3 hours to find this advice which fixed the issue in seconds. Thank you so much ...I can't tell you how grateful I am to you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 14, 2020 0