Highlighted

ERROR for site owner: Invalid domain for site key

Community Beginner ,
Oct 30, 2017

Copy link to clipboard

Copied

I need help fixing this error.

Here is what I did;

1. When I started, I was working on an existing website that had the captcha V1 on it.

2. Deleted captcha v1 and went to Google and got new keys for recaptcha v2.

3. Inserted the new form from the muse library in the same place that the old captcha was in. It is not in a lightbox.

4. Changed the old captcha v1 keys to recaptcha v2 keys (copied and pasted from Google)

5. I used Business Catalyst to look at the form and it worked great. Emails were sent perfectly to my email.

6. I changed my email to my client's email and saved my Muse site file as "save as HTML", and when it automatically opened in safari it had; "ERROR for site owner: Invalid domain for site key" where the box for the recaptcha v2 check mark should be. NOTE; I didn't open it, it automatically opened when I saved as HTML.

7. So, I went to google and got new keys and re-inserted the new keys in muse and it did the same thing.

8. Went to Google and checked the domain name url and it's my client website.

Question:

1. could it be that the error is showing because I haven't uploaded to a functioning website? Thinking that because it worked in Business catalyst.

2. is there a site that I can use to see if it works before publishing to the clients site?

3. is there something else that I'm not doing that I'm suppose to do?

Thanks in advance for quick reply.

Please try the solution mentioned here - reCAPTCHA 2.0 server error -- SOLVED

You can ask your web host tech support to check this setting in the PHP.INI file.  That file resides on the server, not on your computer.

Or, you can use your hosting service control panel to edit the PHP file yourself. 

If your host happens to use cPanel, you'll want to log on and look for the MultiPHP INI Editor. 

The first item is allow_url_fopen > set that to ON.

Also, make sure that the email ID you are using in the form is registered with your domain.

Views

18.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

ERROR for site owner: Invalid domain for site key

Community Beginner ,
Oct 30, 2017

Copy link to clipboard

Copied

I need help fixing this error.

Here is what I did;

1. When I started, I was working on an existing website that had the captcha V1 on it.

2. Deleted captcha v1 and went to Google and got new keys for recaptcha v2.

3. Inserted the new form from the muse library in the same place that the old captcha was in. It is not in a lightbox.

4. Changed the old captcha v1 keys to recaptcha v2 keys (copied and pasted from Google)

5. I used Business Catalyst to look at the form and it worked great. Emails were sent perfectly to my email.

6. I changed my email to my client's email and saved my Muse site file as "save as HTML", and when it automatically opened in safari it had; "ERROR for site owner: Invalid domain for site key" where the box for the recaptcha v2 check mark should be. NOTE; I didn't open it, it automatically opened when I saved as HTML.

7. So, I went to google and got new keys and re-inserted the new keys in muse and it did the same thing.

8. Went to Google and checked the domain name url and it's my client website.

Question:

1. could it be that the error is showing because I haven't uploaded to a functioning website? Thinking that because it worked in Business catalyst.

2. is there a site that I can use to see if it works before publishing to the clients site?

3. is there something else that I'm not doing that I'm suppose to do?

Thanks in advance for quick reply.

Please try the solution mentioned here - reCAPTCHA 2.0 server error -- SOLVED

You can ask your web host tech support to check this setting in the PHP.INI file.  That file resides on the server, not on your computer.

Or, you can use your hosting service control panel to edit the PHP file yourself. 

If your host happens to use cPanel, you'll want to log on and look for the MultiPHP INI Editor. 

The first item is allow_url_fopen > set that to ON.

Also, make sure that the email ID you are using in the form is registered with your domain.

Views

18.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 30, 2017 0
Oct 30, 2017

Copy link to clipboard

Copied

Hi Pete,

You are certainly right, the ReCaptcha will only work if it is uploaded on the domain which you got registered with Google.

However, why don't you try getting a key for your Business Catalyst trial site?

I just gave it a thought. Put your BC url in label and businesscatalyst.com under the domain.

Let me know if this works for you.

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2017 0
Community Beginner ,
Oct 30, 2017

Copy link to clipboard

Copied

Sorry, I forgot to mention that I'm not using BC for client's website. I'm using Network Solutions.

I will try uploading the new HTML files tonight and see if it works.

Let you know late tonight.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2017 1
Oct 31, 2017

Copy link to clipboard

Copied

Sure no worries, take your time.

Cheers,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2017 0
Community Beginner ,
Oct 31, 2017

Copy link to clipboard

Copied

hey ankush,

I uploaded the HTML files with the Recaptcha v2 to server and it all works fine except when i submit the form it gives me a "server encountered an error" message.

any ideas as to what to do?

thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2017 0
Nov 01, 2017

Copy link to clipboard

Copied

Please try the solution mentioned here - reCAPTCHA 2.0 server error -- SOLVED

You can ask your web host tech support to check this setting in the PHP.INI file.  That file resides on the server, not on your computer.

Or, you can use your hosting service control panel to edit the PHP file yourself. 

If your host happens to use cPanel, you'll want to log on and look for the MultiPHP INI Editor. 

The first item is allow_url_fopen > set that to ON.

Also, make sure that the email ID you are using in the form is registered with your domain.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 01, 2017 0