Highlighted

FTP in Muse - Mobile & Tablet - Error 404 when accessing the site with .html included in URL

New Here ,
Nov 02, 2017

Copy link to clipboard

Copied

Hi,

I'm uploading my website with the FTP mode in muse, then I can't access to the website in Mobile and Tablet ? It works for desktop

Someone can help ? I need to access after to my website with inbrowsereditiong, so I can't upload it with filezilla.

Seems to be a problem with the index file......


Thank you

HI,

So finally working a little on your Host panel we were able to find the root cause of the issue.

The reason why the site wasn't opening with .html because after exporting the site they are getting converted into .php automatically.

We manually entered into your 1 & 1 host's control panel.

Found that a small line has to be added to the .htaccess file to rectify the problem.

Found the solution....

"The .htaccess file Muse creates always misses one line "RewriteBase /"

so it should look like this:

<IfModule mod_rewrite.c>

RewriteEngine on

RewriteBase /

RewriteRule ^index.html$ index.php

(Rest otehr php pages )

</IfModule>

After adding that line, everything works just fine.

Hope this helps other's as well.

Regards,

Ankush

Views

869

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

FTP in Muse - Mobile & Tablet - Error 404 when accessing the site with .html included in URL

New Here ,
Nov 02, 2017

Copy link to clipboard

Copied

Hi,

I'm uploading my website with the FTP mode in muse, then I can't access to the website in Mobile and Tablet ? It works for desktop

Someone can help ? I need to access after to my website with inbrowsereditiong, so I can't upload it with filezilla.

Seems to be a problem with the index file......


Thank you

HI,

So finally working a little on your Host panel we were able to find the root cause of the issue.

The reason why the site wasn't opening with .html because after exporting the site they are getting converted into .php automatically.

We manually entered into your 1 & 1 host's control panel.

Found that a small line has to be added to the .htaccess file to rectify the problem.

Found the solution....

"The .htaccess file Muse creates always misses one line "RewriteBase /"

so it should look like this:

<IfModule mod_rewrite.c>

RewriteEngine on

RewriteBase /

RewriteRule ^index.html$ index.php

(Rest otehr php pages )

</IfModule>

After adding that line, everything works just fine.

Hope this helps other's as well.

Regards,

Ankush

Views

870

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 02, 2017 0
Nov 02, 2017

Copy link to clipboard

Copied

Hey damiend,

It will be very helpful if we can get your site URL for checking why particular phone and tablet layout aren't showing up.

I am sure this is something very simple and can be sorted.

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2017 1
Adobe Community Professional ,
Nov 03, 2017

Copy link to clipboard

Copied

It should work as I did a site for a client with adaptive layout as well and he is able to edit in inbrowserediting from tablet all three layouts. Please follow ankushr40215001​ ´s advice.

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2017 1
New Here ,
Nov 04, 2017

Copy link to clipboard

Copied

Hi,

Yes ! Here is the website : www.lauranspourlhomme.com

thank you very much for your help

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2017 0
Nov 06, 2017

Copy link to clipboard

Copied

Hey,

I am able to access the homepage on the phone, however as soon as I try to navigate to another page, it throws error 404.

So either your site is not uploaded properly or links used in your phone pages are not correct.

Can you try uploading the same site on the Business catalyst as a test and share the link with me?

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 0
New Here ,
Nov 07, 2017

Copy link to clipboard

Copied

Here is the link : Home Page

it doesn't work, I don't understand, I've done several websites, first time I have this kind of pb

Thanks for your help

Damien

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Nov 07, 2017

Copy link to clipboard

Copied

So I see that the Business Catalyst work perfect, meaning your file has no errors.

Its either some mistake at the host side.

Can you reach out to them or access the file panel > clear all files from there and re-upload the whole site?

Let me know how it goes.

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
New Here ,
Nov 07, 2017

Copy link to clipboard

Copied

I've uploaded again with Muse, still the same problem.

When I access to in Browser editing, it can't opened it as well : lauranspouurlhomme.com/pages/phone/index.html

Capture d’écran 2017-11-07 à 16.14.10.png

But if I put this adress : lauranspourlhomme.com/pages/phone/     I can access to the right page, so seems to be a problem with the Index.html ??

Capture d’écran 2017-11-07 à 16.13.55.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Nov 07, 2017

Copy link to clipboard

Copied

It has to do something with /index.html

How are you uploading your site (FTP, or HTML) and who is your site host?

Share a screenshot of page properties panel from the phone site's home page.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
New Here ,
Nov 07, 2017

Copy link to clipboard

Copied

if I upload it via Filezilla it works, but I need to upload it via MUSE to use In Browser Editing to give the access to the client

On the left the HTML export, on the right the files on the server export via FTP in Muse to use inBrowserediting :

Capture d’écran 2017-11-07 à 17.48.30.pngCapture d’écran 2017-11-07 à 17.48.30.png

Thanks !

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Nov 07, 2017

Copy link to clipboard

Copied

While you are uploading from Muse, do you put anything on "folder on server" field?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
New Here ,
Nov 07, 2017

Copy link to clipboard

Copied

No..... it's very strange

Capture d’écran 2017-11-07 à 18.10.43.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
New Here ,
Nov 07, 2017

Copy link to clipboard

Copied

no, just doing it via Muse.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
New Here ,
Nov 07, 2017

Copy link to clipboard

Copied

I mean, I upload it without putting a new folder on the server field

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Nov 07, 2017

Copy link to clipboard

Copied

Please put a "/" in this field and let me know how it goes!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
New Here ,
Nov 07, 2017

Copy link to clipboard

Copied

Just have done it, still the same problem

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Nov 07, 2017

Copy link to clipboard

Copied

I am guessing there is something, maybe an HTML code which is interrupting the upload process.

Can you please share your site with me?

You can upload it to either Dropbox or WeTransfer and share the link with me in a private message.

For doing a private message hover the mouse on my picture and click "message".

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Nov 07, 2017

Copy link to clipboard

Copied

HI,

So finally working a little on your Host panel we were able to find the root cause of the issue.

The reason why the site wasn't opening with .html because after exporting the site they are getting converted into .php automatically.

We manually entered into your 1 & 1 host's control panel.

Found that a small line has to be added to the .htaccess file to rectify the problem.

Found the solution....

"The .htaccess file Muse creates always misses one line "RewriteBase /"

so it should look like this:

<IfModule mod_rewrite.c>

RewriteEngine on

RewriteBase /

RewriteRule ^index.html$ index.php

(Rest otehr php pages )

</IfModule>

After adding that line, everything works just fine.

Hope this helps other's as well.

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 2
New Here ,
Jan 13, 2018

Copy link to clipboard

Copied

Hello Ankush:

I build websites and mobile sites in Adobe Muse. The classic website for icareassociates.com works fine, but I get a Site Not Found Error 404 message on a mobile phone. It looks like it switches to mobilewebsiteserver.com. Very strange.

​Can you help me with this? My email is kzierler@comcast.net.

I'm kind of new at this, but have built over 12 sites and never had this issue. Not even sure I would be able to fix it on  my own.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 13, 2018 0
uwep LATEST
New Here ,
Jun 07, 2018

Copy link to clipboard

Copied

thanks Ankush, it works fine.

This must be a bug in Muse which will never be corrected?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 07, 2018 0