Highlighted

Glyphs in web font

New Here ,
Sep 28, 2018

Copy link to clipboard

Copied

I am using a webfont (Aviano Black). Muse accepted it and offers glyphs. They show up in Preview and in Preview page in browser but not when I publish the site.

I don't even mind if it gets converted to an image - can I force it to do this?

It is on a spare url at present so you will see it if you want. www.tourconsultant.co.uk

Bit lost

Thanks

Did you definitely install the system font version of this from you web font package? If you use a different system font version, you will encounter problems. Best practice: Uninstall every version of the font (system version, web font instances) and only install you web font package Including the ttf/otf of this package.

If you want to force a text box being exported as an image, simply use a system font blank within it. This is enough to cause the font conversion.

Views

409

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Glyphs in web font

New Here ,
Sep 28, 2018

Copy link to clipboard

Copied

I am using a webfont (Aviano Black). Muse accepted it and offers glyphs. They show up in Preview and in Preview page in browser but not when I publish the site.

I don't even mind if it gets converted to an image - can I force it to do this?

It is on a spare url at present so you will see it if you want. www.tourconsultant.co.uk

Bit lost

Thanks

Did you definitely install the system font version of this from you web font package? If you use a different system font version, you will encounter problems. Best practice: Uninstall every version of the font (system version, web font instances) and only install you web font package Including the ttf/otf of this package.

If you want to force a text box being exported as an image, simply use a system font blank within it. This is enough to cause the font conversion.

Views

410

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 28, 2018 0
Adobe Community Professional ,
Sep 28, 2018

Copy link to clipboard

Copied

Did you install Aviano Black from Typekit? I was not able to find Aviano Black on Typekit:

Bildschirmfoto 2018-09-28 um 22.01.40.png

One of the common ways to install a webfont, look for WEBFONTS and ADD WEBFONTS+:

Bildschirmfoto 2018-09-28 um 21.59.52.png

You can choose between Typekit or EDGE WEB FONT or SELF HOSTED WEBFONTS.

Where did you fail?

Kind Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 28, 2018 0
New Here ,
Sep 28, 2018

Copy link to clipboard

Copied

It's not a Typekit Font, I installed it from Self Hosted Webfonts. I purchased the web version of the font so it is legitimate.

It installed fine and it added the font to the web fonts available, complete with glyphs. If I uninstall it I guess Muse will convert it to an image but then I don't have the font to use elsewhere.

I didn't realise there was a Typekit version - maybe that will do the job. The trouble is we used the font to sort of create a Logo of if it's not the same it might look odd.

I'll try though.

I'll let you know if it works

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 28, 2018 0
Adobe Community Professional ,
Sep 29, 2018

Copy link to clipboard

Copied

If there were three "checks" to confirm that your webfont was installed correctly, it should pretty much do the job.

You installed SVG, WOFF, and EOT?

Bildschirmfoto 2018-09-29 um 10.09.07.png

Kind Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 29, 2018 0
New Here ,
Sep 29, 2018

Copy link to clipboard

Copied

The files I have are woff, woff2 and eot. I can get the svg but didn't bother yet.

Muse / Typekit seems to have used the woff and the eot to install the font. i don't really know why it didn't use woff2 but I don't suppose that makes much difference.

I just realised that it's not just the glyphs, The wesite is not displaying the font at all.

Just to be clear - this is not the Aviano included in TYpekit which seems totally different from the one I have from 'Myfonts'.

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 29, 2018 0
Adobe Community Professional ,
Sep 29, 2018

Copy link to clipboard

Copied

Did you install via that window from my last Screenshot? As far as I experienced, you definitely need svg as well to have all three types installed. Muse shows fonts that are self hosted with svg, eot and woff. Woff 2 makes no difference, I guess. Tell us, how you installed the font. Yes, the Avian from Type kit is something different.

Kind Regards

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 29, 2018 0
Adobe Community Professional ,
Sep 29, 2018

Copy link to clipboard

Copied

You should have one folder inside your fonts folder with AVIANO BLACK with all types included.

You navigate to that folder from the BLUE BUTTON ON THE LEFT in my screenshot – may sound like SEARCH or similar .

Kind Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 29, 2018 0
New Here ,
Sep 29, 2018

Copy link to clipboard

Copied

Yes, I directed muse to the folder with all the font files in, it selected what to inatall.

Then I had to associate the webfont with the system font and everything seemed OK.

Thanks Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 29, 2018 0
New Here ,
Sep 29, 2018

Copy link to clipboard

Copied

I have uninstalled the font, downloaded and reinstalled it with the svg file.

I have republished the site.

No change! I haven't even been able to make an image out of the text becasue Photoshop doesn't seem to have all the glyphs I need to make up the logo. (that seems strange too).

Probably a swerword on this forum but I might have to make the text/image with Quark and save it as a png but that seems a bit extreme. there must be a better way. I just cannot see what I am missing or doing wrong!

thanks for you efforts

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 29, 2018 0
Adobe Community Professional ,
Sep 30, 2018

Copy link to clipboard

Copied

Now I only know THE wise guy Günter Heißenbüttel who hopefully chimes in here to help you. To create an image out of the font is the worst idea, I guess.

Kind Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 30, 2018 0
LEGEND ,
Sep 30, 2018

Copy link to clipboard

Copied

Did you definitely install the system font version of this from you web font package? If you use a different system font version, you will encounter problems. Best practice: Uninstall every version of the font (system version, web font instances) and only install you web font package Including the ttf/otf of this package.

If you want to force a text box being exported as an image, simply use a system font blank within it. This is enough to cause the font conversion.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 30, 2018 1
New Here ,
Oct 01, 2018

Copy link to clipboard

Copied

Possibly not at least not in the stricktest sense! I have owned this font for many years but only bought the web version a few months ago. the system font has been moved from machine to machine several times. I will do as you suggest and uninstall the lot and try again. However I will need the system version of the font reinstalled for dtp stuff and doesnt Muse need to 'match' the webfont with the system font anyway?

In the short term I did create a png of the Logo which is OKish for the moment.

Thanks for the help!

T

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 01, 2018 0