Highlighted

Hyperlinks not working in Muse 2017.1 update

Community Beginner ,
Aug 23, 2017

Copy link to clipboard

Copied

I just updated the new version (2017.1) of Muse, and upon opening my Muse file to make some changes to the site, I realised when previewing a page that the hyperlinks were not working. I then uploaded the site afresh and discovered hyperlinks are not working on the Desktop site, but are fine on the Mobile site.

Is this a bug related to the update? Any help would be much appreciated.

Daniel.

Dropbox worked!

The reason and the solution of your problem is simple.

When i look at the naming of your layers, I see, that you didn’t understand layering quite correctly. (You named one layer „page layer“, but there are no page layers in Muse!

To assure, that master page elements can be placed behind/before every other element, layers have to work site-wide, not page-wide. Elements on master page layers can be placed „above“ elements on layout page layers and vice versa. And exactly this happens on your site.

  • On your „homepage“ you have this text element containing names and links.
  • On your master page you have a big composition, which stretches up to 1440 px, and is logically placed „above“ the textframe on your „homepage“ – thus preventing, that the links below can be reached and activated.
  • Solution: Resize the composition on your master page or place the text box on you „homepage“ logically „above" the composition. Use the layers panel to do this.

Views

2.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Hyperlinks not working in Muse 2017.1 update

Community Beginner ,
Aug 23, 2017

Copy link to clipboard

Copied

I just updated the new version (2017.1) of Muse, and upon opening my Muse file to make some changes to the site, I realised when previewing a page that the hyperlinks were not working. I then uploaded the site afresh and discovered hyperlinks are not working on the Desktop site, but are fine on the Mobile site.

Is this a bug related to the update? Any help would be much appreciated.

Daniel.

Dropbox worked!

The reason and the solution of your problem is simple.

When i look at the naming of your layers, I see, that you didn’t understand layering quite correctly. (You named one layer „page layer“, but there are no page layers in Muse!

To assure, that master page elements can be placed behind/before every other element, layers have to work site-wide, not page-wide. Elements on master page layers can be placed „above“ elements on layout page layers and vice versa. And exactly this happens on your site.

  • On your „homepage“ you have this text element containing names and links.
  • On your master page you have a big composition, which stretches up to 1440 px, and is logically placed „above“ the textframe on your „homepage“ – thus preventing, that the links below can be reached and activated.
  • Solution: Resize the composition on your master page or place the text box on you „homepage“ logically „above" the composition. Use the layers panel to do this.

Views

2.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 23, 2017 1
Aug 23, 2017

Copy link to clipboard

Copied

Hey Daniel,

I would like to take a look at it.

Could you please share the URL of your site so I can have a look at it.

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2017 0
Community Beginner ,
Aug 23, 2017

Copy link to clipboard

Copied

Here we go: photooxford.org <http://photooxford.org/>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2017 0
LEGEND ,
Aug 23, 2017

Copy link to clipboard

Copied

Looks, the links are placed outside the visible area. On iPad, I only see a minimal section of the hamburger menu entries.

Could you please do the following:

Delete all content on all pages except the menu to reduce file size and isolate the issue. Please, take this seriously and provide the smallest possible file to show us the issue.

Now let us have a look at this .muse file by following these instructions: https://forums.adobe.com/docs/DOC-8652

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2017 1
Adobe Employee ,
Aug 23, 2017

Copy link to clipboard

Copied

The links are working just fine on my Chrome browser on windows. Can you provide us with more details to reproduce your issue?

Thanks,

Preran

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2017 0
Community Beginner ,
Aug 23, 2017

Copy link to clipboard

Copied

Here is the link to the .muse file: Adobe Creative Cloud

You can see on the Artists page that each person's name should be a hyperlink, but it is not functioning when I preview the page or upload it so it is live.

I am using Safari.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2017 0
Community Beginner ,
Aug 23, 2017

Copy link to clipboard

Copied

Yes the website doesn't view properly if the iPad is in landscape position. In portrait it should work well. I need to insert a new Breakpoint to fix this iPad landscape view issue...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2017 0
LEGEND ,
Aug 23, 2017

Copy link to clipboard

Copied

Unfortunately, the Creative Cloud file sharing doesn’t work at the moment. I noticed this all over the day with different files of different users,.

Preran​, may you please try, if the download of Daniel’s file works for you? If not, please inform someone, who is dealing with this matter.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2017 0
Adobe Employee ,
Aug 23, 2017

Copy link to clipboard

Copied

I get a message saying, "This page is unavailable"

Daniel Campbell Blight: Are you sure there are no problems with your upload?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2017 0
Community Beginner ,
Aug 23, 2017

Copy link to clipboard

Copied

Here is the .muse file on my Dropbox. I hope this is accessible to you: Dropbox - AdobeTroubleshooting-Photo-Oxford.muse

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2017 0
LEGEND ,
Aug 23, 2017

Copy link to clipboard

Copied

Dropbox worked!

The reason and the solution of your problem is simple.

When i look at the naming of your layers, I see, that you didn’t understand layering quite correctly. (You named one layer „page layer“, but there are no page layers in Muse!

To assure, that master page elements can be placed behind/before every other element, layers have to work site-wide, not page-wide. Elements on master page layers can be placed „above“ elements on layout page layers and vice versa. And exactly this happens on your site.

  • On your „homepage“ you have this text element containing names and links.
  • On your master page you have a big composition, which stretches up to 1440 px, and is logically placed „above“ the textframe on your „homepage“ – thus preventing, that the links below can be reached and activated.
  • Solution: Resize the composition on your master page or place the text box on you „homepage“ logically „above" the composition. Use the layers panel to do this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2017 0
Community Beginner ,
Aug 23, 2017

Copy link to clipboard

Copied

Thanks! Although, for some reason it won't let me resize the composition on my master page. When I click a corner to resize this rectangle it just pops back to its original place.

Second, if I undertake the second option and move each element of hyperlinked text on all pages to the top layer so the links are working, it means when a user clicks the menu the rectangle fade over from the master page doesn't work...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2017 0
Community Beginner ,
Aug 23, 2017

Copy link to clipboard

Copied

Additionally, if my current layers are the problem, why is it that the hyperlinks function perfectly well on the mobile version of the site? My issue is only on the desktop site, which seems very strange indeed...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2017 0
LEGEND ,
Aug 23, 2017

Copy link to clipboard

Copied

What do you expect? A compositions target can’t be smaller than the elements placed within. You have placed a rectangle into the target. Reduce its size first, then you can reduce the compositions width.

You can see, on which element you are working, if you have a look at the upper left corner of Muse’s application window. There is a label, showing, which element or which part of a widget is active at the moment.

By the way: Your links can’t be reached in both breakpoints.

Your sentence  "if I undertake the …, it means, …“ I really don’t understand.

And: Your site as is won’t never work properly on any mobile device. Pinning and scaling of the elements is in many cases completely wrong. Please have a deep look at it and read my answer here: https://forums.adobe.com/thread/2371995

And: Be aware, that compositions aren’t responsive on your site. You have to use the Muse version, published today, to obtain fully responsiveness.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2017 0
New Here ,
Aug 24, 2017

Copy link to clipboard

Copied

This solution works, but it doesn't resolve my problem. I have created a composition widget on my master page as my navigation for mobile devices. The composition can't be resized and must always be on top, so it overlaps links from my layout pages. When I place the links in front, it messes with my navigation (composition widget). Didn't have this problem in the previous version of Muse. Hopefully you have a solution for my problem, thank you!

Home

Products > links on layout pages mixed in my composition widget

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2017 2
Community Beginner ,
Aug 28, 2017

Copy link to clipboard

Copied

I have spent hours trying to solve this. I cannot see any other option other than there must be a bug in the new version of the software. Help Adobe! Your composition widget is broken.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 28, 2017 1
New Here ,
Aug 23, 2017

Copy link to clipboard

Copied

I am also experiencing the same problem since updating to 2017.1 - the site I've been working on and have applied hyperlinks to a page of text that were working fine, is now broken.  In Muse, it shows that the links are still applied (they're links to child pages of one of the site's main pages, so the links are in the "pagename:subpage" format, selected from the hyperlinks dropdown list).  Other places in the site where I've applied links to image frames or buttons, those are still working ok.. so it seems to be related to hyperlinks applied to text in my situation.  The site is not published yet and even if it were, it's our company's local intranet site - so I can't send you a link.  The site filesize is way over 20MB to upload to Creative Cloud, and Dropbox is blocked in our environment.  Is there any other way to get you a sample file?  If not I'll have to hope you can resolve this by seeing someone else's example as it's really thrown a wrench into the works here. Mainly wanted to add my +1 that I'm seeing the issue as well after the update.

Thank you,

Chris

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2017 1
New Here ,
Aug 23, 2017

Copy link to clipboard

Copied

It took me so long to compose my initial post that I hadn't seen your reply about layers - I went into my site and used Arrange/Bring to Front on the text box where the links were applied, and now the links are working again!  I think I can work through the issue wherever it pops up now; thanks for your help with Daniel's problem, as I think the same thing was happening to me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 23, 2017 1
LEGEND ,
Aug 28, 2017

Copy link to clipboard

Copied

I don't understand. I am quite sure, this is a design problem, no muse bug. Why can't the composition resized?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 28, 2017 0
Oct 18, 2017

Copy link to clipboard

Copied

The latest update to Muse is ready for download. This update addresses most of the issues reported since 2017.1. Please confirm these fixes as soon as you have had a chance to test them.

There is one new feature in the latest update, and it is a feature that will help you make a smooth transition to a next update allowing you to go back and use your files in a previous version of Muse in case it becomes necessary.

Automatic creation of a backup file after you convert files to the next version:

When you open an existing Adobe Muse file using the latest version of the application, file conversion takes place. Earlier, after the file conversion, when you saved your file, you were not able to open the file in an older version of Adobe Muse.

Now, when you open and save an existing file in Adobe Muse (2018.0), you see the following warning message:

If you click OK, a backup file is saved in the same location as your original file. You can use this backup file with the older versions of Adobe Muse.

Note: The backup file is created only for those files that are converted after you open the file using the latest version of Adobe Muse.

More details provided in this doc - https://helpx.adobe.com/muse/using/whats-new.html.

Thanks,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 18, 2017 0